[INFO] fetching crate idcoop 0.0.2... [INFO] documenting idcoop-0.0.2 against 1.99.0-beta.8 for beta-rustdoc-1.100-2 [INFO] extracting crate idcoop 0.0.2 into /workspace/builds/worker-2-tc1/source [INFO] started tweaking crates.io crate idcoop 0.0.2 [INFO] finished tweaking crates.io crate idcoop 0.0.2 [INFO] tweaked toml for crates.io crate idcoop 0.0.2 written to /workspace/builds/worker-2-tc1/source/Cargo.toml [INFO] validating manifest of crates.io crate idcoop 0.0.2 on toolchain 1.99.0-beta.8 [INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" "/workspace/cargo-home/bin/cargo" "+1.99.0-beta.8" "metadata" "--manifest-path" "Cargo.toml" "--no-deps", kill_on_drop: false }` [INFO] crate crates.io crate idcoop 0.0.2 already has a lockfile, it will not be regenerated [INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" "/workspace/cargo-home/bin/cargo" "+1.99.0-beta.8" "fetch" "--manifest-path" "Cargo.toml", kill_on_drop: false }` [INFO] [stderr] Updating crates.io index [INFO] [stderr] Blocking waiting for file lock on package cache [INFO] [stderr] Downloading crates ... [INFO] [stderr] Downloaded socket2 v0.5.9 [INFO] [stderr] Downloaded tower-cookies v0.11.0 [INFO] [stderr] Downloaded axum-core v0.5.2 [INFO] [stderr] Downloaded errno v0.3.11 [INFO] [stderr] Downloaded windows-strings v0.4.0 [INFO] [stderr] Downloaded windows-result v0.3.2 [INFO] [stderr] Downloaded icu_properties v2.0.0 [INFO] [stderr] Downloaded windows-core v0.61.0 [INFO] [stderr] Downloaded cc v1.2.22 [INFO] [stderr] Downloaded icu_properties_data v2.0.0 [INFO] [stderr] Downloaded rstest v0.21.0 [INFO] [stderr] Downloaded toml_write v0.1.1 [INFO] [stderr] Downloaded tokio v1.45.0 [INFO] [stderr] Downloaded rstest_macros v0.21.0 [INFO] [stderr] Downloaded relative-path v1.9.3 [INFO] [stderr] Downloaded futures-timer v3.0.3 [INFO] [stderr] Downloaded pgtemp v0.3.0 [INFO] [stderr] Downloaded metrics-process v1.2.1 [INFO] [stderr] Downloaded rlimit v0.10.2 [INFO] [stderr] Downloaded procfs v0.16.0 [INFO] [stderr] Downloaded procfs-core v0.16.0 [INFO] [stderr] Downloaded metrics v0.22.4 [INFO] [stderr] Downloaded libproc v0.14.10 [INFO] [stderr] Downloaded libloading v0.8.7 [INFO] [stderr] Downloaded metrics-exporter-prometheus v0.12.2 [INFO] [stderr] Downloaded quanta v0.11.1 [INFO] [stderr] Downloaded raw-cpuid v10.7.0 [INFO] [stderr] Downloaded metrics-util v0.15.1 [INFO] [stderr] Downloaded sketches-ddsketch v0.2.2 [INFO] [stderr] Downloaded metrics v0.21.1 [INFO] [stderr] Downloaded metrics-macros v0.7.1 [INFO] [stderr] Downloaded hashbrown v0.13.1 [INFO] [stderr] Downloaded hornbeam v0.0.5 [INFO] [stderr] Downloaded josekit v0.8.7 [INFO] [stderr] Downloaded insta v1.43.1 [INFO] [stderr] Downloaded notify v5.2.0 [INFO] [stderr] Downloaded kqueue v1.1.1 [INFO] [stderr] Downloaded fluent-templates v0.8.0 [INFO] [stderr] Downloaded governor v0.6.3 [INFO] [stderr] Downloaded bevy_reflect v0.14.2 [INFO] [stderr] Downloaded snafu-derive v0.7.5 [INFO] [stderr] Downloaded pest_consume_macros v1.1.0 [INFO] [stderr] Downloaded arc-interner v0.7.0 [INFO] [stderr] Downloaded ahash v0.3.8 [INFO] [stderr] Downloaded hornbeam_ir v0.0.5 [INFO] [stderr] Downloaded bevy_reflect_derive v0.14.2 [INFO] [stderr] Downloaded no-std-compat v0.4.1 [INFO] [stderr] Downloaded toml v0.8.22 [INFO] [stderr] Downloaded erased-serde v0.4.6 [INFO] [stderr] Downloaded intl-memoizer v0.5.2 [INFO] [stderr] Downloaded fluent v0.16.1 [INFO] [stderr] Downloaded matchit v0.8.4 [INFO] [stderr] Downloaded unic-langid-macros-impl v0.9.6 [INFO] [stderr] Downloaded nonzero_ext v0.3.0 [INFO] [stderr] Downloaded formbeam v0.0.5 [INFO] [stderr] Downloaded bevy_utils v0.14.2 [INFO] [stderr] Downloaded utf8-width v0.1.7 [INFO] [stderr] Downloaded pest_meta v2.8.0 [INFO] [stderr] Downloaded bevy_ptr v0.14.2 [INFO] [stderr] Downloaded unic-langid-macros v0.9.6 [INFO] [stderr] Downloaded fluent-template-macros v0.8.0 [INFO] [stderr] Downloaded fluent-syntax v0.11.1 [INFO] [stderr] Downloaded fluent-langneg v0.13.0 [INFO] [stderr] Downloaded indenter v0.3.3 [INFO] [stderr] Downloaded confique-macro v0.0.10 [INFO] [stderr] Downloaded rust-multipart-rfc7578_2 v0.8.0 [INFO] [stderr] Downloaded expect-json-macros v1.0.0 [INFO] [stderr] Downloaded inotify v0.9.6 [INFO] [stderr] Downloaded hornbeam_interpreter v0.0.5 [INFO] [stderr] Downloaded hornbeam_grammar v0.0.5 [INFO] [stderr] Downloaded pest_derive v2.8.0 [INFO] [stderr] Downloaded pest_generator v2.8.0 [INFO] [stderr] Downloaded pest_consume v1.1.3 [INFO] [stderr] Downloaded dashmap v4.0.2 [INFO] [stderr] Downloaded bevy_utils_proc_macros v0.14.2 [INFO] [stderr] Downloaded bevy_macro_utils v0.14.2 [INFO] [stderr] Downloaded ignore v0.4.23 [INFO] [stderr] Downloaded fluent-bundle v0.15.3 [INFO] [stderr] Downloaded self_cell v0.10.3 [INFO] [stderr] Downloaded hyper-util v0.1.11 [INFO] [stderr] Downloaded formbeam_derive v0.0.5 [INFO] [stderr] Downloaded axum-test v18.0.0-rc3 [INFO] [stderr] Downloaded reserve-port v2.2.0 [INFO] [stderr] Downloaded typetag-impl v0.2.20 [INFO] [stderr] Downloaded headers-core v0.3.0 [INFO] [stderr] Downloaded axum-client-ip v0.7.0 [INFO] [stderr] Downloaded forwarded-header-value v0.1.1 [INFO] [stderr] Downloaded nonempty v0.7.0 [INFO] [stderr] Downloaded filetime v0.2.25 [INFO] [stderr] Downloaded html-escape v0.2.13 [INFO] [stderr] Downloaded snafu v0.7.5 [INFO] [stderr] Downloaded doc-comment v0.3.3 [INFO] [stderr] Downloaded type-map v0.5.0 [INFO] [stderr] Downloaded axum-macros v0.5.0 [INFO] [stderr] Downloaded quanta v0.12.5 [INFO] [stderr] Downloaded confique v0.2.6 [INFO] [stderr] Downloaded typetag v0.2.20 [INFO] [stderr] Downloaded inventory v0.3.20 [INFO] [stderr] Downloaded email_address v0.2.9 [INFO] [stderr] Downloaded bytesize v2.0.1 [INFO] [stderr] Downloaded assert_matches2 v0.1.2 [INFO] [stderr] Downloaded globset v0.4.16 [INFO] [stderr] Downloaded clap v4.5.38 [INFO] [stderr] Downloaded flume v0.10.14 [INFO] [stderr] Downloaded spinning_top v0.3.0 [INFO] [stderr] Downloaded raw-cpuid v11.5.0 [INFO] [stderr] Downloaded expect-json v1.0.0 [INFO] [stderr] Downloaded axum-extra v0.10.1 [INFO] [stderr] Downloaded headers v0.4.0 [INFO] [stderr] Downloaded comfy-table v7.1.4 [INFO] [stderr] Downloaded pest v2.8.0 [INFO] [stderr] Downloaded clap_builder v4.5.38 [INFO] [stderr] Downloaded axum v0.8.4 [INFO] [stderr] Downloaded bstr v1.12.0 [INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-2-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-2-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-m" "1610612736" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:77db811e55d90add9212f6832c23229e3de5f1c1f9905e8cb07319ea15df73ac" "sleep" "infinity", kill_on_drop: false }` [INFO] [stdout] 6f233f5b46e5d7485f96a862f7deb74fa56c9e386235beb3bd8a106ea1ba29d6 [INFO] running `Command { std: "docker" "start" "6f233f5b46e5d7485f96a862f7deb74fa56c9e386235beb3bd8a106ea1ba29d6", kill_on_drop: false }` [INFO] running `Command { std: "docker" "inspect" "6f233f5b46e5d7485f96a862f7deb74fa56c9e386235beb3bd8a106ea1ba29d6", kill_on_drop: false }` [INFO] running `Command { std: "docker" "exec" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-w" "/opt/rustwide/workdir" "--user" "0:0" "6f233f5b46e5d7485f96a862f7deb74fa56c9e386235beb3bd8a106ea1ba29d6" "/opt/rustwide/cargo-home/bin/cargo" "+1.99.0-beta.8" "metadata" "--no-deps" "--format-version=1", kill_on_drop: false }` [INFO] running `Command { std: "docker" "inspect" "6f233f5b46e5d7485f96a862f7deb74fa56c9e386235beb3bd8a106ea1ba29d6", kill_on_drop: false }` [INFO] running `Command { std: "docker" "exec" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTFLAGS=--cap-lints=warn" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-w" "/opt/rustwide/workdir" "--user" "0:0" "6f233f5b46e5d7485f96a862f7deb74fa56c9e386235beb3bd8a106ea1ba29d6" "/opt/rustwide/cargo-home/bin/cargo" "+1.99.0-beta.8" "doc" "--frozen" "--no-deps" "--document-private-items" "--message-format=json", kill_on_drop: false }` [INFO] [stderr] Compiling libc v0.2.172 [INFO] [stderr] Compiling serde v1.0.219 [INFO] [stderr] Compiling stable_deref_trait v1.2.0 [INFO] [stderr] Checking smallvec v1.15.0 [INFO] [stderr] Compiling lock_api v0.4.12 [INFO] [stderr] Compiling ahash v0.8.12 [INFO] [stderr] Compiling once_cell v1.21.3 [INFO] [stderr] Compiling zerofrom v0.1.6 [INFO] [stderr] Checking tracing-core v0.1.33 [INFO] [stderr] Compiling parking_lot_core v0.9.10 [INFO] [stderr] Compiling crossbeam-utils v0.8.21 [INFO] [stderr] Compiling cc v1.2.22 [INFO] [stderr] Checking tinystr v0.8.1 [INFO] [stderr] Compiling icu_properties_data v2.0.0 [INFO] [stderr] Checking futures-util v0.3.31 [INFO] [stderr] Compiling syn v1.0.109 [INFO] [stderr] Compiling tokio-macros v2.5.0 [INFO] [stderr] Compiling yoke v0.8.0 [INFO] [stderr] Checking bitflags v2.9.0 [INFO] [stderr] Checking hashbrown v0.15.3 [INFO] [stderr] Compiling num-traits v0.2.19 [INFO] [stderr] Checking subtle v2.6.1 [INFO] [stderr] Compiling typenum v1.18.0 [INFO] [stderr] Compiling zerovec v0.11.2 [INFO] [stderr] Compiling thiserror v2.0.12 [INFO] [stderr] Compiling openssl v0.10.72 [INFO] [stderr] Compiling proc-macro-hack v0.5.20+deprecated [INFO] [stderr] Checking tracing v0.1.41 [INFO] [stderr] Checking digest v0.10.7 [INFO] [stderr] Compiling thiserror-impl v2.0.12 [INFO] [stderr] Compiling openssl-macros v0.1.1 [INFO] [stderr] Compiling serde_json v1.0.140 [INFO] [stderr] Compiling litemap v0.8.0 [INFO] [stderr] Compiling writeable v0.6.1 [INFO] [stderr] Checking indexmap v2.9.0 [INFO] [stderr] Compiling unicode-segmentation v1.12.0 [INFO] [stderr] Compiling zerotrie v0.2.2 [INFO] [stderr] Compiling zerocopy v0.8.25 [INFO] [stderr] Compiling crunchy v0.2.3 [INFO] [stderr] Checking unic-langid-impl v0.9.6 [INFO] [stderr] Checking aho-corasick v1.1.3 [INFO] [stderr] Checking regex-syntax v0.8.5 [INFO] [stderr] Checking getrandom v0.3.3 [INFO] [stderr] Checking socket2 v0.5.9 [INFO] [stderr] Checking mio v1.0.3 [INFO] [stderr] Compiling getrandom v0.2.16 [INFO] [stderr] Compiling generic-array v0.14.7 [INFO] [stderr] Compiling uuid v1.16.0 [INFO] [stderr] Compiling tiny-keccak v2.0.2 [INFO] [stderr] Checking icu_locale_core v2.0.0 [INFO] [stderr] Checking tokio v1.45.0 [INFO] [stderr] Compiling potential_utf v0.1.2 [INFO] [stderr] Checking form_urlencoded v1.2.1 [INFO] [stderr] Compiling icu_normalizer_data v2.0.0 [INFO] [stderr] Compiling futures-core v0.3.31 [INFO] [stderr] Compiling icu_collections v2.0.0 [INFO] [stderr] Compiling ucd-trie v0.1.7 [INFO] [stderr] Compiling pin-project-lite v0.2.16 [INFO] [stderr] Checking rand_core v0.6.4 [INFO] [stderr] Compiling pest v2.8.0 [INFO] [stderr] Checking parking_lot v0.12.3 [INFO] [stderr] Compiling openssl-sys v0.9.108 [INFO] [stderr] Compiling heck v0.4.1 [INFO] [stderr] Checking num_cpus v1.16.0 [INFO] [stderr] Compiling unic-langid-macros-impl v0.9.6 [INFO] [stderr] Compiling foreign-types-shared v0.1.1 [INFO] [stderr] Compiling rustversion v1.0.20 [INFO] [stderr] Compiling block-buffer v0.10.4 [INFO] [stderr] Compiling crypto-common v0.1.6 [INFO] [stderr] Checking icu_provider v2.0.0 [INFO] [stderr] Compiling foreign-types v0.3.2 [INFO] [stderr] Compiling const-random-macro v0.1.16 [INFO] [stderr] Checking unic-langid-macros v0.9.6 [INFO] [stderr] Compiling native-tls v0.2.14 [INFO] [stderr] Checking unic-langid v0.9.6 [INFO] [stderr] Checking crossbeam-epoch v0.9.18 [INFO] [stderr] Checking rustc-hash v1.1.0 [INFO] [stderr] Compiling futures-sink v0.3.31 [INFO] [stderr] Compiling minimal-lexical v0.2.1 [INFO] [stderr] Compiling bytes v1.10.1 [INFO] [stderr] Compiling allocator-api2 v0.2.21 [INFO] [stderr] Compiling icu_normalizer v2.0.0 [INFO] [stderr] Compiling icu_properties v2.0.0 [INFO] [stderr] Checking regex-automata v0.4.9 [INFO] [stderr] Compiling pest_meta v2.8.0 [INFO] [stderr] Compiling hashbrown v0.14.5 [INFO] [stderr] Compiling ppv-lite86 v0.2.21 [INFO] [stderr] Checking either v1.15.0 [INFO] [stderr] Compiling nom v7.1.3 [INFO] [stderr] Checking type-map v0.5.0 [INFO] [stderr] Compiling tinyvec v1.9.0 [INFO] [stderr] Compiling idna_adapter v1.2.1 [INFO] [stderr] Compiling idna v1.0.3 [INFO] [stderr] Compiling pest_generator v2.8.0 [INFO] [stderr] Checking const-random v0.1.18 [INFO] [stderr] Compiling slab v0.4.9 [INFO] [stderr] Compiling bstr v1.12.0 [INFO] [stderr] Checking thread_local v1.1.8 [INFO] [stderr] Compiling openssl-probe v0.1.6 [INFO] [stderr] Compiling itoa v1.0.15 [INFO] [stderr] Checking self_cell v1.2.0 [INFO] [stderr] Compiling doc-comment v0.3.3 [INFO] [stderr] Checking same-file v1.0.6 [INFO] [stderr] Compiling unicode_categories v0.1.1 [INFO] [stderr] Compiling futures-task v0.3.31 [INFO] [stderr] Compiling iana-time-zone v0.1.63 [INFO] [stderr] Compiling ryu v1.0.20 [INFO] [stderr] Compiling rustix v0.38.44 [INFO] [stderr] Compiling crc-catalog v2.4.0 [INFO] [stderr] Compiling rustix v1.0.7 [INFO] [stderr] Compiling futures-io v0.3.31 [INFO] [stderr] Compiling cpufeatures v0.2.17 [INFO] [stderr] Compiling crc v3.3.0 [INFO] [stderr] Compiling pest_derive v2.8.0 [INFO] [stderr] Compiling sha2 v0.10.9 [INFO] [stderr] Compiling chrono v0.4.41 [INFO] [stderr] Checking walkdir v2.5.0 [INFO] [stderr] Checking self_cell v0.10.3 [INFO] [stderr] Checking regex v1.11.1 [INFO] [stderr] Compiling crossbeam-deque v0.8.6 [INFO] [stderr] Compiling pest_consume_macros v1.1.0 [INFO] [stderr] Compiling rand_chacha v0.3.1 [INFO] [stderr] Compiling sqlformat v0.2.6 [INFO] [stderr] Checking axum-core v0.5.2 [INFO] [stderr] Compiling url v2.5.4 [INFO] [stderr] Compiling unicode-normalization v0.1.24 [INFO] [stderr] Checking ahash v0.3.8 [INFO] [stderr] Compiling futures-intrusive v0.5.0 [INFO] [stderr] Compiling hashlink v0.8.4 [INFO] [stderr] Compiling bevy_macro_utils v0.14.2 [INFO] [stderr] Checking hyper v1.6.0 [INFO] [stderr] Checking intl-memoizer v0.5.2 [INFO] [stderr] Compiling atoi v2.0.0 [INFO] [stderr] Compiling futures-channel v0.3.31 [INFO] [stderr] Checking fluent-langneg v0.13.0 [INFO] [stderr] Checking intl_pluralrules v7.0.2 [INFO] [stderr] Compiling hmac v0.12.1 [INFO] [stderr] Checking dashmap v4.0.2 [INFO] [stderr] Compiling crossbeam-queue v0.3.12 [INFO] [stderr] Compiling spin v0.9.8 [INFO] [stderr] Checking fluent-syntax v0.11.1 [INFO] [stderr] Compiling thiserror v1.0.69 [INFO] [stderr] Compiling bevy_utils_proc_macros v0.14.2 [INFO] [stderr] Checking web-time v1.1.0 [INFO] [stderr] Compiling hex v0.4.3 [INFO] [stderr] Compiling unicode-bidi v0.3.18 [INFO] [stderr] Compiling event-listener v2.5.3 [INFO] [stderr] Compiling linux-raw-sys v0.9.4 [INFO] [stderr] Compiling unicode-properties v0.1.3 [INFO] [stderr] Compiling num-conv v0.1.0 [INFO] [stderr] Compiling time-core v0.1.4 [INFO] [stderr] Compiling globset v0.4.16 [INFO] [stderr] Compiling byteorder v1.5.0 [INFO] [stderr] Compiling time-macros v0.2.22 [INFO] [stderr] Compiling stringprep v0.1.5 [INFO] [stderr] Compiling ignore v0.4.23 [INFO] [stderr] Checking deranged v0.4.0 [INFO] [stderr] Checking fluent-bundle v0.15.3 [INFO] [stderr] Checking bevy_utils v0.14.2 [INFO] [stderr] Checking hyper-util v0.1.11 [INFO] [stderr] Checking arc-interner v0.7.0 [INFO] [stderr] Compiling flume v0.10.14 [INFO] [stderr] Compiling hkdf v0.12.4 [INFO] [stderr] Compiling bevy_reflect_derive v0.14.2 [INFO] [stderr] Checking erased-serde v0.4.6 [INFO] [stderr] Checking pest_consume v1.1.3 [INFO] [stderr] Checking tower v0.5.2 [INFO] [stderr] Compiling rand v0.8.5 [INFO] [stderr] Compiling snafu-derive v0.7.5 [INFO] [stderr] Compiling tokio-stream v0.1.17 [INFO] [stderr] Checking serde_urlencoded v0.7.1 [INFO] [stderr] Checking serde_path_to_error v0.1.17 [INFO] [stderr] Compiling md-5 v0.10.6 [INFO] [stderr] Compiling axum-macros v0.5.0 [INFO] [stderr] Checking bevy_ptr v0.14.2 [INFO] [stderr] Compiling dotenvy v0.15.7 [INFO] [stderr] Checking utf8-width v0.1.7 [INFO] [stderr] Compiling fastrand v2.3.0 [INFO] [stderr] Checking matchit v0.8.4 [INFO] [stderr] Compiling home v0.5.11 [INFO] [stderr] Compiling unicase v2.8.1 [INFO] [stderr] Compiling base64 v0.21.7 [INFO] [stderr] Compiling whoami v1.6.0 [INFO] [stderr] Compiling mime_guess v2.0.5 [INFO] [stderr] Compiling fluent-template-macros v0.8.0 [INFO] [stderr] Checking html-escape v0.2.13 [INFO] [stderr] Checking time v0.3.41 [INFO] [stderr] Compiling tempfile v3.20.0 [INFO] [stderr] Checking anstyle-parse v0.2.6 [INFO] [stderr] Checking fluent v0.16.1 [INFO] [stderr] Checking hornbeam_grammar v0.0.5 [INFO] [stderr] Checking itertools v0.10.5 [INFO] [stderr] Checking toml_datetime v0.6.9 [INFO] [stderr] Checking serde_spanned v0.6.8 [INFO] [stderr] Checking raw-cpuid v10.7.0 [INFO] [stderr] Checking inotify-sys v0.1.5 [INFO] [stderr] Compiling metrics-macros v0.7.1 [INFO] [stderr] Compiling cookie v0.18.1 [INFO] [stderr] Compiling indexmap v1.9.3 [INFO] [stderr] Checking bevy_reflect v0.14.2 [INFO] [stderr] Checking axum v0.8.4 [INFO] [stderr] Checking colorchoice v1.0.3 [INFO] [stderr] Checking anstyle v1.0.10 [INFO] [stderr] Checking snafu v0.7.5 [INFO] [stderr] Checking winnow v0.7.10 [INFO] [stderr] Compiling anyhow v1.0.98 [INFO] [stderr] Checking anstyle-query v1.1.2 [INFO] [stderr] Compiling portable-atomic v1.11.0 [INFO] [stderr] Checking is_terminal_polyfill v1.70.1 [INFO] [stderr] Checking regex-syntax v0.6.29 [INFO] [stderr] Compiling procfs v0.16.0 [INFO] [stderr] Checking toml_write v0.1.1 [INFO] [stderr] Compiling sqlx-core v0.7.4 [INFO] [stderr] Checking miniz_oxide v0.8.8 [INFO] [stderr] Checking anstream v0.6.18 [INFO] [stderr] Checking fluent-templates v0.8.0 [INFO] [stderr] Checking metrics v0.21.1 [INFO] [stderr] Checking quanta v0.11.1 [INFO] [stderr] Checking inotify v0.9.6 [INFO] [stderr] Checking procfs-core v0.16.0 [INFO] [stderr] Checking futures-executor v0.3.31 [INFO] [stderr] Checking sha1 v0.10.6 [INFO] [stderr] Checking hashbrown v0.13.1 [INFO] [stderr] Compiling heck v0.3.3 [INFO] [stderr] Checking mio v0.8.11 [INFO] [stderr] Checking filetime v0.2.25 [INFO] [stderr] Checking crossbeam-channel v0.5.15 [INFO] [stderr] Checking headers-core v0.3.0 [INFO] [stderr] Checking raw-cpuid v11.5.0 [INFO] [stderr] Compiling async-recursion v1.1.1 [INFO] [stderr] Checking overload v0.1.1 [INFO] [stderr] Checking base64ct v1.7.3 [INFO] [stderr] Checking clap_lex v0.7.4 [INFO] [stderr] Compiling eyre v0.6.12 [INFO] [stderr] Checking nonempty v0.7.0 [INFO] [stderr] Checking hornbeam_ir v0.0.5 [INFO] [stderr] Checking hashbrown v0.12.3 [INFO] [stderr] Checking sketches-ddsketch v0.2.2 [INFO] [stderr] Checking forwarded-header-value v0.1.1 [INFO] [stderr] Checking password-hash v0.5.0 [INFO] [stderr] Checking notify v5.2.0 [INFO] [stderr] Checking clap_builder v4.5.38 [INFO] [stderr] Compiling clap_derive v4.5.32 [INFO] [stderr] Checking metrics-util v0.15.1 [INFO] [stderr] Checking headers v0.4.0 [INFO] [stderr] Checking nu-ansi-term v0.46.0 [INFO] [stderr] Compiling confique-macro v0.0.10 [INFO] [stderr] Checking flate2 v1.1.1 [INFO] [stderr] Checking regex-automata v0.1.10 [INFO] [stderr] Checking toml_edit v0.22.26 [INFO] [stderr] Checking futures v0.3.31 [INFO] [stderr] Checking crossterm v0.28.1 [INFO] [stderr] Checking hyper v0.14.32 [INFO] [stderr] Checking tokio-util v0.7.15 [INFO] [stderr] Checking dashmap v5.5.3 [INFO] [stderr] Checking metrics v0.22.4 [INFO] [stderr] Checking matchers v0.1.0 [INFO] [stderr] Checking blake2 v0.10.6 [INFO] [stderr] Checking tracing-log v0.2.0 [INFO] [stderr] Checking spinning_top v0.3.0 [INFO] [stderr] Compiling idcoop v0.0.2 (/opt/rustwide/workdir) [INFO] [stderr] Checking futures-timer v3.0.3 [INFO] [stderr] Checking indenter v0.3.3 [INFO] [stderr] Checking nonzero_ext v0.3.0 [INFO] [stderr] Checking http-range-header v0.4.2 [INFO] [stderr] Checking quanta v0.12.5 [INFO] [stderr] Checking unicode-width v0.2.0 [INFO] [stderr] Checking no-std-compat v0.4.1 [INFO] [stderr] Checking josekit v0.8.7 [INFO] [stderr] Checking argon2 v0.5.3 [INFO] [stderr] Checking tower-http v0.6.4 [INFO] [stderr] Checking tracing-subscriber v0.3.19 [INFO] [stderr] Checking governor v0.6.3 [INFO] [stderr] Checking comfy-table v7.1.4 [INFO] [stderr] Checking tower-cookies v0.11.0 [INFO] [stderr] Checking rand_xoshiro v0.6.0 [INFO] [stderr] Compiling formbeam_derive v0.0.5 [INFO] [stderr] Checking toml v0.8.22 [INFO] [stderr] Checking clap v4.5.38 [INFO] [stderr] Compiling sqlx-postgres v0.7.4 [INFO] [stderr] Checking confique v0.2.6 [INFO] [stderr] Checking formbeam v0.0.5 [INFO] [stderr] Checking hornbeam_interpreter v0.0.5 [INFO] [stderr] Checking axum-client-ip v0.7.0 [INFO] [stderr] Checking axum-extra v0.10.1 [INFO] [stderr] Checking metrics-process v1.2.1 [INFO] [stderr] Checking hornbeam v0.0.5 [INFO] [stderr] Checking metrics-exporter-prometheus v0.12.2 [INFO] [stderr] Compiling sqlx-macros-core v0.7.4 [INFO] [stderr] Compiling sqlx-macros v0.7.4 [INFO] [stderr] Checking sqlx v0.7.4 [INFO] [stderr] Documenting idcoop v0.0.2 (/opt/rustwide/workdir) [INFO] [stdout] warning: unresolved link to `RFC3986` [INFO] [stdout] --> src/web/oauth_openid/authorisation.rs:56:71 [INFO] [stdout] | [INFO] [stdout] 56 | /// with the matching performed as described in Section 6.2.1 of [RFC3986] (Simple String Comparison). [INFO] [stdout] | ^^^^^^^ no item named `RFC3986` in scope [INFO] [stdout] | [INFO] [stdout] = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]` [INFO] [stdout] = note: `#[warn(rustdoc::broken_intra_doc_links)]` on by default [INFO] [stdout] [INFO] [stdout] [INFO] [stdout] warning: unresolved link to `RFC3339` [INFO] [stdout] --> src/web/oauth_openid/token.rs:453:23 [INFO] [stdout] | [INFO] [stdout] 453 | /// See RFC 3339 [RFC3339] for details regarding date/times in general and UTC in particular. [INFO] [stdout] | ^^^^^^^ no item named `RFC3339` in scope [INFO] [stdout] | [INFO] [stdout] = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]` [INFO] [stdout] [INFO] [stdout] [INFO] [stdout] warning: unresolved link to `JWK` [INFO] [stdout] --> src/web/oauth_openid.rs:75:53 [INFO] [stdout] | [INFO] [stdout] 75 | /// REQUIRED. URL of the OP's JSON Web Key Set [JWK] document. [INFO] [stdout] | ^^^ no item named `JWK` in scope [INFO] [stdout] | [INFO] [stdout] = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]` [INFO] [stdout] [INFO] [stdout] [INFO] [stdout] warning: unresolved link to `RFC6749` [INFO] [stdout] --> src/web/oauth_openid.rs:86:69 [INFO] [stdout] | [INFO] [stdout] 86 | /// RECOMMENDED. JSON array containing a list of the OAuth 2.0 [RFC6749] scope values that this server supports [INFO] [stdout] | ^^^^^^^ no item named `RFC6749` in scope [INFO] [stdout] | [INFO] [stdout] = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]` [INFO] [stdout] [INFO] [stdout] [INFO] [stdout] warning: unresolved link to `JWT` [INFO] [stdout] --> src/web/oauth_openid.rs:107:159 [INFO] [stdout] | [INFO] [stdout] 107 | ...for the ID Token to encode the Claims in a JWT [JWT]. [INFO] [stdout] | ^^^ no item named `JWT` in scope [INFO] [stdout] | [INFO] [stdout] = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]` [INFO] [stdout] [INFO] [stdout] [INFO] [stdout] warning: this URL is not a hyperlink [INFO] [stdout] --> src/web/oauth_openid/authorisation.rs:501:16 [INFO] [stdout] | [INFO] [stdout] 501 | /// OAuth 2.1: https://datatracker.ietf.org/doc/html/draft-ietf-oauth-v2-1-09#name-error-response-2 [INFO] [stdout] | ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ [INFO] [stdout] | [INFO] [stdout] = note: bare URLs are not automatically turned into clickable links [INFO] [stdout] = note: `#[warn(rustdoc::bare_urls)]` on by default [INFO] [stdout] help: use an automatic link instead [INFO] [stdout] | [INFO] [stdout] 501 | /// OAuth 2.1: [INFO] [stdout] | + + [INFO] [stdout] [INFO] [stdout] [INFO] [stdout] warning: this URL is not a hyperlink [INFO] [stdout] --> src/web/oauth_openid/authorisation.rs:504:26 [INFO] [stdout] | [INFO] [stdout] 504 | /// OpenID Connect Core: https://openid.net/specs/openid-connect-core-1_0.html#AuthError [INFO] [stdout] | ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ [INFO] [stdout] | [INFO] [stdout] = note: bare URLs are not automatically turned into clickable links [INFO] [stdout] help: use an automatic link instead [INFO] [stdout] | [INFO] [stdout] 504 | /// OpenID Connect Core: [INFO] [stdout] | + + [INFO] [stdout] [INFO] [stdout] [INFO] [stderr] Finished `dev` profile [unoptimized + debuginfo] target(s) in 1m 58s [INFO] [stderr] warning: the following packages contain code that will be rejected by a future version of Rust: sqlx-postgres v0.7.4 [INFO] [stderr] note: to see what the problems were, use the option `--future-incompat-report`, or run `cargo report future-incompatibilities --id 5` [INFO] [stderr] Generated /opt/rustwide/target/doc/idcoop/index.html [INFO] running `Command { std: "docker" "inspect" "6f233f5b46e5d7485f96a862f7deb74fa56c9e386235beb3bd8a106ea1ba29d6", kill_on_drop: false }` [INFO] running `Command { std: "docker" "exec" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTFLAGS=--cap-lints=warn" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "RUSTC_BOOTSTRAP=1" "-e" "DOCS_RS=1" "-w" "/opt/rustwide/workdir" "--user" "0:0" "6f233f5b46e5d7485f96a862f7deb74fa56c9e386235beb3bd8a106ea1ba29d6" "/opt/rustwide/cargo-home/bin/cargo" "+1.99.0-beta.8" "rustdoc" "--lib" "-Zrustdoc-map" "--config" "build.rustdocflags=[\"--cfg\", \"docsrs\", \"-Z\", \"unstable-options\", \"--document-private-items\"]" "--frozen" "--message-format=json", kill_on_drop: false }` [INFO] [stderr] Compiling proc-macro2 v1.0.95 [INFO] [stderr] Compiling thiserror v1.0.69 [INFO] [stderr] Compiling thiserror v2.0.12 [INFO] [stderr] Compiling anyhow v1.0.98 [INFO] [stderr] Compiling quote v1.0.40 [INFO] [stderr] Compiling syn v2.0.101 [INFO] [stderr] Compiling syn v1.0.109 [INFO] [stderr] Compiling pest_consume_macros v1.1.0 [INFO] [stderr] Compiling snafu-derive v0.7.5 [INFO] [stderr] Compiling confique-macro v0.0.10 [INFO] [stderr] Compiling synstructure v0.13.2 [INFO] [stderr] Compiling bevy_macro_utils v0.14.2 [INFO] [stderr] Checking snafu v0.7.5 [INFO] [stderr] Compiling zerovec-derive v0.11.1 [INFO] [stderr] Compiling displaydoc v0.2.5 [INFO] [stderr] Compiling serde_derive v1.0.219 [INFO] [stderr] Compiling tracing-attributes v0.1.28 [INFO] [stderr] Compiling thiserror-impl v1.0.69 [INFO] [stderr] Compiling futures-macro v0.3.31 [INFO] [stderr] Compiling tokio-macros v2.5.0 [INFO] [stderr] Compiling thiserror-impl v2.0.12 [INFO] [stderr] Compiling openssl-macros v0.1.1 [INFO] [stderr] Compiling bevy_utils_proc_macros v0.14.2 [INFO] [stderr] Compiling axum-macros v0.5.0 [INFO] [stderr] Compiling bevy_reflect_derive v0.14.2 [INFO] [stderr] Compiling async-trait v0.1.88 [INFO] [stderr] Compiling metrics-macros v0.7.1 [INFO] [stderr] Compiling async-recursion v1.1.1 [INFO] [stderr] Compiling zerofrom-derive v0.1.6 [INFO] [stderr] Compiling yoke-derive v0.8.0 [INFO] [stderr] Compiling openssl v0.10.72 [INFO] [stderr] Checking tokio v1.45.0 [INFO] [stderr] Checking metrics v0.21.1 [INFO] [stderr] Compiling clap_derive v4.5.32 [INFO] [stderr] Checking metrics-util v0.15.1 [INFO] [stderr] Compiling formbeam_derive v0.0.5 [INFO] [stderr] Checking futures-util v0.3.31 [INFO] [stderr] Compiling pest v2.8.0 [INFO] [stderr] Checking fluent-syntax v0.11.1 [INFO] [stderr] Checking forwarded-header-value v0.1.1 [INFO] [stderr] Checking tracing v0.1.41 [INFO] [stderr] Compiling zerofrom v0.1.6 [INFO] [stderr] Checking yoke v0.8.0 [INFO] [stderr] Checking axum-core v0.5.2 [INFO] [stderr] Checking tracing-subscriber v0.3.19 [INFO] [stderr] Compiling zerovec v0.11.2 [INFO] [stderr] Compiling zerotrie v0.2.2 [INFO] [stderr] Checking clap v4.5.38 [INFO] [stderr] Compiling pest_meta v2.8.0 [INFO] [stderr] Checking serde v1.0.219 [INFO] [stderr] Checking tinystr v0.8.1 [INFO] [stderr] Checking potential_utf v0.1.2 [INFO] [stderr] Checking icu_collections v2.0.0 [INFO] [stderr] Checking unic-langid-impl v0.9.6 [INFO] [stderr] Checking icu_locale_core v2.0.0 [INFO] [stderr] Compiling unic-langid v0.9.6 [INFO] [stderr] Compiling unic-langid-macros-impl v0.9.6 [INFO] [stderr] Compiling fluent-template-macros v0.8.0 [INFO] [stderr] Compiling pest_generator v2.8.0 [INFO] [stderr] Checking icu_provider v2.0.0 [INFO] [stderr] Checking unic-langid-macros v0.9.6 [INFO] [stderr] Checking icu_properties v2.0.0 [INFO] [stderr] Checking icu_normalizer v2.0.0 [INFO] [stderr] Checking intl-memoizer v0.5.2 [INFO] [stderr] Checking fluent-langneg v0.13.0 [INFO] [stderr] Checking intl_pluralrules v7.0.2 [INFO] [stderr] Compiling native-tls v0.2.14 [INFO] [stderr] Compiling pest_derive v2.8.0 [INFO] [stderr] Checking fluent-bundle v0.15.3 [INFO] [stderr] Checking pest_consume v1.1.3 [INFO] [stderr] Checking futures-executor v0.3.31 [INFO] [stderr] Checking tower-cookies v0.11.0 [INFO] [stderr] Checking futures v0.3.31 [INFO] [stderr] Checking fluent v0.16.1 [INFO] [stderr] Checking idna_adapter v1.2.1 [INFO] [stderr] Checking idna v1.0.3 [INFO] [stderr] Checking hyper v1.6.0 [INFO] [stderr] Checking tower v0.5.2 [INFO] [stderr] Checking tokio-stream v0.1.17 [INFO] [stderr] Checking tokio-util v0.7.15 [INFO] [stderr] Checking hyper v0.14.32 [INFO] [stderr] Checking tower-http v0.6.4 [INFO] [stderr] Checking url v2.5.4 [INFO] [stderr] Checking hashbrown v0.14.5 [INFO] [stderr] Checking serde_json v1.0.140 [INFO] [stderr] Checking either v1.15.0 [INFO] [stderr] Checking serde_urlencoded v0.7.1 [INFO] [stderr] Checking erased-serde v0.4.6 [INFO] [stderr] Checking arc-interner v0.7.0 [INFO] [stderr] Checking serde_path_to_error v0.1.17 [INFO] [stderr] Checking toml_datetime v0.6.9 [INFO] [stderr] Checking hornbeam_grammar v0.0.5 [INFO] [stderr] Checking serde_spanned v0.6.8 [INFO] [stderr] Checking uuid v1.16.0 [INFO] [stderr] Checking toml_edit v0.22.26 [INFO] [stderr] Checking itertools v0.10.5 [INFO] [stderr] Checking hyper-util v0.1.11 [INFO] [stderr] Checking bevy_utils v0.14.2 [INFO] [stderr] Checking hashlink v0.8.4 [INFO] [stderr] Checking dashmap v5.5.3 [INFO] [stderr] Checking bevy_reflect v0.14.2 [INFO] [stderr] Checking governor v0.6.3 [INFO] [stderr] Checking axum v0.8.4 [INFO] [stderr] Checking sqlx-core v0.7.4 [INFO] [stderr] Checking fluent-templates v0.8.0 [INFO] [stderr] Checking josekit v0.8.7 [INFO] [stderr] Checking toml v0.8.22 [INFO] [stderr] Checking hornbeam_ir v0.0.5 [INFO] [stderr] Checking confique v0.2.6 [INFO] [stderr] Checking sqlx-postgres v0.7.4 [INFO] [stderr] Checking formbeam v0.0.5 [INFO] [stderr] Checking hornbeam_interpreter v0.0.5 [INFO] [stderr] Checking metrics-exporter-prometheus v0.12.2 [INFO] [stderr] Checking axum-client-ip v0.7.0 [INFO] [stderr] Checking hornbeam v0.0.5 [INFO] [stderr] Checking axum-extra v0.10.1 [INFO] [stderr] Compiling sqlx-macros-core v0.7.4 [INFO] [stderr] Compiling sqlx-macros v0.7.4 [INFO] [stderr] Checking sqlx v0.7.4 [INFO] [stderr] Documenting idcoop v0.0.2 (/opt/rustwide/workdir) [INFO] [stdout] warning: unresolved link to `RFC3339` [INFO] [stdout] --> src/web/oauth_openid/token.rs:453:23 [INFO] [stdout] | [INFO] [stdout] 453 | /// See RFC 3339 [RFC3339] for details regarding date/times in general and UTC in particular. [INFO] [stdout] | ^^^^^^^ no item named `RFC3339` in scope [INFO] [stdout] | [INFO] [stdout] = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]` [INFO] [stdout] = note: `#[warn(rustdoc::broken_intra_doc_links)]` on by default [INFO] [stdout] [INFO] [stdout] [INFO] [stdout] warning: this URL is not a hyperlink [INFO] [stdout] --> src/web/oauth_openid/authorisation.rs:501:16 [INFO] [stdout] | [INFO] [stdout] 501 | /// OAuth 2.1: https://datatracker.ietf.org/doc/html/draft-ietf-oauth-v2-1-09#name-error-response-2 [INFO] [stdout] | ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ [INFO] [stdout] | [INFO] [stdout] = note: bare URLs are not automatically turned into clickable links [INFO] [stdout] = note: `#[warn(rustdoc::bare_urls)]` on by default [INFO] [stdout] help: use an automatic link instead [INFO] [stdout] | [INFO] [stdout] 501 | /// OAuth 2.1: [INFO] [stdout] | + + [INFO] [stdout] [INFO] [stdout] [INFO] [stdout] warning: this URL is not a hyperlink [INFO] [stdout] --> src/web/oauth_openid/authorisation.rs:504:26 [INFO] [stdout] | [INFO] [stdout] 504 | /// OpenID Connect Core: https://openid.net/specs/openid-connect-core-1_0.html#AuthError [INFO] [stdout] | ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ [INFO] [stdout] | [INFO] [stdout] = note: bare URLs are not automatically turned into clickable links [INFO] [stdout] help: use an automatic link instead [INFO] [stdout] | [INFO] [stdout] 504 | /// OpenID Connect Core: [INFO] [stdout] | + + [INFO] [stdout] [INFO] [stdout] [INFO] [stderr] Finished `dev` profile [unoptimized + debuginfo] target(s) in 1m 11s [INFO] [stderr] warning: the following packages contain code that will be rejected by a future version of Rust: sqlx-postgres v0.7.4 [INFO] [stderr] note: to see what the problems were, use the option `--future-incompat-report`, or run `cargo report future-incompatibilities --id 5` [INFO] [stderr] Generated /opt/rustwide/target/doc/idcoop/index.html [INFO] running `Command { std: "docker" "inspect" "6f233f5b46e5d7485f96a862f7deb74fa56c9e386235beb3bd8a106ea1ba29d6", kill_on_drop: false }` [INFO] running `Command { std: "docker" "rm" "-f" "6f233f5b46e5d7485f96a862f7deb74fa56c9e386235beb3bd8a106ea1ba29d6", kill_on_drop: false }` [INFO] [stdout] 6f233f5b46e5d7485f96a862f7deb74fa56c9e386235beb3bd8a106ea1ba29d6