[INFO] cloning repository https://github.com/quasipaas/quasipaa
[INFO] running `Command { std: "git" "-c" "credential.helper=" "-c" "credential.helper=/workspace/cargo-home/bin/git-credential-null" "clone" "--bare" "https://github.com/quasipaas/quasipaa" "/workspace/cache/git-repos/https%3A%2F%2Fgithub.com%2Fquasipaas%2Fquasipaa", kill_on_drop: false }`
[INFO] [stderr] Cloning into bare repository '/workspace/cache/git-repos/https%3A%2F%2Fgithub.com%2Fquasipaas%2Fquasipaa'...
[INFO] running `Command { std: "git" "rev-parse" "HEAD", kill_on_drop: false }`
[INFO] [stdout] 8df865064d3bfe2afb9bb21de63771e41ceb8466
[INFO] documenting quasipaas/quasipaa against 1.95.0 for beta-1.96-rustdoc-2
[INFO] running `Command { std: "git" "clone" "/workspace/cache/git-repos/https%3A%2F%2Fgithub.com%2Fquasipaas%2Fquasipaa" "/workspace/builds/worker-4-tc1/source", kill_on_drop: false }`
[INFO] [stderr] Cloning into '/workspace/builds/worker-4-tc1/source'...
[INFO] [stderr] done.
[INFO] started tweaking git repo https://github.com/quasipaas/quasipaa
[INFO] finished tweaking git repo https://github.com/quasipaas/quasipaa
[INFO] tweaked toml for git repo https://github.com/quasipaas/quasipaa written to /workspace/builds/worker-4-tc1/source/Cargo.toml
[INFO] validating manifest of git repo https://github.com/quasipaas/quasipaa on toolchain 1.95.0
[INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" "/workspace/cargo-home/bin/cargo" "+1.95.0" "metadata" "--manifest-path" "Cargo.toml" "--no-deps", kill_on_drop: false }`
[INFO] crate git repo https://github.com/quasipaas/quasipaa already has a lockfile, it will not be regenerated
[INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" "/workspace/cargo-home/bin/cargo" "+1.95.0" "fetch" "--manifest-path" "Cargo.toml", kill_on_drop: false }`
[INFO] [stderr]     Blocking waiting for file lock on package cache
[INFO] [stderr]     Updating crates.io index
[INFO] [stderr]     Blocking waiting for file lock on package cache
[INFO] [stderr]  Downloading crates ...
[INFO] [stderr]   Downloaded tonic-prost-build v0.14.5
[INFO] [stderr]   Downloaded tonic-build v0.14.5
[INFO] [stderr]   Downloaded prost-derive v0.14.3
[INFO] [stderr]   Downloaded ciborium-ll v0.2.2
[INFO] [stderr]   Downloaded pollster v0.4.0
[INFO] [stderr]   Downloaded cast v0.3.0
[INFO] [stderr]   Downloaded wasm-bindgen-shared v0.2.114
[INFO] [stderr]   Downloaded wasm-bindgen-macro v0.2.114
[INFO] [stderr]   Downloaded wait-timeout v0.2.1
[INFO] [stderr]   Downloaded syslog v6.1.1
[INFO] [stderr]   Downloaded plotters-backend v0.3.7
[INFO] [stderr]   Downloaded rand_xorshift v0.4.0
[INFO] [stderr]   Downloaded unarray v0.1.4
[INFO] [stderr]   Downloaded tonic-prost v0.14.5
[INFO] [stderr]   Downloaded mimalloc v0.1.48
[INFO] [stderr]   Downloaded serde_spanned v1.0.4
[INFO] [stderr]   Downloaded prost v0.14.3
[INFO] [stderr]   Downloaded ciborium-io v0.2.2
[INFO] [stderr]   Downloaded plotters-svg v0.3.7
[INFO] [stderr]   Downloaded bit-set v0.8.0
[INFO] [stderr]   Downloaded bit-vec v0.8.0
[INFO] [stderr]   Downloaded anes v0.1.6
[INFO] [stderr]   Downloaded oorandom v11.1.5
[INFO] [stderr]   Downloaded tinytemplate v1.2.1
[INFO] [stderr]   Downloaded cmake v0.1.57
[INFO] [stderr]   Downloaded axum-core v0.5.6
[INFO] [stderr]   Downloaded toml_writer v1.0.7+spec-1.1.0
[INFO] [stderr]   Downloaded rusty-fork v0.3.1
[INFO] [stderr]   Downloaded pulldown-cmark-to-cmark v22.0.0
[INFO] [stderr]   Downloaded prost-build v0.14.3
[INFO] [stderr]   Downloaded fs-err v3.3.0
[INFO] [stderr]   Downloaded criterion-plot v0.6.0
[INFO] [stderr]   Downloaded hyper-timeout v0.5.2
[INFO] [stderr]   Downloaded multimap v0.10.1
[INFO] [stderr]   Downloaded fixedbitset v0.5.7
[INFO] [stderr]   Downloaded toml_datetime v1.0.1+spec-1.1.0
[INFO] [stderr]   Downloaded error-chain v0.12.4
[INFO] [stderr]   Downloaded toml_parser v1.0.10+spec-1.1.0
[INFO] [stderr]   Downloaded toml_datetime v0.7.5+spec-1.1.0
[INFO] [stderr]   Downloaded prost-types v0.14.3
[INFO] [stderr]   Downloaded ciborium v0.2.2
[INFO] [stderr]   Downloaded matchit v0.8.4
[INFO] [stderr]   Downloaded half v2.7.1
[INFO] [stderr]   Downloaded wasm-bindgen-macro-support v0.2.114
[INFO] [stderr]   Downloaded wasm-bindgen v0.2.114
[INFO] [stderr]   Downloaded axum-server v0.8.0
[INFO] [stderr]   Downloaded toml v0.9.12+spec-1.1.0
[INFO] [stderr]   Downloaded arc-swap v1.9.0
[INFO] [stderr]   Downloaded toml_edit v0.25.5+spec-1.1.0
[INFO] [stderr]   Downloaded zerocopy-derive v0.8.47
[INFO] [stderr]   Downloaded js-sys v0.3.91
[INFO] [stderr]   Downloaded cc v1.2.57
[INFO] [stderr]   Downloaded prometheus v0.14.0
[INFO] [stderr]   Downloaded tonic v0.14.5
[INFO] [stderr]   Downloaded rand v0.9.3
[INFO] [stderr]   Downloaded plotters v0.3.7
[INFO] [stderr]   Downloaded criterion v0.7.0
[INFO] [stderr]   Downloaded pulldown-cmark v0.13.2
[INFO] [stderr]   Downloaded axum v0.8.8
[INFO] [stderr]   Downloaded hyper v1.8.1
[INFO] [stderr]   Downloaded winnow v1.0.0
[INFO] [stderr]   Downloaded proptest v1.10.0
[INFO] [stderr]   Downloaded chrono v0.4.44
[INFO] [stderr]   Downloaded aws-lc-rs v1.16.2
[INFO] [stderr]   Downloaded winnow v0.7.15
[INFO] [stderr]   Downloaded zerocopy v0.8.47
[INFO] [stderr]   Downloaded fern v0.7.1
[INFO] [stderr]   Downloaded itertools v0.14.0
[INFO] [stderr]   Downloaded libmimalloc-sys v0.1.44
[INFO] [stderr]   Downloaded web-sys v0.3.91
[INFO] [stderr]   Downloaded petgraph v0.8.3
[INFO] [stderr]   Downloaded libc v0.2.183
[INFO] [stderr]   Downloaded aws-lc-sys v0.39.0
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-4-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-4-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:d429b63d4308055ea97f60fb1d3dfca48854a00942f1bd2ad806beaf015945ec" "/opt/rustwide/cargo-home/bin/cargo" "+1.95.0" "metadata" "--no-deps" "--format-version=1", kill_on_drop: false }`
[INFO] [stdout] 0305ae08ee794fd06c51c09fd4297d415597347a865d4028d5292ff605e06986
[INFO] running `Command { std: "docker" "start" "-a" "0305ae08ee794fd06c51c09fd4297d415597347a865d4028d5292ff605e06986", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "inspect" "0305ae08ee794fd06c51c09fd4297d415597347a865d4028d5292ff605e06986", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "0305ae08ee794fd06c51c09fd4297d415597347a865d4028d5292ff605e06986", kill_on_drop: false }`
[INFO] [stdout] 0305ae08ee794fd06c51c09fd4297d415597347a865d4028d5292ff605e06986
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-4-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-4-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTFLAGS=--cap-lints=warn" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:d429b63d4308055ea97f60fb1d3dfca48854a00942f1bd2ad806beaf015945ec" "/opt/rustwide/cargo-home/bin/cargo" "+1.95.0" "doc" "--frozen" "--no-deps" "--document-private-items" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] 3297d468863f430ba75948f2abb227736b0e4a8e5c746c3c2c40a4be33c815a1
[INFO] running `Command { std: "docker" "start" "-a" "3297d468863f430ba75948f2abb227736b0e4a8e5c746c3c2c40a4be33c815a1", kill_on_drop: false }`
[INFO] [stderr]    Compiling proc-macro2 v1.0.106
[INFO] [stderr]    Compiling quote v1.0.45
[INFO] [stderr]    Compiling unicode-ident v1.0.24
[INFO] [stderr]    Compiling libc v0.2.183
[INFO] [stderr]     Checking cfg-if v1.0.4
[INFO] [stderr]     Checking smallvec v1.15.1
[INFO] [stderr]     Checking bytes v1.11.1
[INFO] [stderr]     Checking itoa v1.0.18
[INFO] [stderr]    Compiling find-msvc-tools v0.1.9
[INFO] [stderr]     Checking pin-project-lite v0.2.17
[INFO] [stderr]    Compiling shlex v1.3.0
[INFO] [stderr]    Compiling parking_lot_core v0.9.12
[INFO] [stderr]     Checking once_cell v1.21.4
[INFO] [stderr]     Checking scopeguard v1.2.0
[INFO] [stderr]    Compiling version_check v0.9.5
[INFO] [stderr]     Checking log v0.4.29
[INFO] [stderr]     Checking lock_api v0.4.14
[INFO] [stderr]     Checking futures-core v0.3.32
[INFO] [stderr]    Compiling anyhow v1.0.102
[INFO] [stderr]    Compiling dunce v1.0.5
[INFO] [stderr]     Checking stable_deref_trait v1.2.1
[INFO] [stderr]    Compiling fs_extra v1.3.0
[INFO] [stderr]    Compiling serde_core v1.0.228
[INFO] [stderr]     Checking tracing-core v0.1.36
[INFO] [stderr]     Checking http v1.4.0
[INFO] [stderr]    Compiling either v1.15.0
[INFO] [stderr]    Compiling itertools v0.14.0
[INFO] [stderr]    Compiling syn v2.0.117
[INFO] [stderr]    Compiling hashbrown v0.16.1
[INFO] [stderr]     Checking futures-sink v0.3.32
[INFO] [stderr]     Checking slab v0.4.12
[INFO] [stderr]    Compiling equivalent v1.0.2
[INFO] [stderr]     Checking http-body v1.0.1
[INFO] [stderr]    Compiling aws-lc-rs v1.16.2
[INFO] [stderr]     Checking errno v0.3.14
[INFO] [stderr]     Checking parking_lot v0.12.5
[INFO] [stderr]    Compiling jobserver v0.1.34
[INFO] [stderr]     Checking signal-hook-registry v1.4.8
[INFO] [stderr]     Checking socket2 v0.6.3
[INFO] [stderr]     Checking mio v1.1.1
[INFO] [stderr]     Checking indexmap v2.13.0
[INFO] [stderr]    Compiling cc v1.2.57
[INFO] [stderr]     Checking fnv v1.0.7
[INFO] [stderr]    Compiling httparse v1.10.1
[INFO] [stderr]    Compiling autocfg v1.5.0
[INFO] [stderr]     Checking tower-service v0.3.3
[INFO] [stderr]     Checking try-lock v0.2.5
[INFO] [stderr]     Checking atomic-waker v1.1.2
[INFO] [stderr]    Compiling typenum v1.19.0
[INFO] [stderr]     Checking zeroize v1.8.2
[INFO] [stderr]    Compiling bitflags v2.11.0
[INFO] [stderr]     Checking futures-task v0.3.32
[INFO] [stderr]     Checking want v0.3.1
[INFO] [stderr]     Checking futures-util v0.3.32
[INFO] [stderr]    Compiling generic-array v0.14.7
[INFO] [stderr]     Checking futures-channel v0.3.32
[INFO] [stderr]     Checking untrusted v0.7.1
[INFO] [stderr]    Compiling getrandom v0.4.2
[INFO] [stderr]    Compiling pulldown-cmark v0.13.2
[INFO] [stderr]    Compiling prettyplease v0.2.37
[INFO] [stderr]    Compiling rustix v1.1.4
[INFO] [stderr]     Checking httpdate v1.0.3
[INFO] [stderr]     Checking pin-utils v0.1.0
[INFO] [stderr]     Checking rustls-pki-types v1.14.0
[INFO] [stderr]    Compiling foldhash v0.1.5
[INFO] [stderr]    Compiling cmake v0.1.57
[INFO] [stderr]    Compiling serde v1.0.228
[INFO] [stderr]     Checking litemap v0.8.1
[INFO] [stderr]    Compiling heck v0.5.0
[INFO] [stderr]     Checking percent-encoding v2.3.2
[INFO] [stderr]     Checking untrusted v0.9.0
[INFO] [stderr]    Compiling unicase v2.9.0
[INFO] [stderr]    Compiling zmij v1.0.21
[INFO] [stderr]    Compiling aws-lc-sys v0.39.0
[INFO] [stderr]    Compiling regex-syntax v0.8.10
[INFO] [stderr]    Compiling rustls v0.23.37
[INFO] [stderr]     Checking writeable v0.6.2
[INFO] [stderr]    Compiling memchr v2.8.0
[INFO] [stderr]    Compiling linux-raw-sys v0.12.1
[INFO] [stderr]     Checking form_urlencoded v1.2.2
[INFO] [stderr]    Compiling hashbrown v0.15.5
[INFO] [stderr]    Compiling zerocopy v0.8.47
[INFO] [stderr]    Compiling fixedbitset v0.5.7
[INFO] [stderr]    Compiling getrandom v0.3.4
[INFO] [stderr]    Compiling icu_properties_data v2.1.2
[INFO] [stderr]     Checking sync_wrapper v1.0.2
[INFO] [stderr]    Compiling serde_json v1.0.149
[INFO] [stderr]    Compiling regex-automata v0.4.14
[INFO] [stderr]    Compiling fastrand v2.3.0
[INFO] [stderr]     Checking tower-layer v0.3.3
[INFO] [stderr]    Compiling crc32fast v1.5.0
[INFO] [stderr]    Compiling icu_normalizer_data v2.1.1
[INFO] [stderr]     Checking subtle v2.6.1
[INFO] [stderr]    Compiling petgraph v0.8.3
[INFO] [stderr]    Compiling pulldown-cmark-to-cmark v22.0.0
[INFO] [stderr]    Compiling synstructure v0.13.2
[INFO] [stderr]     Checking http-body-util v0.1.3
[INFO] [stderr]    Compiling tempfile v3.27.0
[INFO] [stderr]    Compiling winnow v1.0.0
[INFO] [stderr]    Compiling rustversion v1.0.22
[INFO] [stderr]     Checking simd-adler32 v0.3.8
[INFO] [stderr]    Compiling multimap v0.10.1
[INFO] [stderr]    Compiling thiserror v1.0.69
[INFO] [stderr]     Checking mime v0.3.17
[INFO] [stderr]     Checking ryu v1.0.23
[INFO] [stderr]    Compiling regex v1.12.3
[INFO] [stderr]     Checking adler2 v2.0.1
[INFO] [stderr]     Checking miniz_oxide v0.8.9
[INFO] [stderr]    Compiling tonic-build v0.14.5
[INFO] [stderr]    Compiling tokio-macros v2.6.1
[INFO] [stderr]    Compiling zerofrom-derive v0.1.6
[INFO] [stderr]    Compiling yoke-derive v0.8.1
[INFO] [stderr]    Compiling tracing-attributes v0.1.31
[INFO] [stderr]    Compiling zerovec-derive v0.11.2
[INFO] [stderr]    Compiling displaydoc v0.2.5
[INFO] [stderr]     Checking tokio v1.50.0
[INFO] [stderr]    Compiling prost-derive v0.14.3
[INFO] [stderr]     Checking zerofrom v0.1.6
[INFO] [stderr]    Compiling serde_derive v1.0.228
[INFO] [stderr]     Checking yoke v0.8.1
[INFO] [stderr]     Checking zerotrie v0.2.3
[INFO] [stderr]     Checking zerovec v0.11.5
[INFO] [stderr]    Compiling toml_parser v1.0.10+spec-1.1.0
[INFO] [stderr]     Checking tracing v0.1.44
[INFO] [stderr]     Checking axum-core v0.5.6
[INFO] [stderr]     Checking tinystr v0.8.2
[INFO] [stderr]     Checking icu_locale_core v2.1.1
[INFO] [stderr]     Checking potential_utf v0.1.4
[INFO] [stderr]     Checking icu_collections v2.1.1
[INFO] [stderr]     Checking icu_provider v2.1.1
[INFO] [stderr]    Compiling prost v0.14.3
[INFO] [stderr]    Compiling pin-project-internal v1.1.11
[INFO] [stderr]    Compiling thiserror-impl v1.0.69
[INFO] [stderr]    Compiling prost-types v0.14.3
[INFO] [stderr]     Checking crypto-common v0.1.7
[INFO] [stderr]     Checking block-buffer v0.10.4
[INFO] [stderr]     Checking serde_path_to_error v0.1.20
[INFO] [stderr]    Compiling num-traits v0.2.19
[INFO] [stderr]    Compiling error-chain v0.12.4
[INFO] [stderr]    Compiling toml_datetime v1.0.1+spec-1.1.0
[INFO] [stderr]     Checking utf8parse v0.2.2
[INFO] [stderr]     Checking matchit v0.8.4
[INFO] [stderr]     Checking powerfmt v0.2.0
[INFO] [stderr]     Checking anstyle-parse v1.0.0
[INFO] [stderr]    Compiling toml_edit v0.25.5+spec-1.1.0
[INFO] [stderr]     Checking deranged v0.5.8
[INFO] [stderr]     Checking digest v0.10.7
[INFO] [stderr]     Checking flate2 v1.1.9
[INFO] [stderr]    Compiling prost-build v0.14.3
[INFO] [stderr]     Checking icu_normalizer v2.1.1
[INFO] [stderr]     Checking pin-project v1.1.11
[INFO] [stderr]     Checking icu_properties v2.1.2
[INFO] [stderr]     Checking tokio-util v0.7.18
[INFO] [stderr]     Checking tokio-stream v0.1.18
[INFO] [stderr]     Checking h2 v0.4.13
[INFO] [stderr]     Checking serde_urlencoded v0.7.1
[INFO] [stderr]     Checking tower v0.5.3
[INFO] [stderr]    Compiling tonic-prost-build v0.14.5
[INFO] [stderr]    Compiling async-trait v0.1.89
[INFO] [stderr]    Compiling libmimalloc-sys v0.1.44
[INFO] [stderr]    Compiling fs-err v3.3.0
[INFO] [stderr]     Checking colorchoice v1.0.5
[INFO] [stderr]     Checking num-conv v0.2.0
[INFO] [stderr]     Checking time-core v0.1.8
[INFO] [stderr]    Compiling protobuf v3.7.2
[INFO] [stderr]     Checking base64 v0.22.1
[INFO] [stderr]     Checking anstyle v1.0.14
[INFO] [stderr]     Checking match_cfg v0.1.0
[INFO] [stderr]     Checking num_threads v0.1.7
[INFO] [stderr]    Compiling crossbeam-utils v0.8.21
[INFO] [stderr]     Checking anstyle-query v1.1.5
[INFO] [stderr]    Compiling thiserror v2.0.18
[INFO] [stderr]     Checking is_terminal_polyfill v1.70.2
[INFO] [stderr]     Checking time v0.3.47
[INFO] [stderr]     Checking hostname v0.3.1
[INFO] [stderr]    Compiling turn-server-sdk v0.3.0 (/opt/rustwide/workdir/sdk)
[INFO] [stderr]     Checking anstream v1.0.0
[INFO] [stderr]     Checking idna_adapter v1.2.1
[INFO] [stderr]    Compiling proc-macro-crate v3.5.0
[INFO] [stderr]     Checking protobuf-support v3.7.2
[INFO] [stderr]     Checking ppv-lite86 v0.2.21
[INFO] [stderr]     Checking rand_core v0.9.5
[INFO] [stderr]    Compiling thiserror-impl v2.0.18
[INFO] [stderr]    Compiling ahash v0.8.12
[INFO] [stderr]     Checking cpufeatures v0.2.17
[INFO] [stderr]     Checking clap_lex v1.1.0
[INFO] [stderr]     Checking strsim v0.11.1
[INFO] [stderr]     Checking iana-time-zone v0.1.65
[INFO] [stderr]    Compiling prometheus v0.14.0
[INFO] [stderr]     Checking utf8_iter v1.0.4
[INFO] [stderr]     Checking clap_builder v4.6.0
[INFO] [stderr]     Checking chrono v0.4.44
[INFO] [stderr]     Checking idna v1.1.0
[INFO] [stderr]     Checking rand_chacha v0.9.0
[INFO] [stderr]     Checking syslog v6.1.1
[INFO] [stderr]     Checking sha2 v0.10.9
[INFO] [stderr]    Compiling num_enum_derive v0.7.6
[INFO] [stderr]     Checking arc-swap v1.9.0
[INFO] [stderr]     Checking md-5 v0.10.6
[INFO] [stderr]    Compiling clap_derive v4.6.0
[INFO] [stderr]     Checking toml_datetime v0.7.5+spec-1.1.0
[INFO] [stderr]     Checking serde_spanned v1.0.4
[INFO] [stderr]     Checking hyper v1.8.1
[INFO] [stderr]     Checking toml_writer v1.0.7+spec-1.1.0
[INFO] [stderr]     Checking winnow v0.7.15
[INFO] [stderr]     Checking lazy_static v1.5.0
[INFO] [stderr]     Checking num_enum v0.7.6
[INFO] [stderr]     Checking crossbeam-channel v0.5.15
[INFO] [stderr]     Checking fern v0.7.1
[INFO] [stderr]     Checking rand v0.9.3
[INFO] [stderr]     Checking mimalloc v0.1.48
[INFO] [stderr]     Checking url v2.5.8
[INFO] [stderr]     Checking num_cpus v1.17.0
[INFO] [stderr]     Checking hyper-util v0.1.20
[INFO] [stderr]     Checking clap v4.6.0
[INFO] [stderr]     Checking toml v0.9.12+spec-1.1.0
[INFO] [stderr]     Checking axum v0.8.8
[INFO] [stderr]     Checking hyper-timeout v0.5.2
[INFO] [stderr]     Checking rustls-webpki v0.103.13
[INFO] [stderr]     Checking tokio-rustls v0.26.4
[INFO] [stderr]     Checking tonic v0.14.5
[INFO] [stderr]     Checking axum-server v0.8.0
[INFO] [stderr]     Checking tonic-prost v0.14.5
[INFO] [stderr]  Documenting turn-server v4.1.2 (/opt/rustwide/workdir)
[INFO] [stdout] warning: unresolved link to `RFC8265`
[INFO] [stdout]    --> src/codec/message/attributes/mod.rs:189:52
[INFO] [stdout]     |
[INFO] [stdout] 189 | /// been processed using the OpaqueString profile [RFC8265], and the realm MUST
[INFO] [stdout]     |                                                    ^^^^^^^ no item named `RFC8265` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout]     = note: `#[warn(rustdoc::broken_intra_doc_links)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC8265`
[INFO] [stdout]    --> src/codec/message/attributes/mod.rs:190:57
[INFO] [stdout]     |
[INFO] [stdout] 190 | /// have been processed using the OpaqueString profile [RFC8265] before hashing.
[INFO] [stdout]     |                                                         ^^^^^^^ no item named `RFC8265` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2104`
[INFO] [stdout]    --> src/codec/message/attributes/mod.rs:381:6
[INFO] [stdout]     |
[INFO] [stdout] 381 | /// [RFC2104] of the STUN message.  The MESSAGE-INTEGRITY-SHA256
[INFO] [stdout]     |      ^^^^^^^ no item named `RFC2104` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2104`
[INFO] [stdout]    --> src/codec/message/attributes/mod.rs:384:14
[INFO] [stdout]     |
[INFO] [stdout] 384 | /// SHA-256 [RFC2104] of the STUN message.  The value will be at most 32
[INFO] [stdout]     |              ^^^^^^^ no item named `RFC2104` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5389`
[INFO] [stdout]     --> src/codec/message/attributes/mod.rs:1213:37
[INFO] [stdout]      |
[INFO] [stdout] 1213 | /// attribute (see Section 15 from [RFC5389]).  If the client is able to
[INFO] [stdout]      |                                     ^^^^^^^ no item named `RFC5389` in scope
[INFO] [stdout]      |
[INFO] [stdout]      = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5389`
[INFO] [stdout]     --> src/codec/message/attributes/mod.rs:1216:33
[INFO] [stdout]      |
[INFO] [stdout] 1216 | /// explained in Section 10 of [RFC5389]).
[INFO] [stdout]      |                                 ^^^^^^^ no item named `RFC5389` in scope
[INFO] [stdout]      |
[INFO] [stdout]      = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6263`
[INFO] [stdout]    --> src/service/routing.rs:684:28
[INFO] [stdout]     |
[INFO] [stdout] 684 | /// sent [(Section 4.1 of [RFC6263])](https://tools.ietf.org/html/rfc6263#section-4.1).
[INFO] [stdout]     |                            ^^^^^^^ no item named `RFC6263` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC0793`
[INFO] [stdout]    --> src/service/session/ports.rs:123:21
[INFO] [stdout]     |
[INFO] [stdout] 123 | /// Protocol (TCP) [RFC0793] and similar protocols.  The consequences of
[INFO] [stdout]     |                     ^^^^^^^ no item named `RFC0793` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5927`
[INFO] [stdout]    --> src/service/session/ports.rs:125:25
[INFO] [stdout]     |
[INFO] [stdout] 125 | /// or data corruption [RFC5927] [RFC4953] [Watson].
[INFO] [stdout]     |                         ^^^^^^^ no item named `RFC5927` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4953`
[INFO] [stdout]    --> src/service/session/ports.rs:125:35
[INFO] [stdout]     |
[INFO] [stdout] 125 | /// or data corruption [RFC5927] [RFC4953] [Watson].
[INFO] [stdout]     |                                   ^^^^^^^ no item named `RFC4953` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `Watson`
[INFO] [stdout]    --> src/service/session/ports.rs:125:45
[INFO] [stdout]     |
[INFO] [stdout] 125 | /// or data corruption [RFC5927] [RFC4953] [Watson].
[INFO] [stdout]     |                                             ^^^^^^ no item named `Watson` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `IANA`
[INFO] [stdout]    --> src/service/session/ports.rs:132:64
[INFO] [stdout]     |
[INFO] [stdout] 132 | /// Services are usually located at fixed, "well-known" ports [IANA] at
[INFO] [stdout]     |                                                                ^^^^ no item named `IANA` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `Stevens`
[INFO] [stdout]    --> src/service/session/ports.rs:139:35
[INFO] [stdout]     |
[INFO] [stdout] 139 | /// are known as ephemeral ports [Stevens].
[INFO] [stdout]     |                                   ^^^^^^^ no item named `Stevens` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr]     Finished `dev` profile [unoptimized + debuginfo] target(s) in 2m 46s
[INFO] [stderr]    Generated /opt/rustwide/target/doc/turn_server/index.html
[INFO] running `Command { std: "docker" "inspect" "3297d468863f430ba75948f2abb227736b0e4a8e5c746c3c2c40a4be33c815a1", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "3297d468863f430ba75948f2abb227736b0e4a8e5c746c3c2c40a4be33c815a1", kill_on_drop: false }`
[INFO] [stdout] 3297d468863f430ba75948f2abb227736b0e4a8e5c746c3c2c40a4be33c815a1
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-4-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-4-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTFLAGS=--cap-lints=warn" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "DOCS_RS=1" "-e" "RUSTC_BOOTSTRAP=1" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:d429b63d4308055ea97f60fb1d3dfca48854a00942f1bd2ad806beaf015945ec" "/opt/rustwide/cargo-home/bin/cargo" "+1.95.0" "rustdoc" "--lib" "-Zrustdoc-map" "--config" "build.rustdocflags=[\"--cfg\", \"docsrs\", \"-Z\", \"unstable-options\", \"--document-private-items\"]" "--frozen" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] 55ce7358c4798b6ce24ab73653d116089d252f60137bd7de521b8019d4790740
[INFO] running `Command { std: "docker" "start" "-a" "55ce7358c4798b6ce24ab73653d116089d252f60137bd7de521b8019d4790740", kill_on_drop: false }`
[INFO] [stderr]    Compiling proc-macro2 v1.0.106
[INFO] [stderr]    Compiling anyhow v1.0.102
[INFO] [stderr]    Compiling thiserror v1.0.69
[INFO] [stderr]    Compiling thiserror v2.0.18
[INFO] [stderr]    Compiling quote v1.0.45
[INFO] [stderr]    Compiling syn v2.0.117
[INFO] [stderr]    Compiling synstructure v0.13.2
[INFO] [stderr]    Compiling prettyplease v0.2.37
[INFO] [stderr]    Compiling tonic-build v0.14.5
[INFO] [stderr]    Compiling tokio-macros v2.6.1
[INFO] [stderr]    Compiling zerofrom-derive v0.1.6
[INFO] [stderr]    Compiling yoke-derive v0.8.1
[INFO] [stderr]    Compiling tracing-attributes v0.1.31
[INFO] [stderr]    Compiling zerovec-derive v0.11.2
[INFO] [stderr]    Compiling displaydoc v0.2.5
[INFO] [stderr]    Compiling prost-derive v0.14.3
[INFO] [stderr]    Compiling serde_derive v1.0.228
[INFO] [stderr]    Compiling thiserror-impl v1.0.69
[INFO] [stderr]     Checking tokio v1.50.0
[INFO] [stderr]    Compiling pin-project-internal v1.1.11
[INFO] [stderr]     Checking tracing v0.1.44
[INFO] [stderr]     Checking zerofrom v0.1.6
[INFO] [stderr]    Compiling async-trait v0.1.89
[INFO] [stderr]     Checking yoke v0.8.1
[INFO] [stderr]     Checking axum-core v0.5.6
[INFO] [stderr]     Checking zerovec v0.11.5
[INFO] [stderr]    Compiling prost v0.14.3
[INFO] [stderr]     Checking tinystr v0.8.2
[INFO] [stderr]     Checking icu_locale_core v2.1.1
[INFO] [stderr]     Checking potential_utf v0.1.4
[INFO] [stderr]     Checking zerotrie v0.2.3
[INFO] [stderr]     Checking icu_collections v2.1.1
[INFO] [stderr]    Compiling prost-types v0.14.3
[INFO] [stderr]     Checking pin-project v1.1.11
[INFO] [stderr]     Checking protobuf-support v3.7.2
[INFO] [stderr]    Compiling thiserror-impl v2.0.18
[INFO] [stderr]     Checking protobuf v3.7.2
[INFO] [stderr]     Checking icu_provider v2.1.1
[INFO] [stderr]     Checking icu_normalizer v2.1.1
[INFO] [stderr]     Checking icu_properties v2.1.2
[INFO] [stderr]    Compiling num_enum_derive v0.7.6
[INFO] [stderr]    Compiling prost-build v0.14.3
[INFO] [stderr]    Compiling clap_derive v4.6.0
[INFO] [stderr]     Checking num_enum v0.7.6
[INFO] [stderr]     Checking idna_adapter v1.2.1
[INFO] [stderr]     Checking idna v1.1.0
[INFO] [stderr]     Checking serde v1.0.228
[INFO] [stderr]    Compiling tonic-prost-build v0.14.5
[INFO] [stderr]     Checking url v2.5.8
[INFO] [stderr]     Checking clap v4.6.0
[INFO] [stderr]    Compiling turn-server-sdk v0.3.0 (/opt/rustwide/workdir/sdk)
[INFO] [stderr]     Checking serde_urlencoded v0.7.1
[INFO] [stderr]     Checking tokio-util v0.7.18
[INFO] [stderr]     Checking tokio-rustls v0.26.4
[INFO] [stderr]     Checking tokio-stream v0.1.18
[INFO] [stderr]     Checking fs-err v3.3.0
[INFO] [stderr]     Checking prometheus v0.14.0
[INFO] [stderr]     Checking h2 v0.4.13
[INFO] [stderr]     Checking tower v0.5.3
[INFO] [stderr]     Checking hyper v1.8.1
[INFO] [stderr]     Checking hyper-util v0.1.20
[INFO] [stderr]     Checking axum v0.8.8
[INFO] [stderr]     Checking hyper-timeout v0.5.2
[INFO] [stderr]     Checking axum-server v0.8.0
[INFO] [stderr]     Checking tonic v0.14.5
[INFO] [stderr]     Checking tonic-prost v0.14.5
[INFO] [stderr]  Documenting turn-server v4.1.2 (/opt/rustwide/workdir)
[INFO] [stdout] warning: unresolved link to `RFC8265`
[INFO] [stdout]    --> src/codec/message/attributes/mod.rs:189:52
[INFO] [stdout]     |
[INFO] [stdout] 189 | /// been processed using the OpaqueString profile [RFC8265], and the realm MUST
[INFO] [stdout]     |                                                    ^^^^^^^ no item named `RFC8265` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout]     = note: `#[warn(rustdoc::broken_intra_doc_links)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC8265`
[INFO] [stdout]    --> src/codec/message/attributes/mod.rs:190:57
[INFO] [stdout]     |
[INFO] [stdout] 190 | /// have been processed using the OpaqueString profile [RFC8265] before hashing.
[INFO] [stdout]     |                                                         ^^^^^^^ no item named `RFC8265` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2104`
[INFO] [stdout]    --> src/codec/message/attributes/mod.rs:381:6
[INFO] [stdout]     |
[INFO] [stdout] 381 | /// [RFC2104] of the STUN message.  The MESSAGE-INTEGRITY-SHA256
[INFO] [stdout]     |      ^^^^^^^ no item named `RFC2104` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2104`
[INFO] [stdout]    --> src/codec/message/attributes/mod.rs:384:14
[INFO] [stdout]     |
[INFO] [stdout] 384 | /// SHA-256 [RFC2104] of the STUN message.  The value will be at most 32
[INFO] [stdout]     |              ^^^^^^^ no item named `RFC2104` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5389`
[INFO] [stdout]     --> src/codec/message/attributes/mod.rs:1213:37
[INFO] [stdout]      |
[INFO] [stdout] 1213 | /// attribute (see Section 15 from [RFC5389]).  If the client is able to
[INFO] [stdout]      |                                     ^^^^^^^ no item named `RFC5389` in scope
[INFO] [stdout]      |
[INFO] [stdout]      = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5389`
[INFO] [stdout]     --> src/codec/message/attributes/mod.rs:1216:33
[INFO] [stdout]      |
[INFO] [stdout] 1216 | /// explained in Section 10 of [RFC5389]).
[INFO] [stdout]      |                                 ^^^^^^^ no item named `RFC5389` in scope
[INFO] [stdout]      |
[INFO] [stdout]      = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC0793`
[INFO] [stdout]    --> src/service/session/ports.rs:123:21
[INFO] [stdout]     |
[INFO] [stdout] 123 | /// Protocol (TCP) [RFC0793] and similar protocols.  The consequences of
[INFO] [stdout]     |                     ^^^^^^^ no item named `RFC0793` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5927`
[INFO] [stdout]    --> src/service/session/ports.rs:125:25
[INFO] [stdout]     |
[INFO] [stdout] 125 | /// or data corruption [RFC5927] [RFC4953] [Watson].
[INFO] [stdout]     |                         ^^^^^^^ no item named `RFC5927` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4953`
[INFO] [stdout]    --> src/service/session/ports.rs:125:35
[INFO] [stdout]     |
[INFO] [stdout] 125 | /// or data corruption [RFC5927] [RFC4953] [Watson].
[INFO] [stdout]     |                                   ^^^^^^^ no item named `RFC4953` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `Watson`
[INFO] [stdout]    --> src/service/session/ports.rs:125:45
[INFO] [stdout]     |
[INFO] [stdout] 125 | /// or data corruption [RFC5927] [RFC4953] [Watson].
[INFO] [stdout]     |                                             ^^^^^^ no item named `Watson` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `IANA`
[INFO] [stdout]    --> src/service/session/ports.rs:132:64
[INFO] [stdout]     |
[INFO] [stdout] 132 | /// Services are usually located at fixed, "well-known" ports [IANA] at
[INFO] [stdout]     |                                                                ^^^^ no item named `IANA` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `Stevens`
[INFO] [stdout]    --> src/service/session/ports.rs:139:35
[INFO] [stdout]     |
[INFO] [stdout] 139 | /// are known as ephemeral ports [Stevens].
[INFO] [stdout]     |                                   ^^^^^^^ no item named `Stevens` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr]     Finished `dev` profile [unoptimized + debuginfo] target(s) in 57.80s
[INFO] [stderr]    Generated /opt/rustwide/target/doc/turn_server/index.html
[INFO] running `Command { std: "docker" "inspect" "55ce7358c4798b6ce24ab73653d116089d252f60137bd7de521b8019d4790740", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "55ce7358c4798b6ce24ab73653d116089d252f60137bd7de521b8019d4790740", kill_on_drop: false }`
[INFO] [stdout] 55ce7358c4798b6ce24ab73653d116089d252f60137bd7de521b8019d4790740
