[INFO] cloning repository https://github.com/quasipaas/quasipaa
[INFO] running `Command { std: "git" "-c" "credential.helper=" "-c" "credential.helper=/workspace/cargo-home/bin/git-credential-null" "clone" "--bare" "https://github.com/quasipaas/quasipaa" "/workspace/cache/git-repos/https%3A%2F%2Fgithub.com%2Fquasipaas%2Fquasipaa", kill_on_drop: false }`
[INFO] [stderr] Cloning into bare repository '/workspace/cache/git-repos/https%3A%2F%2Fgithub.com%2Fquasipaas%2Fquasipaa'...
[INFO] running `Command { std: "git" "rev-parse" "HEAD", kill_on_drop: false }`
[INFO] [stdout] 51171ee5983093e3fef5b51508dceb9ac91bf2c9
[INFO] documenting quasipaas/quasipaa against 1.69.0 for beta-1.70-rustdoc-1
[INFO] running `Command { std: "git" "clone" "/workspace/cache/git-repos/https%3A%2F%2Fgithub.com%2Fquasipaas%2Fquasipaa" "/workspace/builds/worker-0-tc1/source", kill_on_drop: false }`
[INFO] [stderr] Cloning into '/workspace/builds/worker-0-tc1/source'...
[INFO] [stderr] done.
[INFO] validating manifest of git repo https://github.com/quasipaas/quasipaa on toolchain 1.69.0
[INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" "/workspace/cargo-home/bin/cargo" "+1.69.0" "metadata" "--manifest-path" "Cargo.toml" "--no-deps", kill_on_drop: false }`
[INFO] started tweaking git repo https://github.com/quasipaas/quasipaa
[INFO] finished tweaking git repo https://github.com/quasipaas/quasipaa
[INFO] tweaked toml for git repo https://github.com/quasipaas/quasipaa written to /workspace/builds/worker-0-tc1/source/Cargo.toml
[INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" __CARGO_TEST_CHANNEL_OVERRIDE_DO_NOT_USE_THIS="nightly" "/workspace/cargo-home/bin/cargo" "+1.69.0" "generate-lockfile" "--manifest-path" "Cargo.toml" "-Zno-index-update", kill_on_drop: false }`
[INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" "/workspace/cargo-home/bin/cargo" "+1.69.0" "fetch" "--manifest-path" "Cargo.toml", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-0-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-0-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:5ff2268d62e97bff2cde7d5815dd6ed5b47097566f13b8d0ca110b04b60e07ed" "/opt/rustwide/cargo-home/bin/cargo" "+1.69.0" "metadata" "--no-deps" "--format-version=1", kill_on_drop: false }`
[INFO] [stdout] 9bdb5f4f114b3af7e902d79d71b535edf5e1f48bbb0140d639fa73d429feb1d2
[INFO] running `Command { std: "docker" "start" "-a" "9bdb5f4f114b3af7e902d79d71b535edf5e1f48bbb0140d639fa73d429feb1d2", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "inspect" "9bdb5f4f114b3af7e902d79d71b535edf5e1f48bbb0140d639fa73d429feb1d2", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "9bdb5f4f114b3af7e902d79d71b535edf5e1f48bbb0140d639fa73d429feb1d2", kill_on_drop: false }`
[INFO] [stdout] 9bdb5f4f114b3af7e902d79d71b535edf5e1f48bbb0140d639fa73d429feb1d2
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-0-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-0-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTFLAGS=--cap-lints=warn" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:5ff2268d62e97bff2cde7d5815dd6ed5b47097566f13b8d0ca110b04b60e07ed" "/opt/rustwide/cargo-home/bin/cargo" "+1.69.0" "doc" "--frozen" "--no-deps" "--document-private-items" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] bad6e62591bb6c01409ae6318a7313f4a4fefdc3102b29e1820376a93ba2c19f
[INFO] running `Command { std: "docker" "start" "-a" "bad6e62591bb6c01409ae6318a7313f4a4fefdc3102b29e1820376a93ba2c19f", kill_on_drop: false }`
[INFO] [stderr]    Compiling libc v0.2.142
[INFO] [stderr]    Compiling proc-macro2 v1.0.56
[INFO] [stderr]    Compiling unicode-ident v1.0.8
[INFO] [stderr]    Compiling quote v1.0.26
[INFO] [stderr]    Compiling autocfg v1.1.0
[INFO] [stderr]     Checking cfg-if v1.0.0
[INFO] [stderr]    Compiling log v0.4.17
[INFO] [stderr]     Checking bytes v1.4.0
[INFO] [stderr]     Checking pin-project-lite v0.2.9
[INFO] [stderr]    Compiling cc v1.0.79
[INFO] [stderr]    Compiling parking_lot_core v0.9.7
[INFO] [stderr]     Checking scopeguard v1.1.0
[INFO] [stderr]     Checking itoa v1.0.6
[INFO] [stderr]    Compiling futures-core v0.3.28
[INFO] [stderr]     Checking once_cell v1.17.1
[INFO] [stderr]     Checking smallvec v1.10.0
[INFO] [stderr]    Compiling typenum v1.16.0
[INFO] [stderr]     Checking bitflags v1.3.2
[INFO] [stderr]    Compiling syn v1.0.109
[INFO] [stderr]    Compiling version_check v0.9.4
[INFO] [stderr]    Compiling futures-task v0.3.28
[INFO] [stderr]    Compiling pkg-config v0.3.26
[INFO] [stderr]    Compiling futures-util v0.3.28
[INFO] [stderr]     Checking pin-utils v0.1.0
[INFO] [stderr]    Compiling hashbrown v0.12.3
[INFO] [stderr]     Checking fnv v1.0.7
[INFO] [stderr]    Compiling serde_derive v1.0.160
[INFO] [stderr]     Checking tracing-core v0.1.30
[INFO] [stderr]    Compiling serde v1.0.160
[INFO] [stderr]    Compiling indexmap v1.9.3
[INFO] [stderr]    Compiling lock_api v0.4.9
[INFO] [stderr]    Compiling tokio v1.28.0
[INFO] [stderr]     Checking http v0.2.9
[INFO] [stderr]    Compiling generic-array v0.14.7
[INFO] [stderr]    Compiling rustversion v1.0.12
[INFO] [stderr]    Compiling toml_datetime v0.6.1
[INFO] [stderr]    Compiling winnow v0.4.4
[INFO] [stderr]     Checking tracing v0.1.37
[INFO] [stderr]    Compiling slab v0.4.8
[INFO] [stderr]    Compiling getrandom v0.1.16
[INFO] [stderr]    Compiling build_const v0.2.2
[INFO] [stderr]    Compiling io-lifetimes v1.0.10
[INFO] [stderr]    Compiling syn v2.0.15
[INFO] [stderr]     Checking tower-service v0.3.2
[INFO] [stderr]    Compiling crc v1.8.1
[INFO] [stderr]    Compiling futures-channel v0.3.28
[INFO] [stderr]    Compiling openssl v0.10.52
[INFO] [stderr]     Checking http-body v0.4.5
[INFO] [stderr]    Compiling async-trait v0.1.68
[INFO] [stderr]     Checking subtle v2.4.1
[INFO] [stderr]    Compiling openssl-sys v0.9.87
[INFO] [stderr]    Compiling rustix v0.37.18
[INFO] [stderr]     Checking futures-sink v0.3.28
[INFO] [stderr]    Compiling anyhow v1.0.71
[INFO] [stderr]    Compiling httparse v1.8.0
[INFO] [stderr]     Checking foreign-types-shared v0.1.1
[INFO] [stderr]     Checking foreign-types v0.3.2
[INFO] [stderr]     Checking tinyvec_macros v0.1.1
[INFO] [stderr]    Compiling native-tls v0.2.11
[INFO] [stderr]     Checking try-lock v0.2.4
[INFO] [stderr]     Checking linux-raw-sys v0.3.6
[INFO] [stderr]     Checking mio v0.8.6
[INFO] [stderr]     Checking socket2 v0.4.9
[INFO] [stderr]     Checking num_cpus v1.15.0
[INFO] [stderr]     Checking signal-hook-registry v1.4.1
[INFO] [stderr]     Checking digest v0.9.0
[INFO] [stderr]     Checking parking_lot v0.12.1
[INFO] [stderr]     Checking block-buffer v0.9.0
[INFO] [stderr]     Checking crypto-mac v0.10.1
[INFO] [stderr]     Checking cpufeatures v0.2.7
[INFO] [stderr]     Checking percent-encoding v2.2.0
[INFO] [stderr]     Checking opaque-debug v0.3.0
[INFO] [stderr]     Checking hmac v0.10.1
[INFO] [stderr]     Checking rand_core v0.5.1
[INFO] [stderr]     Checking want v0.3.0
[INFO] [stderr]     Checking tinyvec v1.6.0
[INFO] [stderr]     Checking sha-1 v0.9.8
[INFO] [stderr]     Checking form_urlencoded v1.1.0
[INFO] [stderr]     Checking ppv-lite86 v0.2.17
[INFO] [stderr]     Checking md5 v0.7.0
[INFO] [stderr]     Checking httpdate v1.0.2
[INFO] [stderr]    Compiling serde_json v1.0.96
[INFO] [stderr]     Checking tower-layer v0.3.2
[INFO] [stderr]     Checking ryu v1.0.13
[INFO] [stderr]     Checking openssl-probe v0.1.5
[INFO] [stderr]     Checking utf8parse v0.2.1
[INFO] [stderr]    Compiling axum-core v0.3.4
[INFO] [stderr]    Compiling libmimalloc-sys v0.1.33
[INFO] [stderr]     Checking colorchoice v1.0.0
[INFO] [stderr]     Checking unicode-bidi v0.3.13
[INFO] [stderr]     Checking anstyle-parse v0.2.0
[INFO] [stderr]     Checking anstyle v1.0.0
[INFO] [stderr]    Compiling time-core v0.1.0
[INFO] [stderr]     Checking rand_chacha v0.2.2
[INFO] [stderr]     Checking mime v0.3.17
[INFO] [stderr]     Checking anstyle-query v1.0.0
[INFO] [stderr]    Compiling memchr v2.5.0
[INFO] [stderr]    Compiling toml_edit v0.19.8
[INFO] [stderr]     Checking unicode-normalization v0.1.22
[INFO] [stderr]    Compiling time-macros v0.2.8
[INFO] [stderr]    Compiling axum v0.6.18
[INFO] [stderr]     Checking atty v0.2.14
[INFO] [stderr]    Compiling heck v0.4.1
[INFO] [stderr]     Checking num_threads v0.1.6
[INFO] [stderr]     Checking clap_lex v0.4.1
[INFO] [stderr]     Checking rand v0.7.3
[INFO] [stderr]     Checking lazy_static v1.4.0
[INFO] [stderr]     Checking strsim v0.10.0
[INFO] [stderr]     Checking encoding_rs v0.8.32
[INFO] [stderr]     Checking colored v2.0.0
[INFO] [stderr]     Checking sync_wrapper v0.1.2
[INFO] [stderr]     Checking base64 v0.21.0
[INFO] [stderr]     Checking matchit v0.7.0
[INFO] [stderr]     Checking ipnet v2.7.2
[INFO] [stderr]     Checking http-range-header v0.3.0
[INFO] [stderr]     Checking idna v0.3.0
[INFO] [stderr]     Checking tower-http v0.3.5
[INFO] [stderr]     Checking url v2.3.1
[INFO] [stderr]     Checking mimalloc v0.1.37
[INFO] [stderr]     Checking time v0.3.20
[INFO] [stderr]    Compiling proc-macro-crate v1.3.1
[INFO] [stderr]     Checking is-terminal v0.4.7
[INFO] [stderr]    Compiling tokio-macros v2.1.0
[INFO] [stderr]    Compiling openssl-macros v0.1.1
[INFO] [stderr]     Checking anstream v0.3.1
[INFO] [stderr]    Compiling clap_derive v4.2.0
[INFO] [stderr]     Checking simple_logger v4.1.0
[INFO] [stderr]     Checking clap_builder v4.2.5
[INFO] [stderr]    Compiling num_enum_derive v0.5.11
[INFO] [stderr]    Compiling pin-project-internal v1.0.12
[INFO] [stderr]     Checking pin-project v1.0.12
[INFO] [stderr]     Checking num_enum v0.5.11
[INFO] [stderr]     Checking faster-stun v1.0.0 (/opt/rustwide/workdir/stun)
[INFO] [stderr]  Documenting faster-stun v1.0.0 (/opt/rustwide/workdir/stun)
[INFO] [stderr]     Checking clap v4.2.5
[INFO] [stderr]     Checking tokio-util v0.7.8
[INFO] [stderr]     Checking tokio-native-tls v0.3.1
[INFO] [stderr]     Checking tower v0.4.13
[INFO] [stderr]     Checking turn-rs v1.1.0 (/opt/rustwide/workdir/turn)
[INFO] [stderr]  Documenting turn-rs v1.1.0 (/opt/rustwide/workdir/turn)
[INFO] [stderr]     Checking h2 v0.3.18
[INFO] [stdout] warning: unresolved link to `RFC6056`
[INFO] [stdout]   --> turn/src/processor/allocate.rs:61:39
[INFO] [stdout]    |
[INFO] [stdout] 61 | /// types of attacks is described in [RFC6056].  It is RECOMMENDED
[INFO] [stdout]    |                                       ^^^^^^^ no item named `RFC6056` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout]    = note: `#[warn(rustdoc::broken_intra_doc_links)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6056`
[INFO] [stdout]   --> turn/src/processor/allocate.rs:63:21
[INFO] [stdout]    |
[INFO] [stdout] 63 | /// algorithm from [RFC6056].  This is especially applicable to
[INFO] [stdout]    |                     ^^^^^^^ no item named `RFC6056` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6263`
[INFO] [stdout]   --> turn/src/processor/channel_data.rs:34:28
[INFO] [stdout]    |
[INFO] [stdout] 34 | /// sent [(Section 4.1 of [RFC6263])](https://tools.ietf.org/html/rfc6263#section-4.1).
[INFO] [stdout]    |                            ^^^^^^^ no item named `RFC6263` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC1918`
[INFO] [stdout]   --> turn/src/processor/mod.rs:83:18
[INFO] [stdout]    |
[INFO] [stdout] 83 |     /// network [RFC1918] and, through one or more NATs, to the public
[INFO] [stdout]    |                  ^^^^^^^ no item named `RFC1918` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4787`
[INFO] [stdout]    --> turn/src/processor/mod.rs:129:64
[INFO] [stdout]     |
[INFO] [stdout] 129 |     /// property of "address-and-port-dependent mapping" (see [RFC4787]).
[INFO] [stdout]     |                                                                ^^^^^^^ no item named `RFC4787` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC8489`
[INFO] [stdout]    --> turn/src/processor/mod.rs:218:45
[INFO] [stdout]     |
[INFO] [stdout] 218 |     /// base processing rules described in [RFC8489] apply to STUN-formatted
[INFO] [stdout]     |                                             ^^^^^^^ no item named `RFC8489` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC8489`
[INFO] [stdout]    --> turn/src/processor/mod.rs:221:23
[INFO] [stdout]     |
[INFO] [stdout] 221 |     /// the rules of [RFC8489].
[INFO] [stdout]     |                       ^^^^^^^ no item named `RFC8489` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC8489`
[INFO] [stdout]    --> turn/src/processor/mod.rs:223:10
[INFO] [stdout]     |
[INFO] [stdout] 223 |     /// [RFC8489] specifies an authentication mechanism called the "long-term
[INFO] [stdout]     |          ^^^^^^^ no item named `RFC8489` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4086`
[INFO] [stdout]    --> turn/src/processor/mod.rs:240:40
[INFO] [stdout]     |
[INFO] [stdout] 240 |     /// randomness recommendations in [RFC4086] and SHOULD expire the nonce
[INFO] [stdout]     |                                        ^^^^^^^ no item named `RFC4086` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC8489`
[INFO] [stdout]    --> turn/src/processor/mod.rs:242:64
[INFO] [stdout]     |
[INFO] [stdout] 242 |     /// server uses the mechanism described in Section 9.2 of [RFC8489] to
[INFO] [stdout]     |                                                                ^^^^^^^ no item named `RFC8489` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC8489`
[INFO] [stdout]    --> turn/src/processor/mod.rs:243:36
[INFO] [stdout]     |
[INFO] [stdout] 243 |     /// indicate that it supports [RFC8489].
[INFO] [stdout]     |                                    ^^^^^^^ no item named `RFC8489` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC8489`
[INFO] [stdout]    --> turn/src/processor/mod.rs:275:10
[INFO] [stdout]     |
[INFO] [stdout] 275 |     /// [RFC8489] defines a number of attributes, including the SOFTWARE and
[INFO] [stdout]     |          ^^^^^^^ no item named `RFC8489` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC8489`
[INFO] [stdout]    --> turn/src/processor/mod.rs:285:10
[INFO] [stdout]     |
[INFO] [stdout] 285 |     /// [RFC8489].
[INFO] [stdout]     |          ^^^^^^^ no item named `RFC8489` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC8489`
[INFO] [stdout]    --> turn/src/processor/mod.rs:315:61
[INFO] [stdout]     |
[INFO] [stdout] 315 |     /// this case and treat the request as idempotent (see [RFC8489]).  Some
[INFO] [stdout]     |                                                             ^^^^^^^ no item named `RFC8489` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC8489`
[INFO] [stdout]    --> turn/src/processor/mod.rs:318:28
[INFO] [stdout]     |
[INFO] [stdout] 318 |     /// (Section 6.3.1 of [RFC8489]).  Other implementations may choose to
[INFO] [stdout]     |                            ^^^^^^^ no item named `RFC8489` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC0793`
[INFO] [stdout]   --> turn/src/router/ports.rs:31:21
[INFO] [stdout]    |
[INFO] [stdout] 31 | /// Protocol (TCP) [RFC0793] and similar protocols.  The consequences of
[INFO] [stdout]    |                     ^^^^^^^ no item named `RFC0793` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5927`
[INFO] [stdout]   --> turn/src/router/ports.rs:33:25
[INFO] [stdout]    |
[INFO] [stdout] 33 | /// or data corruption [RFC5927] [RFC4953] [Watson].
[INFO] [stdout]    |                         ^^^^^^^ no item named `RFC5927` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4953`
[INFO] [stdout]   --> turn/src/router/ports.rs:33:35
[INFO] [stdout]    |
[INFO] [stdout] 33 | /// or data corruption [RFC5927] [RFC4953] [Watson].
[INFO] [stdout]    |                                   ^^^^^^^ no item named `RFC4953` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `Watson`
[INFO] [stdout]   --> turn/src/router/ports.rs:33:45
[INFO] [stdout]    |
[INFO] [stdout] 33 | /// or data corruption [RFC5927] [RFC4953] [Watson].
[INFO] [stdout]    |                                             ^^^^^^ no item named `Watson` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `IANA`
[INFO] [stdout]   --> turn/src/router/ports.rs:40:64
[INFO] [stdout]    |
[INFO] [stdout] 40 | /// Services are usually located at fixed, "well-known" ports [IANA] at
[INFO] [stdout]    |                                                                ^^^^ no item named `IANA` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `Stevens`
[INFO] [stdout]   --> turn/src/router/ports.rs:47:35
[INFO] [stdout]    |
[INFO] [stdout] 47 | /// are known as ephemeral ports [Stevens].
[INFO] [stdout]    |                                   ^^^^^^^ no item named `Stevens` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6056`
[INFO] [stdout]    --> turn/src/router/mod.rs:248:45
[INFO] [stdout]     |
[INFO] [stdout] 248 |     ///   types of attacks is described in [RFC6056].  It is RECOMMENDED
[INFO] [stdout]     |                                             ^^^^^^^ no item named `RFC6056` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6056`
[INFO] [stdout]    --> turn/src/router/mod.rs:250:27
[INFO] [stdout]     |
[INFO] [stdout] 250 |     ///   algorithm from [RFC6056].  This is especially applicable to
[INFO] [stdout]     |                           ^^^^^^^ no item named `RFC6056` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: 23 warnings emitted
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr]     Checking serde_urlencoded v0.7.1
[INFO] [stderr]     Checking serde_path_to_error v0.1.11
[INFO] [stderr]     Checking toml v0.5.11
[INFO] [stderr]     Checking hyper v0.14.26
[INFO] [stderr]     Checking hyper-tls v0.5.0
[INFO] [stderr]     Checking reqwest v0.11.17
[INFO] [stderr]  Documenting turn-server v1.0.3 (/opt/rustwide/workdir/turn-server)
[INFO] [stderr]     Finished dev [unoptimized + debuginfo] target(s) in 27.39s
[INFO] running `Command { std: "docker" "inspect" "bad6e62591bb6c01409ae6318a7313f4a4fefdc3102b29e1820376a93ba2c19f", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "bad6e62591bb6c01409ae6318a7313f4a4fefdc3102b29e1820376a93ba2c19f", kill_on_drop: false }`
[INFO] [stdout] bad6e62591bb6c01409ae6318a7313f4a4fefdc3102b29e1820376a93ba2c19f
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-0-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-0-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTFLAGS=--cap-lints=warn" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "DOCS_RS=1" "-e" "RUSTC_BOOTSTRAP=1" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:5ff2268d62e97bff2cde7d5815dd6ed5b47097566f13b8d0ca110b04b60e07ed" "/opt/rustwide/cargo-home/bin/cargo" "+1.69.0" "rustdoc" "--lib" "-Zrustdoc-map" "-Z" "unstable-options" "--config" "build.rustdocflags=[\"-Z\", \"unstable-options\", \"--document-private-items\"]" "--frozen" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] 701c5dfafd6b918884f4cec6686f2781f1020fc8e8686d8a6bd455de249aa71e
[INFO] running `Command { std: "docker" "start" "-a" "701c5dfafd6b918884f4cec6686f2781f1020fc8e8686d8a6bd455de249aa71e", kill_on_drop: false }`
[INFO] [stderr] error: manifest path `/opt/rustwide/workdir/Cargo.toml` is a virtual manifest, but this command requires running against an actual package in this workspace
[INFO] running `Command { std: "docker" "inspect" "701c5dfafd6b918884f4cec6686f2781f1020fc8e8686d8a6bd455de249aa71e", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "701c5dfafd6b918884f4cec6686f2781f1020fc8e8686d8a6bd455de249aa71e", kill_on_drop: false }`
[INFO] [stdout] 701c5dfafd6b918884f4cec6686f2781f1020fc8e8686d8a6bd455de249aa71e
