[INFO] fetching crate turn-rs 1.1.0...
[INFO] documenting turn-rs-1.1.0 against 1.69.0 for beta-1.70-rustdoc-1
[INFO] extracting crate turn-rs 1.1.0 into /workspace/builds/worker-0-tc1/source
[INFO] validating manifest of crates.io crate turn-rs 1.1.0 on toolchain 1.69.0
[INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" "/workspace/cargo-home/bin/cargo" "+1.69.0" "metadata" "--manifest-path" "Cargo.toml" "--no-deps", kill_on_drop: false }`
[INFO] started tweaking crates.io crate turn-rs 1.1.0
[INFO] finished tweaking crates.io crate turn-rs 1.1.0
[INFO] tweaked toml for crates.io crate turn-rs 1.1.0 written to /workspace/builds/worker-0-tc1/source/Cargo.toml
[INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" __CARGO_TEST_CHANNEL_OVERRIDE_DO_NOT_USE_THIS="nightly" "/workspace/cargo-home/bin/cargo" "+1.69.0" "generate-lockfile" "--manifest-path" "Cargo.toml" "-Zno-index-update", kill_on_drop: false }`
[INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" "/workspace/cargo-home/bin/cargo" "+1.69.0" "fetch" "--manifest-path" "Cargo.toml", kill_on_drop: false }`
[INFO] [stderr]  Downloading crates ...
[INFO] [stderr]   Downloaded faster-stun v1.0.0
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-0-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-0-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:5ff2268d62e97bff2cde7d5815dd6ed5b47097566f13b8d0ca110b04b60e07ed" "/opt/rustwide/cargo-home/bin/cargo" "+1.69.0" "metadata" "--no-deps" "--format-version=1", kill_on_drop: false }`
[INFO] [stdout] be90c9671222e8063b5d0a317de4a36ade74ef4ec717315ddbc2bdd606f45b4b
[INFO] running `Command { std: "docker" "start" "-a" "be90c9671222e8063b5d0a317de4a36ade74ef4ec717315ddbc2bdd606f45b4b", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "inspect" "be90c9671222e8063b5d0a317de4a36ade74ef4ec717315ddbc2bdd606f45b4b", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "be90c9671222e8063b5d0a317de4a36ade74ef4ec717315ddbc2bdd606f45b4b", kill_on_drop: false }`
[INFO] [stdout] be90c9671222e8063b5d0a317de4a36ade74ef4ec717315ddbc2bdd606f45b4b
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-0-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-0-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTFLAGS=--cap-lints=warn" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:5ff2268d62e97bff2cde7d5815dd6ed5b47097566f13b8d0ca110b04b60e07ed" "/opt/rustwide/cargo-home/bin/cargo" "+1.69.0" "doc" "--frozen" "--no-deps" "--document-private-items" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] 12dbb70e14452847754f334a37e92bff024573171f45956a5eaeed40fc31716a
[INFO] running `Command { std: "docker" "start" "-a" "12dbb70e14452847754f334a37e92bff024573171f45956a5eaeed40fc31716a", kill_on_drop: false }`
[INFO] [stderr]    Compiling syn v1.0.109
[INFO] [stderr]    Compiling build_const v0.2.2
[INFO] [stderr]     Checking subtle v2.4.1
[INFO] [stderr]    Compiling tokio v1.28.0
[INFO] [stderr]    Compiling async-trait v0.1.68
[INFO] [stderr]    Compiling anyhow v1.0.71
[INFO] [stderr]     Checking md5 v0.7.0
[INFO] [stderr]     Checking getrandom v0.1.16
[INFO] [stderr]    Compiling syn v2.0.15
[INFO] [stderr]     Checking sha-1 v0.9.8
[INFO] [stderr]     Checking crypto-mac v0.10.1
[INFO] [stderr]    Compiling crc v1.8.1
[INFO] [stderr]     Checking rand_core v0.5.1
[INFO] [stderr]     Checking hmac v0.10.1
[INFO] [stderr]     Checking rand_chacha v0.2.2
[INFO] [stderr]     Checking rand v0.7.3
[INFO] [stderr]    Compiling num_enum_derive v0.5.11
[INFO] [stderr]     Checking num_enum v0.5.11
[INFO] [stderr]     Checking faster-stun v1.0.0
[INFO] [stderr]  Documenting turn-rs v1.1.0 (/opt/rustwide/workdir)
[INFO] [stdout] warning: unresolved link to `RFC6056`
[INFO] [stdout]   --> src/processor/allocate.rs:61:39
[INFO] [stdout]    |
[INFO] [stdout] 61 | /// types of attacks is described in [RFC6056].  It is RECOMMENDED
[INFO] [stdout]    |                                       ^^^^^^^ no item named `RFC6056` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout]    = note: `#[warn(rustdoc::broken_intra_doc_links)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6056`
[INFO] [stdout]   --> src/processor/allocate.rs:63:21
[INFO] [stdout]    |
[INFO] [stdout] 63 | /// algorithm from [RFC6056].  This is especially applicable to
[INFO] [stdout]    |                     ^^^^^^^ no item named `RFC6056` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6263`
[INFO] [stdout]   --> src/processor/channel_data.rs:34:28
[INFO] [stdout]    |
[INFO] [stdout] 34 | /// sent [(Section 4.1 of [RFC6263])](https://tools.ietf.org/html/rfc6263#section-4.1).
[INFO] [stdout]    |                            ^^^^^^^ no item named `RFC6263` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC1918`
[INFO] [stdout]   --> src/processor/mod.rs:83:18
[INFO] [stdout]    |
[INFO] [stdout] 83 |     /// network [RFC1918] and, through one or more NATs, to the public
[INFO] [stdout]    |                  ^^^^^^^ no item named `RFC1918` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4787`
[INFO] [stdout]    --> src/processor/mod.rs:129:64
[INFO] [stdout]     |
[INFO] [stdout] 129 |     /// property of "address-and-port-dependent mapping" (see [RFC4787]).
[INFO] [stdout]     |                                                                ^^^^^^^ no item named `RFC4787` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC8489`
[INFO] [stdout]    --> src/processor/mod.rs:218:45
[INFO] [stdout]     |
[INFO] [stdout] 218 |     /// base processing rules described in [RFC8489] apply to STUN-formatted
[INFO] [stdout]     |                                             ^^^^^^^ no item named `RFC8489` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC8489`
[INFO] [stdout]    --> src/processor/mod.rs:221:23
[INFO] [stdout]     |
[INFO] [stdout] 221 |     /// the rules of [RFC8489].
[INFO] [stdout]     |                       ^^^^^^^ no item named `RFC8489` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC8489`
[INFO] [stdout]    --> src/processor/mod.rs:223:10
[INFO] [stdout]     |
[INFO] [stdout] 223 |     /// [RFC8489] specifies an authentication mechanism called the "long-term
[INFO] [stdout]     |          ^^^^^^^ no item named `RFC8489` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4086`
[INFO] [stdout]    --> src/processor/mod.rs:240:40
[INFO] [stdout]     |
[INFO] [stdout] 240 |     /// randomness recommendations in [RFC4086] and SHOULD expire the nonce
[INFO] [stdout]     |                                        ^^^^^^^ no item named `RFC4086` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC8489`
[INFO] [stdout]    --> src/processor/mod.rs:242:64
[INFO] [stdout]     |
[INFO] [stdout] 242 |     /// server uses the mechanism described in Section 9.2 of [RFC8489] to
[INFO] [stdout]     |                                                                ^^^^^^^ no item named `RFC8489` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC8489`
[INFO] [stdout]    --> src/processor/mod.rs:243:36
[INFO] [stdout]     |
[INFO] [stdout] 243 |     /// indicate that it supports [RFC8489].
[INFO] [stdout]     |                                    ^^^^^^^ no item named `RFC8489` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC8489`
[INFO] [stdout]    --> src/processor/mod.rs:275:10
[INFO] [stdout]     |
[INFO] [stdout] 275 |     /// [RFC8489] defines a number of attributes, including the SOFTWARE and
[INFO] [stdout]     |          ^^^^^^^ no item named `RFC8489` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC8489`
[INFO] [stdout]    --> src/processor/mod.rs:285:10
[INFO] [stdout]     |
[INFO] [stdout] 285 |     /// [RFC8489].
[INFO] [stdout]     |          ^^^^^^^ no item named `RFC8489` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC8489`
[INFO] [stdout]    --> src/processor/mod.rs:315:61
[INFO] [stdout]     |
[INFO] [stdout] 315 |     /// this case and treat the request as idempotent (see [RFC8489]).  Some
[INFO] [stdout]     |                                                             ^^^^^^^ no item named `RFC8489` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC8489`
[INFO] [stdout]    --> src/processor/mod.rs:318:28
[INFO] [stdout]     |
[INFO] [stdout] 318 |     /// (Section 6.3.1 of [RFC8489]).  Other implementations may choose to
[INFO] [stdout]     |                            ^^^^^^^ no item named `RFC8489` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC0793`
[INFO] [stdout]   --> src/router/ports.rs:31:21
[INFO] [stdout]    |
[INFO] [stdout] 31 | /// Protocol (TCP) [RFC0793] and similar protocols.  The consequences of
[INFO] [stdout]    |                     ^^^^^^^ no item named `RFC0793` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5927`
[INFO] [stdout]   --> src/router/ports.rs:33:25
[INFO] [stdout]    |
[INFO] [stdout] 33 | /// or data corruption [RFC5927] [RFC4953] [Watson].
[INFO] [stdout]    |                         ^^^^^^^ no item named `RFC5927` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4953`
[INFO] [stdout]   --> src/router/ports.rs:33:35
[INFO] [stdout]    |
[INFO] [stdout] 33 | /// or data corruption [RFC5927] [RFC4953] [Watson].
[INFO] [stdout]    |                                   ^^^^^^^ no item named `RFC4953` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `Watson`
[INFO] [stdout]   --> src/router/ports.rs:33:45
[INFO] [stdout]    |
[INFO] [stdout] 33 | /// or data corruption [RFC5927] [RFC4953] [Watson].
[INFO] [stdout]    |                                             ^^^^^^ no item named `Watson` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `IANA`
[INFO] [stdout]   --> src/router/ports.rs:40:64
[INFO] [stdout]    |
[INFO] [stdout] 40 | /// Services are usually located at fixed, "well-known" ports [IANA] at
[INFO] [stdout]    |                                                                ^^^^ no item named `IANA` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `Stevens`
[INFO] [stdout]   --> src/router/ports.rs:47:35
[INFO] [stdout]    |
[INFO] [stdout] 47 | /// are known as ephemeral ports [Stevens].
[INFO] [stdout]    |                                   ^^^^^^^ no item named `Stevens` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6056`
[INFO] [stdout]    --> src/router/mod.rs:248:45
[INFO] [stdout]     |
[INFO] [stdout] 248 |     ///   types of attacks is described in [RFC6056].  It is RECOMMENDED
[INFO] [stdout]     |                                             ^^^^^^^ no item named `RFC6056` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6056`
[INFO] [stdout]    --> src/router/mod.rs:250:27
[INFO] [stdout]     |
[INFO] [stdout] 250 |     ///   algorithm from [RFC6056].  This is especially applicable to
[INFO] [stdout]     |                           ^^^^^^^ no item named `RFC6056` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: 23 warnings emitted
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr]     Finished dev [unoptimized + debuginfo] target(s) in 3.72s
[INFO] running `Command { std: "docker" "inspect" "12dbb70e14452847754f334a37e92bff024573171f45956a5eaeed40fc31716a", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "12dbb70e14452847754f334a37e92bff024573171f45956a5eaeed40fc31716a", kill_on_drop: false }`
[INFO] [stdout] 12dbb70e14452847754f334a37e92bff024573171f45956a5eaeed40fc31716a
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-0-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-0-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTFLAGS=--cap-lints=warn" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "DOCS_RS=1" "-e" "RUSTC_BOOTSTRAP=1" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:5ff2268d62e97bff2cde7d5815dd6ed5b47097566f13b8d0ca110b04b60e07ed" "/opt/rustwide/cargo-home/bin/cargo" "+1.69.0" "rustdoc" "--lib" "-Zrustdoc-map" "-Z" "unstable-options" "--config" "build.rustdocflags=[\"-Z\", \"unstable-options\", \"--document-private-items\"]" "--frozen" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] e38a08e7fc6a27e74d1e5137a9a2fb1c63e91fcb9dee035b99c0503aea53818d
[INFO] running `Command { std: "docker" "start" "-a" "e38a08e7fc6a27e74d1e5137a9a2fb1c63e91fcb9dee035b99c0503aea53818d", kill_on_drop: false }`
[INFO] [stderr]  Documenting turn-rs v1.1.0 (/opt/rustwide/workdir)
[INFO] [stdout] warning: unresolved link to `RFC6263`
[INFO] [stdout]   --> src/processor/channel_data.rs:34:28
[INFO] [stdout]    |
[INFO] [stdout] 34 | /// sent [(Section 4.1 of [RFC6263])](https://tools.ietf.org/html/rfc6263#section-4.1).
[INFO] [stdout]    |                            ^^^^^^^ no item named `RFC6263` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout]    = note: `#[warn(rustdoc::broken_intra_doc_links)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC1918`
[INFO] [stdout]   --> src/processor/mod.rs:83:18
[INFO] [stdout]    |
[INFO] [stdout] 83 |     /// network [RFC1918] and, through one or more NATs, to the public
[INFO] [stdout]    |                  ^^^^^^^ no item named `RFC1918` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4787`
[INFO] [stdout]    --> src/processor/mod.rs:129:64
[INFO] [stdout]     |
[INFO] [stdout] 129 |     /// property of "address-and-port-dependent mapping" (see [RFC4787]).
[INFO] [stdout]     |                                                                ^^^^^^^ no item named `RFC4787` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC0793`
[INFO] [stdout]   --> src/router/ports.rs:31:21
[INFO] [stdout]    |
[INFO] [stdout] 31 | /// Protocol (TCP) [RFC0793] and similar protocols.  The consequences of
[INFO] [stdout]    |                     ^^^^^^^ no item named `RFC0793` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5927`
[INFO] [stdout]   --> src/router/ports.rs:33:25
[INFO] [stdout]    |
[INFO] [stdout] 33 | /// or data corruption [RFC5927] [RFC4953] [Watson].
[INFO] [stdout]    |                         ^^^^^^^ no item named `RFC5927` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4953`
[INFO] [stdout]   --> src/router/ports.rs:33:35
[INFO] [stdout]    |
[INFO] [stdout] 33 | /// or data corruption [RFC5927] [RFC4953] [Watson].
[INFO] [stdout]    |                                   ^^^^^^^ no item named `RFC4953` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `Watson`
[INFO] [stdout]   --> src/router/ports.rs:33:45
[INFO] [stdout]    |
[INFO] [stdout] 33 | /// or data corruption [RFC5927] [RFC4953] [Watson].
[INFO] [stdout]    |                                             ^^^^^^ no item named `Watson` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `IANA`
[INFO] [stdout]   --> src/router/ports.rs:40:64
[INFO] [stdout]    |
[INFO] [stdout] 40 | /// Services are usually located at fixed, "well-known" ports [IANA] at
[INFO] [stdout]    |                                                                ^^^^ no item named `IANA` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `Stevens`
[INFO] [stdout]   --> src/router/ports.rs:47:35
[INFO] [stdout]    |
[INFO] [stdout] 47 | /// are known as ephemeral ports [Stevens].
[INFO] [stdout]    |                                   ^^^^^^^ no item named `Stevens` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6056`
[INFO] [stdout]    --> src/router/mod.rs:248:45
[INFO] [stdout]     |
[INFO] [stdout] 248 |     ///   types of attacks is described in [RFC6056].  It is RECOMMENDED
[INFO] [stdout]     |                                             ^^^^^^^ no item named `RFC6056` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6056`
[INFO] [stdout]    --> src/router/mod.rs:250:27
[INFO] [stdout]     |
[INFO] [stdout] 250 |     ///   algorithm from [RFC6056].  This is especially applicable to
[INFO] [stdout]     |                           ^^^^^^^ no item named `RFC6056` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: 11 warnings emitted
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr]     Finished dev [unoptimized + debuginfo] target(s) in 0.47s
[INFO] running `Command { std: "docker" "inspect" "e38a08e7fc6a27e74d1e5137a9a2fb1c63e91fcb9dee035b99c0503aea53818d", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "e38a08e7fc6a27e74d1e5137a9a2fb1c63e91fcb9dee035b99c0503aea53818d", kill_on_drop: false }`
[INFO] [stdout] e38a08e7fc6a27e74d1e5137a9a2fb1c63e91fcb9dee035b99c0503aea53818d
