[INFO] fetching crate sawp-gre 0.12.1...
[INFO] documenting sawp-gre-0.12.1 against 1.69.0 for beta-1.70-rustdoc-1
[INFO] extracting crate sawp-gre 0.12.1 into /workspace/builds/worker-6-tc1/source
[INFO] validating manifest of crates.io crate sawp-gre 0.12.1 on toolchain 1.69.0
[INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" "/workspace/cargo-home/bin/cargo" "+1.69.0" "metadata" "--manifest-path" "Cargo.toml" "--no-deps", kill_on_drop: false }`
[INFO] started tweaking crates.io crate sawp-gre 0.12.1
[INFO] finished tweaking crates.io crate sawp-gre 0.12.1
[INFO] tweaked toml for crates.io crate sawp-gre 0.12.1 written to /workspace/builds/worker-6-tc1/source/Cargo.toml
[INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" __CARGO_TEST_CHANNEL_OVERRIDE_DO_NOT_USE_THIS="nightly" "/workspace/cargo-home/bin/cargo" "+1.69.0" "generate-lockfile" "--manifest-path" "Cargo.toml" "-Zno-index-update", kill_on_drop: false }`
[INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" "/workspace/cargo-home/bin/cargo" "+1.69.0" "fetch" "--manifest-path" "Cargo.toml", kill_on_drop: false }`
[INFO] [stderr]  Downloading crates ...
[INFO] [stderr]   Downloaded sawp-flags-derive v0.12.1
[INFO] [stderr]   Downloaded sawp-ffi v0.12.1
[INFO] [stderr]   Downloaded sawp v0.12.1
[INFO] [stderr]   Downloaded sawp-ffi-derive v0.12.1
[INFO] [stderr]   Downloaded cbindgen v0.15.0
[INFO] [stderr]   Downloaded sawp-flags v0.12.1
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-6-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-6-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:5ff2268d62e97bff2cde7d5815dd6ed5b47097566f13b8d0ca110b04b60e07ed" "/opt/rustwide/cargo-home/bin/cargo" "+1.69.0" "metadata" "--no-deps" "--format-version=1", kill_on_drop: false }`
[INFO] [stdout] 08b301749b1f0bbc59ebfeb213eb5ca6f582488a89fec7196c19b8255ee7494f
[INFO] running `Command { std: "docker" "start" "-a" "08b301749b1f0bbc59ebfeb213eb5ca6f582488a89fec7196c19b8255ee7494f", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "inspect" "08b301749b1f0bbc59ebfeb213eb5ca6f582488a89fec7196c19b8255ee7494f", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "08b301749b1f0bbc59ebfeb213eb5ca6f582488a89fec7196c19b8255ee7494f", kill_on_drop: false }`
[INFO] [stdout] 08b301749b1f0bbc59ebfeb213eb5ca6f582488a89fec7196c19b8255ee7494f
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-6-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-6-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTFLAGS=--cap-lints=warn" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:5ff2268d62e97bff2cde7d5815dd6ed5b47097566f13b8d0ca110b04b60e07ed" "/opt/rustwide/cargo-home/bin/cargo" "+1.69.0" "doc" "--frozen" "--no-deps" "--document-private-items" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] 3d8b561b4b972bc38500684cdacbcf80a97fd1b13a33a8101c0d1383f3200fbb
[INFO] running `Command { std: "docker" "start" "-a" "3d8b561b4b972bc38500684cdacbcf80a97fd1b13a33a8101c0d1383f3200fbb", kill_on_drop: false }`
[INFO] [stderr]    Compiling thiserror v1.0.40
[INFO] [stderr]     Checking sawp v0.12.1
[INFO] [stderr]    Compiling proc-macro-crate v1.1.0
[INFO] [stderr]    Compiling num_enum_derive v0.5.11
[INFO] [stderr]    Compiling sawp-flags-derive v0.12.1
[INFO] [stderr]     Checking sawp-flags v0.12.1
[INFO] [stderr]     Checking num_enum v0.5.11
[INFO] [stderr]  Documenting sawp-gre v0.12.1 (/opt/rustwide/workdir)
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]  --> src/lib.rs:8:27
[INFO] [stdout]   |
[INFO] [stdout] 8 | //! [CURRENT GRE RFC2784] https://tools.ietf.org/html/rfc2784
[INFO] [stdout]   |                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc2784>`
[INFO] [stdout]   |
[INFO] [stdout]   = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout]   = note: `#[warn(rustdoc::bare_urls)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]  --> src/lib.rs:9:30
[INFO] [stdout]   |
[INFO] [stdout] 9 | //! [DEPRECATED GRE RFC1701] https://tools.ietf.org/html/rfc1701
[INFO] [stdout]   |                              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc1701>`
[INFO] [stdout]   |
[INFO] [stdout]   = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/lib.rs:10:40
[INFO] [stdout]    |
[INFO] [stdout] 10 | //! [POINT TO POINT TUNNELING RFC2637] https://tools.ietf.org/html/rfc2637
[INFO] [stdout]    |                                        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc2637>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]    --> src/lib.rs:113:9
[INFO] [stdout]     |
[INFO] [stdout] 113 | /// See https://tools.ietf.org/html/rfc1701 for implementation in GRE headers
[INFO] [stdout]     |         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc1701>`
[INFO] [stdout]     |
[INFO] [stdout]     = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]    --> src/lib.rs:114:9
[INFO] [stdout]     |
[INFO] [stdout] 114 | /// and https://tools.ietf.org/html/rfc1702 for further details.
[INFO] [stdout]     |         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc1702>`
[INFO] [stdout]     |
[INFO] [stdout]     = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]    --> src/lib.rs:125:19
[INFO] [stdout]     |
[INFO] [stdout] 125 | ///  Current GRE: https://tools.ietf.org/html/rfc2784
[INFO] [stdout]     |                   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc2784>`
[INFO] [stdout]     |
[INFO] [stdout]     = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]    --> src/lib.rs:126:22
[INFO] [stdout]     |
[INFO] [stdout] 126 | ///  Deprecated GRE: https://tools.ietf.org/html/rfc1701
[INFO] [stdout]     |                      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc1701>`
[INFO] [stdout]     |
[INFO] [stdout]     = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]    --> src/lib.rs:127:63
[INFO] [stdout]     |
[INFO] [stdout] 127 | ///  Point-to-Point Tunneling Protocol (Enhanced GRE Header): https://tools.ietf.org/html/rfc2637
[INFO] [stdout]     |                                                               ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc2637>`
[INFO] [stdout]     |
[INFO] [stdout]     = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: 8 warnings emitted
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr]     Finished dev [unoptimized + debuginfo] target(s) in 2.15s
[INFO] running `Command { std: "docker" "inspect" "3d8b561b4b972bc38500684cdacbcf80a97fd1b13a33a8101c0d1383f3200fbb", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "3d8b561b4b972bc38500684cdacbcf80a97fd1b13a33a8101c0d1383f3200fbb", kill_on_drop: false }`
[INFO] [stdout] 3d8b561b4b972bc38500684cdacbcf80a97fd1b13a33a8101c0d1383f3200fbb
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-6-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-6-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTFLAGS=--cap-lints=warn" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "DOCS_RS=1" "-e" "RUSTC_BOOTSTRAP=1" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:5ff2268d62e97bff2cde7d5815dd6ed5b47097566f13b8d0ca110b04b60e07ed" "/opt/rustwide/cargo-home/bin/cargo" "+1.69.0" "rustdoc" "--lib" "-Zrustdoc-map" "-Z" "unstable-options" "--config" "build.rustdocflags=[\"-Z\", \"unstable-options\", \"--document-private-items\"]" "--frozen" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] 0cef5307c9bd26f5472c32cda5f2cb0c17a452300420fdc6d1fdc3d8f38296af
[INFO] running `Command { std: "docker" "start" "-a" "0cef5307c9bd26f5472c32cda5f2cb0c17a452300420fdc6d1fdc3d8f38296af", kill_on_drop: false }`
[INFO] [stderr]  Documenting sawp-gre v0.12.1 (/opt/rustwide/workdir)
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]  --> src/lib.rs:8:27
[INFO] [stdout]   |
[INFO] [stdout] 8 | //! [CURRENT GRE RFC2784] https://tools.ietf.org/html/rfc2784
[INFO] [stdout]   |                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc2784>`
[INFO] [stdout]   |
[INFO] [stdout]   = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout]   = note: `#[warn(rustdoc::bare_urls)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]  --> src/lib.rs:9:30
[INFO] [stdout]   |
[INFO] [stdout] 9 | //! [DEPRECATED GRE RFC1701] https://tools.ietf.org/html/rfc1701
[INFO] [stdout]   |                              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc1701>`
[INFO] [stdout]   |
[INFO] [stdout]   = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/lib.rs:10:40
[INFO] [stdout]    |
[INFO] [stdout] 10 | //! [POINT TO POINT TUNNELING RFC2637] https://tools.ietf.org/html/rfc2637
[INFO] [stdout]    |                                        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc2637>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]    --> src/lib.rs:113:9
[INFO] [stdout]     |
[INFO] [stdout] 113 | /// See https://tools.ietf.org/html/rfc1701 for implementation in GRE headers
[INFO] [stdout]     |         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc1701>`
[INFO] [stdout]     |
[INFO] [stdout]     = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]    --> src/lib.rs:114:9
[INFO] [stdout]     |
[INFO] [stdout] 114 | /// and https://tools.ietf.org/html/rfc1702 for further details.
[INFO] [stdout]     |         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc1702>`
[INFO] [stdout]     |
[INFO] [stdout]     = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]    --> src/lib.rs:125:19
[INFO] [stdout]     |
[INFO] [stdout] 125 | ///  Current GRE: https://tools.ietf.org/html/rfc2784
[INFO] [stdout]     |                   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc2784>`
[INFO] [stdout]     |
[INFO] [stdout]     = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]    --> src/lib.rs:126:22
[INFO] [stdout]     |
[INFO] [stdout] 126 | ///  Deprecated GRE: https://tools.ietf.org/html/rfc1701
[INFO] [stdout]     |                      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc1701>`
[INFO] [stdout]     |
[INFO] [stdout]     = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]    --> src/lib.rs:127:63
[INFO] [stdout]     |
[INFO] [stdout] 127 | ///  Point-to-Point Tunneling Protocol (Enhanced GRE Header): https://tools.ietf.org/html/rfc2637
[INFO] [stdout]     |                                                               ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc2637>`
[INFO] [stdout]     |
[INFO] [stdout]     = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: 8 warnings emitted
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr]     Finished dev [unoptimized + debuginfo] target(s) in 0.58s
[INFO] running `Command { std: "docker" "inspect" "0cef5307c9bd26f5472c32cda5f2cb0c17a452300420fdc6d1fdc3d8f38296af", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "0cef5307c9bd26f5472c32cda5f2cb0c17a452300420fdc6d1fdc3d8f38296af", kill_on_drop: false }`
[INFO] [stdout] 0cef5307c9bd26f5472c32cda5f2cb0c17a452300420fdc6d1fdc3d8f38296af
