[INFO] fetching crate melib 0.7.2...
[INFO] documenting melib-0.7.2 against 1.69.0 for beta-1.70-rustdoc-1
[INFO] extracting crate melib 0.7.2 into /workspace/builds/worker-5-tc1/source
[INFO] validating manifest of crates.io crate melib 0.7.2 on toolchain 1.69.0
[INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" "/workspace/cargo-home/bin/cargo" "+1.69.0" "metadata" "--manifest-path" "Cargo.toml" "--no-deps", kill_on_drop: false }`
[INFO] started tweaking crates.io crate melib 0.7.2
[INFO] finished tweaking crates.io crate melib 0.7.2
[INFO] tweaked toml for crates.io crate melib 0.7.2 written to /workspace/builds/worker-5-tc1/source/Cargo.toml
[INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" __CARGO_TEST_CHANNEL_OVERRIDE_DO_NOT_USE_THIS="nightly" "/workspace/cargo-home/bin/cargo" "+1.69.0" "generate-lockfile" "--manifest-path" "Cargo.toml" "-Zno-index-update", kill_on_drop: false }`
[INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" "/workspace/cargo-home/bin/cargo" "+1.69.0" "fetch" "--manifest-path" "Cargo.toml", kill_on_drop: false }`
[INFO] [stderr]  Downloading crates ...
[INFO] [stderr]   Downloaded xdg-utils v0.4.0
[INFO] [stderr]   Downloaded rusqlite v0.24.2
[INFO] [stderr]   Downloaded libsqlite3-sys v0.20.1
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-5-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-5-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:5ff2268d62e97bff2cde7d5815dd6ed5b47097566f13b8d0ca110b04b60e07ed" "/opt/rustwide/cargo-home/bin/cargo" "+1.69.0" "metadata" "--no-deps" "--format-version=1", kill_on_drop: false }`
[INFO] [stdout] dfa876eef546c4c1b11c856df7c6d59ff9f893b8fcc152379d3ddb7cafebec07
[INFO] running `Command { std: "docker" "start" "-a" "dfa876eef546c4c1b11c856df7c6d59ff9f893b8fcc152379d3ddb7cafebec07", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "inspect" "dfa876eef546c4c1b11c856df7c6d59ff9f893b8fcc152379d3ddb7cafebec07", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "dfa876eef546c4c1b11c856df7c6d59ff9f893b8fcc152379d3ddb7cafebec07", kill_on_drop: false }`
[INFO] [stdout] dfa876eef546c4c1b11c856df7c6d59ff9f893b8fcc152379d3ddb7cafebec07
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-5-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-5-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTFLAGS=--cap-lints=warn" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:5ff2268d62e97bff2cde7d5815dd6ed5b47097566f13b8d0ca110b04b60e07ed" "/opt/rustwide/cargo-home/bin/cargo" "+1.69.0" "doc" "--frozen" "--no-deps" "--document-private-items" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] d4890fc908f92889b580ef9983d6e00c593cf9acb3a1e1ae79e5ef1624ef404b
[INFO] running `Command { std: "docker" "start" "-a" "d4890fc908f92889b580ef9983d6e00c593cf9acb3a1e1ae79e5ef1624ef404b", kill_on_drop: false }`
[INFO] [stderr]    Compiling libc v0.2.142
[INFO] [stderr]    Compiling futures-core v0.3.28
[INFO] [stderr]    Compiling slab v0.4.8
[INFO] [stderr]    Compiling crossbeam-utils v0.8.15
[INFO] [stderr]     Checking pin-project-lite v0.2.9
[INFO] [stderr]     Checking futures-io v0.3.28
[INFO] [stderr]     Checking event-listener v2.5.3
[INFO] [stderr]    Compiling syn v2.0.15
[INFO] [stderr]     Checking parking v2.1.0
[INFO] [stderr]     Checking fastrand v1.9.0
[INFO] [stderr]     Checking waker-fn v1.1.0
[INFO] [stderr]     Checking async-lock v2.7.0
[INFO] [stderr]    Compiling io-lifetimes v1.0.10
[INFO] [stderr]    Compiling serde v1.0.160
[INFO] [stderr]     Checking futures-lite v1.13.0
[INFO] [stderr]    Compiling openssl-sys v0.9.87
[INFO] [stderr]    Compiling polling v2.8.0
[INFO] [stderr]     Checking concurrent-queue v2.2.0
[INFO] [stderr]    Compiling rustix v0.37.18
[INFO] [stderr]    Compiling async-io v1.13.0
[INFO] [stderr]    Compiling futures-channel v0.3.28
[INFO] [stderr]    Compiling futures-task v0.3.28
[INFO] [stderr]     Checking linux-raw-sys v0.3.6
[INFO] [stderr]     Checking async-task v4.4.0
[INFO] [stderr]     Checking async-channel v1.8.0
[INFO] [stderr]    Compiling syn v1.0.109
[INFO] [stderr]     Checking socket2 v0.4.9
[INFO] [stderr]    Compiling futures-util v0.3.28
[INFO] [stderr]     Checking futures-sink v0.3.28
[INFO] [stderr]    Compiling signal-hook v0.3.15
[INFO] [stderr]     Checking atomic-waker v1.1.1
[INFO] [stderr]     Checking blocking v1.3.1
[INFO] [stderr]     Checking signal-hook-registry v1.4.1
[INFO] [stderr]     Checking net2 v0.2.38
[INFO] [stderr]     Checking iovec v0.1.4
[INFO] [stderr]    Compiling libsqlite3-sys v0.20.1
[INFO] [stderr]    Compiling async-net v1.7.0
[INFO] [stderr]    Compiling async-fs v1.6.0
[INFO] [stderr]    Compiling async-process v1.7.0
[INFO] [stderr]     Checking pin-utils v0.1.0
[INFO] [stderr]     Checking foreign-types-shared v0.1.1
[INFO] [stderr]    Compiling openssl v0.10.52
[INFO] [stderr]    Compiling crc32fast v1.3.2
[INFO] [stderr]    Compiling lexical-core v0.7.6
[INFO] [stderr]     Checking ahash v0.4.7
[INFO] [stderr]    Compiling nom v5.1.3
[INFO] [stderr]     Checking hashbrown v0.9.1
[INFO] [stderr]     Checking foreign-types v0.3.2
[INFO] [stderr]     Checking mio v0.6.23
[INFO] [stderr]     Checking inotify-sys v0.1.5
[INFO] [stderr]    Compiling indexmap v1.9.3
[INFO] [stderr]     Checking once_cell v1.17.1
[INFO] [stderr]     Checking sha1_smol v1.0.0
[INFO] [stderr]    Compiling nix v0.17.0
[INFO] [stderr]     Checking arrayvec v0.5.2
[INFO] [stderr]    Compiling native-tls v0.2.11
[INFO] [stderr]     Checking miniz_oxide v0.7.1
[INFO] [stderr]     Checking smallvec v1.10.0
[INFO] [stderr]     Checking mio-extras v2.0.6
[INFO] [stderr]     Checking walkdir v2.3.3
[INFO] [stderr]     Checking sha1 v0.6.1
[INFO] [stderr]     Checking inotify v0.7.1
[INFO] [stderr]     Checking hashlink v0.6.0
[INFO] [stderr]     Checking async-executor v1.5.1
[INFO] [stderr]     Checking getrandom v0.2.9
[INFO] [stderr]     Checking filetime v0.2.21
[INFO] [stderr]     Checking fallible-streaming-iterator v0.1.9
[INFO] [stderr]     Checking openssl-probe v0.1.5
[INFO] [stderr]     Checking void v1.0.2
[INFO] [stderr]     Checking home v0.5.5
[INFO] [stderr]    Compiling melib v0.7.2 (/opt/rustwide/workdir)
[INFO] [stderr]     Checking hashbrown v0.12.3
[INFO] [stderr]     Checking fallible-iterator v0.2.0
[INFO] [stderr]     Checking notify v4.0.17
[INFO] [stderr]     Checking xdg v2.5.0
[INFO] [stderr]     Checking smol v1.3.0
[INFO] [stderr]     Checking rusqlite v0.24.2
[INFO] [stderr]     Checking uuid v0.8.2
[INFO] [stderr]     Checking flate2 v1.0.26
[INFO] [stderr]     Checking bincode v1.3.3
[INFO] [stderr]     Checking libloading v0.6.7
[INFO] [stderr]    Compiling futures-macro v0.3.28
[INFO] [stderr]    Compiling openssl-macros v0.1.1
[INFO] [stderr]    Compiling serde_derive v1.0.160
[INFO] [stderr]     Checking xdg-utils v0.4.0
[INFO] [stderr]     Checking data-encoding v2.3.3
[INFO] [stderr]     Checking base64 v0.12.3
[INFO] [stderr]     Checking unicode-segmentation v1.10.1
[INFO] [stderr]    Compiling async-stream-impl v0.2.1
[INFO] [stderr]     Checking async-stream v0.2.1
[INFO] [stderr]     Checking futures-executor v0.3.28
[INFO] [stderr]     Checking futures v0.3.28
[INFO] [stderr]  Documenting melib v0.7.2 (/opt/rustwide/workdir)
[INFO] [stdout] warning: unresolved link to `0`
[INFO] [stdout]   --> src/backends/mbox.rs:26:8
[INFO] [stdout]    |
[INFO] [stdout] 26 | //! - [0] <https://web.archive.org/web/20160812091518/https://jdebp.eu./FGA/mail-mbox-formats.html>
[INFO] [stdout]    |        ^ no item named `0` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout]    = note: `#[warn(rustdoc::broken_intra_doc_links)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `1`
[INFO] [stdout]   --> src/backends/mbox.rs:27:8
[INFO] [stdout]    |
[INFO] [stdout] 27 | //! - [1] <https://wiki2.dovecot.org/MailboxFormat/mbox>
[INFO] [stdout]    |        ^ no item named `1` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `2`
[INFO] [stdout]   --> src/backends/mbox.rs:28:8
[INFO] [stdout]    |
[INFO] [stdout] 28 | //! - [2] <https://manpages.debian.org/buster/mutt/mbox.5.en.html>
[INFO] [stdout]    |        ^ no item named `2` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `0`
[INFO] [stdout]   --> src/backends/mbox.rs:33:147
[INFO] [stdout]    |
[INFO] [stdout] 33 | ...ivery appends new messages to the end of the file." [0]
[INFO] [stdout]    |                                                         ^ no item named `0` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `0`
[INFO] [stdout]   --> src/backends/mbox.rs:35:168
[INFO] [stdout]    |
[INFO] [stdout] 35 | ...h the five characters 'F', 'r', 'o', 'm', and ' '." [0]
[INFO] [stdout]    |                                                         ^ no item named `0` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `2`
[INFO] [stdout]   --> src/backends/mbox.rs:62:62
[INFO] [stdout]    |
[INFO] [stdout] 62 | //! any occurrence of 'From ' at the start of a body line." [2]
[INFO] [stdout]    |                                                              ^ no item named `2` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `email::address::Address`
[INFO] [stdout]   --> src/email.rs:28:80
[INFO] [stdout]    |
[INFO] [stdout] 28 |  * structure. Addresses in `To`, `From` fields etc are parsed into [`Address`](email::address::Address) types.
[INFO] [stdout]    |                                                                                ^^^^^^^^^^^^^^^^^^^^^^^ no item named `email` in scope
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC0822`
[INFO] [stdout]    --> src/email/parser.rs:322:16
[INFO] [stdout]     |
[INFO] [stdout] 322 |     ///way in [RFC0822] and are therefore unpredictable in their meaning.
[INFO] [stdout]     |                ^^^^^^^ no item named `RFC0822` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC0822`
[INFO] [stdout]    --> src/email/parser.rs:328:22
[INFO] [stdout]     |
[INFO] [stdout] 328 |     ///the error in [RFC0822], they SHOULD all be considered equivalent to
[INFO] [stdout]     |                      ^^^^^^^ no item named `RFC0822` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `CFWS`
[INFO] [stdout]    --> src/email/parser.rs:364:59
[INFO] [stdout]     |
[INFO] [stdout] 364 |     ///date-time       =   [ day-of-week "," ] date time [CFWS]
[INFO] [stdout]     |                                                           ^^^^ no item named `CFWS` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `FWS`
[INFO] [stdout]    --> src/email/parser.rs:433:30
[INFO] [stdout]     |
[INFO] [stdout] 433 |     ///day             =   ([FWS] 1*2DIGIT FWS) / obs-day
[INFO] [stdout]     |                              ^^^ no item named `FWS` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5234`
[INFO] [stdout]    --> src/email/parser.rs:541:24
[INFO] [stdout]     |
[INFO] [stdout] 541 |     ///following ABNF [RFC5234], taken from [RFC3629]:
[INFO] [stdout]     |                        ^^^^^^^ no item named `RFC5234` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3629`
[INFO] [stdout]    --> src/email/parser.rs:541:46
[INFO] [stdout]     |
[INFO] [stdout] 541 |     ///following ABNF [RFC5234], taken from [RFC3629]:
[INFO] [stdout]     |                                              ^^^^^^^ no item named `RFC3629` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `CFWS`
[INFO] [stdout]     --> src/email/parser.rs:1129:29
[INFO] [stdout]      |
[INFO] [stdout] 1129 |     ///dot-atom        =   [CFWS] dot-atom-text [CFWS]
[INFO] [stdout]      |                             ^^^^ no item named `CFWS` in scope
[INFO] [stdout]      |
[INFO] [stdout]      = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `CFWS`
[INFO] [stdout]     --> src/email/parser.rs:1129:50
[INFO] [stdout]      |
[INFO] [stdout] 1129 |     ///dot-atom        =   [CFWS] dot-atom-text [CFWS]
[INFO] [stdout]      |                                                  ^^^^ no item named `CFWS` in scope
[INFO] [stdout]      |
[INFO] [stdout]      = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/addressbook/vcard.rs:36:5
[INFO] [stdout]    |
[INFO] [stdout] 36 | /// https://tools.ietf.org/html/rfc6350
[INFO] [stdout]    |     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc6350>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout]    = note: `#[warn(rustdoc::bare_urls)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/addressbook/vcard.rs:41:5
[INFO] [stdout]    |
[INFO] [stdout] 41 | /// https://tools.ietf.org/html/rfc2426
[INFO] [stdout]    |     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc2426>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/backends/imap/connection.rs:47:59
[INFO] [stdout]    |
[INFO] [stdout] 47 |     ///rfc4549 `Synch Ops for Disconnected IMAP4 Clients` https://tools.ietf.org/html/rfc4549
[INFO] [stdout]    |                                                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc4549>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]    --> src/backends/maildir/backend.rs:105:21
[INFO] [stdout]     |
[INFO] [stdout] 105 | /// Maildir backend https://cr.yp.to/proto/maildir.html
[INFO] [stdout]     |                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://cr.yp.to/proto/maildir.html>`
[INFO] [stdout]     |
[INFO] [stdout]     = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unclosed HTML tag `domain`
[INFO] [stdout]    --> src/smtp.rs:790:8
[INFO] [stdout]     |
[INFO] [stdout] 790 |     ///<domain> Service ready
[INFO] [stdout]     |        ^^^^^^^^
[INFO] [stdout]     |
[INFO] [stdout]     = note: `#[warn(rustdoc::invalid_html_tags)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unclosed HTML tag `domain`
[INFO] [stdout]    --> src/smtp.rs:792:8
[INFO] [stdout]     |
[INFO] [stdout] 792 |     ///<domain> Service closing transmission channel
[INFO] [stdout]     |        ^^^^^^^^
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unclosed HTML tag `forward-path`
[INFO] [stdout]    --> src/smtp.rs:798:40
[INFO] [stdout]     |
[INFO] [stdout] 798 |     ///User not local; will forward to <forward-path> (See Section 3.4)
[INFO] [stdout]     |                                        ^^^^^^^^^^^^^^
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unclosed HTML tag `CRLF`
[INFO] [stdout]    --> src/smtp.rs:806:35
[INFO] [stdout]     |
[INFO] [stdout] 806 |     ///Start mail input; end with <CRLF>.<CRLF>
[INFO] [stdout]     |                                   ^^^^^^
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unclosed HTML tag `CRLF`
[INFO] [stdout]    --> src/smtp.rs:806:42
[INFO] [stdout]     |
[INFO] [stdout] 806 |     ///Start mail input; end with <CRLF>.<CRLF>
[INFO] [stdout]     |                                          ^^^^^^
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unclosed HTML tag `domain`
[INFO] [stdout]    --> src/smtp.rs:808:8
[INFO] [stdout]     |
[INFO] [stdout] 808 |     ///<domain> Service not available, closing transmission channel (This may be a reply to any command if the service knows it must shut...
[INFO] [stdout]     |        ^^^^^^^^
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unclosed HTML tag `forward-path`
[INFO] [stdout]    --> src/smtp.rs:832:35
[INFO] [stdout]     |
[INFO] [stdout] 832 |     ///User not local; please try <forward-path> (See Section 3.4)
[INFO] [stdout]     |                                   ^^^^^^^^^^^^^^
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: 26 warnings emitted
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr]     Finished dev [unoptimized + debuginfo] target(s) in 27.50s
[INFO] running `Command { std: "docker" "inspect" "d4890fc908f92889b580ef9983d6e00c593cf9acb3a1e1ae79e5ef1624ef404b", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "d4890fc908f92889b580ef9983d6e00c593cf9acb3a1e1ae79e5ef1624ef404b", kill_on_drop: false }`
[INFO] [stdout] d4890fc908f92889b580ef9983d6e00c593cf9acb3a1e1ae79e5ef1624ef404b
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-5-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-5-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTFLAGS=--cap-lints=warn" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "DOCS_RS=1" "-e" "RUSTC_BOOTSTRAP=1" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:5ff2268d62e97bff2cde7d5815dd6ed5b47097566f13b8d0ca110b04b60e07ed" "/opt/rustwide/cargo-home/bin/cargo" "+1.69.0" "rustdoc" "--lib" "-Zrustdoc-map" "-Z" "unstable-options" "--config" "build.rustdocflags=[\"-Z\", \"unstable-options\", \"--document-private-items\"]" "--frozen" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] 1a7f36ca76b0bdb08119b886a03da3bc98a7be1e3c323f98a2c1f0543175c3fc
[INFO] running `Command { std: "docker" "start" "-a" "1a7f36ca76b0bdb08119b886a03da3bc98a7be1e3c323f98a2c1f0543175c3fc", kill_on_drop: false }`
[INFO] [stderr]  Documenting melib v0.7.2 (/opt/rustwide/workdir)
[INFO] [stdout] warning: unresolved link to `0`
[INFO] [stdout]   --> src/backends/mbox.rs:26:8
[INFO] [stdout]    |
[INFO] [stdout] 26 | //! - [0] <https://web.archive.org/web/20160812091518/https://jdebp.eu./FGA/mail-mbox-formats.html>
[INFO] [stdout]    |        ^ no item named `0` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout]    = note: `#[warn(rustdoc::broken_intra_doc_links)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `1`
[INFO] [stdout]   --> src/backends/mbox.rs:27:8
[INFO] [stdout]    |
[INFO] [stdout] 27 | //! - [1] <https://wiki2.dovecot.org/MailboxFormat/mbox>
[INFO] [stdout]    |        ^ no item named `1` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `2`
[INFO] [stdout]   --> src/backends/mbox.rs:28:8
[INFO] [stdout]    |
[INFO] [stdout] 28 | //! - [2] <https://manpages.debian.org/buster/mutt/mbox.5.en.html>
[INFO] [stdout]    |        ^ no item named `2` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `0`
[INFO] [stdout]   --> src/backends/mbox.rs:33:147
[INFO] [stdout]    |
[INFO] [stdout] 33 | ...ivery appends new messages to the end of the file." [0]
[INFO] [stdout]    |                                                         ^ no item named `0` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `0`
[INFO] [stdout]   --> src/backends/mbox.rs:35:168
[INFO] [stdout]    |
[INFO] [stdout] 35 | ...h the five characters 'F', 'r', 'o', 'm', and ' '." [0]
[INFO] [stdout]    |                                                         ^ no item named `0` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `2`
[INFO] [stdout]   --> src/backends/mbox.rs:62:62
[INFO] [stdout]    |
[INFO] [stdout] 62 | //! any occurrence of 'From ' at the start of a body line." [2]
[INFO] [stdout]    |                                                              ^ no item named `2` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `email::address::Address`
[INFO] [stdout]   --> src/email.rs:28:80
[INFO] [stdout]    |
[INFO] [stdout] 28 |  * structure. Addresses in `To`, `From` fields etc are parsed into [`Address`](email::address::Address) types.
[INFO] [stdout]    |                                                                                ^^^^^^^^^^^^^^^^^^^^^^^ no item named `email` in scope
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `CFWS`
[INFO] [stdout]     --> src/email/parser.rs:1129:29
[INFO] [stdout]      |
[INFO] [stdout] 1129 |     ///dot-atom        =   [CFWS] dot-atom-text [CFWS]
[INFO] [stdout]      |                             ^^^^ no item named `CFWS` in scope
[INFO] [stdout]      |
[INFO] [stdout]      = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `CFWS`
[INFO] [stdout]     --> src/email/parser.rs:1129:50
[INFO] [stdout]      |
[INFO] [stdout] 1129 |     ///dot-atom        =   [CFWS] dot-atom-text [CFWS]
[INFO] [stdout]      |                                                  ^^^^ no item named `CFWS` in scope
[INFO] [stdout]      |
[INFO] [stdout]      = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/addressbook/vcard.rs:36:5
[INFO] [stdout]    |
[INFO] [stdout] 36 | /// https://tools.ietf.org/html/rfc6350
[INFO] [stdout]    |     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc6350>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout]    = note: `#[warn(rustdoc::bare_urls)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/addressbook/vcard.rs:41:5
[INFO] [stdout]    |
[INFO] [stdout] 41 | /// https://tools.ietf.org/html/rfc2426
[INFO] [stdout]    |     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc2426>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/backends/imap/connection.rs:47:59
[INFO] [stdout]    |
[INFO] [stdout] 47 |     ///rfc4549 `Synch Ops for Disconnected IMAP4 Clients` https://tools.ietf.org/html/rfc4549
[INFO] [stdout]    |                                                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc4549>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]    --> src/backends/maildir/backend.rs:105:21
[INFO] [stdout]     |
[INFO] [stdout] 105 | /// Maildir backend https://cr.yp.to/proto/maildir.html
[INFO] [stdout]     |                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://cr.yp.to/proto/maildir.html>`
[INFO] [stdout]     |
[INFO] [stdout]     = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unclosed HTML tag `domain`
[INFO] [stdout]    --> src/smtp.rs:790:8
[INFO] [stdout]     |
[INFO] [stdout] 790 |     ///<domain> Service ready
[INFO] [stdout]     |        ^^^^^^^^
[INFO] [stdout]     |
[INFO] [stdout]     = note: `#[warn(rustdoc::invalid_html_tags)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unclosed HTML tag `domain`
[INFO] [stdout]    --> src/smtp.rs:792:8
[INFO] [stdout]     |
[INFO] [stdout] 792 |     ///<domain> Service closing transmission channel
[INFO] [stdout]     |        ^^^^^^^^
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unclosed HTML tag `forward-path`
[INFO] [stdout]    --> src/smtp.rs:798:40
[INFO] [stdout]     |
[INFO] [stdout] 798 |     ///User not local; will forward to <forward-path> (See Section 3.4)
[INFO] [stdout]     |                                        ^^^^^^^^^^^^^^
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unclosed HTML tag `CRLF`
[INFO] [stdout]    --> src/smtp.rs:806:35
[INFO] [stdout]     |
[INFO] [stdout] 806 |     ///Start mail input; end with <CRLF>.<CRLF>
[INFO] [stdout]     |                                   ^^^^^^
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unclosed HTML tag `CRLF`
[INFO] [stdout]    --> src/smtp.rs:806:42
[INFO] [stdout]     |
[INFO] [stdout] 806 |     ///Start mail input; end with <CRLF>.<CRLF>
[INFO] [stdout]     |                                          ^^^^^^
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unclosed HTML tag `domain`
[INFO] [stdout]    --> src/smtp.rs:808:8
[INFO] [stdout]     |
[INFO] [stdout] 808 |     ///<domain> Service not available, closing transmission channel (This may be a reply to any command if the service knows it must shut...
[INFO] [stdout]     |        ^^^^^^^^
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unclosed HTML tag `forward-path`
[INFO] [stdout]    --> src/smtp.rs:832:35
[INFO] [stdout]     |
[INFO] [stdout] 832 |     ///User not local; please try <forward-path> (See Section 3.4)
[INFO] [stdout]     |                                   ^^^^^^^^^^^^^^
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: 20 warnings emitted
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr]     Finished dev [unoptimized + debuginfo] target(s) in 1.92s
[INFO] running `Command { std: "docker" "inspect" "1a7f36ca76b0bdb08119b886a03da3bc98a7be1e3c323f98a2c1f0543175c3fc", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "1a7f36ca76b0bdb08119b886a03da3bc98a7be1e3c323f98a2c1f0543175c3fc", kill_on_drop: false }`
[INFO] [stdout] 1a7f36ca76b0bdb08119b886a03da3bc98a7be1e3c323f98a2c1f0543175c3fc
