[INFO] fetching crate libpacket 0.1.2...
[INFO] documenting libpacket-0.1.2 against 1.69.0 for beta-1.70-rustdoc-1
[INFO] extracting crate libpacket 0.1.2 into /workspace/builds/worker-2-tc1/source
[INFO] validating manifest of crates.io crate libpacket 0.1.2 on toolchain 1.69.0
[INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" "/workspace/cargo-home/bin/cargo" "+1.69.0" "metadata" "--manifest-path" "Cargo.toml" "--no-deps", kill_on_drop: false }`
[INFO] started tweaking crates.io crate libpacket 0.1.2
[INFO] finished tweaking crates.io crate libpacket 0.1.2
[INFO] tweaked toml for crates.io crate libpacket 0.1.2 written to /workspace/builds/worker-2-tc1/source/Cargo.toml
[INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" __CARGO_TEST_CHANNEL_OVERRIDE_DO_NOT_USE_THIS="nightly" "/workspace/cargo-home/bin/cargo" "+1.69.0" "generate-lockfile" "--manifest-path" "Cargo.toml" "-Zno-index-update", kill_on_drop: false }`
[INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" "/workspace/cargo-home/bin/cargo" "+1.69.0" "fetch" "--manifest-path" "Cargo.toml", kill_on_drop: false }`
[INFO] [stderr]  Downloading crates ...
[INFO] [stderr]   Downloaded libpacket-core v0.1.0
[INFO] [stderr]   Downloaded libpacket-derive v0.1.1
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-2-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-2-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:5ff2268d62e97bff2cde7d5815dd6ed5b47097566f13b8d0ca110b04b60e07ed" "/opt/rustwide/cargo-home/bin/cargo" "+1.69.0" "metadata" "--no-deps" "--format-version=1", kill_on_drop: false }`
[INFO] [stdout] 79b1c5393adf9efb025eb40fb62c11413d0fd568e93223e0ca806f18de9025fd
[INFO] running `Command { std: "docker" "start" "-a" "79b1c5393adf9efb025eb40fb62c11413d0fd568e93223e0ca806f18de9025fd", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "inspect" "79b1c5393adf9efb025eb40fb62c11413d0fd568e93223e0ca806f18de9025fd", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "79b1c5393adf9efb025eb40fb62c11413d0fd568e93223e0ca806f18de9025fd", kill_on_drop: false }`
[INFO] [stdout] 79b1c5393adf9efb025eb40fb62c11413d0fd568e93223e0ca806f18de9025fd
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-2-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-2-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTFLAGS=--cap-lints=warn" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:5ff2268d62e97bff2cde7d5815dd6ed5b47097566f13b8d0ca110b04b60e07ed" "/opt/rustwide/cargo-home/bin/cargo" "+1.69.0" "doc" "--frozen" "--no-deps" "--document-private-items" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] 82fecfd0dd5a4d34b9b296afac0a4735976b7909aab6b3c3dd14efe0914ce33b
[INFO] running `Command { std: "docker" "start" "-a" "82fecfd0dd5a4d34b9b296afac0a4735976b7909aab6b3c3dd14efe0914ce33b", kill_on_drop: false }`
[INFO] [stderr]    Compiling memchr v2.5.0
[INFO] [stderr]    Compiling syn v1.0.109
[INFO] [stderr]    Compiling regex-syntax v0.7.1
[INFO] [stderr]     Checking libpacket-core v0.1.0
[INFO] [stderr]    Compiling aho-corasick v1.0.1
[INFO] [stderr]    Compiling regex v1.8.1
[INFO] [stderr]    Compiling libpacket-derive v0.1.1
[INFO] [stderr]  Documenting libpacket v0.1.2 (/opt/rustwide/workdir)
[INFO] [stdout] warning: unresolved link to `RFC7042`
[INFO] [stdout]   --> src/ethernet.rs:64:45
[INFO] [stdout]    |
[INFO] [stdout] 64 |     /// Internet Protocol version 4 (IPv4) [RFC7042].
[INFO] [stdout]    |                                             ^^^^^^^ no item named `RFC7042` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout]    = note: `#[warn(rustdoc::broken_intra_doc_links)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC7042`
[INFO] [stdout]   --> src/ethernet.rs:66:44
[INFO] [stdout]    |
[INFO] [stdout] 66 |     /// Address Resolution Protocol (ARP) [RFC7042].
[INFO] [stdout]    |                                            ^^^^^^^ no item named `RFC7042` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `IEEE`
[INFO] [stdout]   --> src/ethernet.rs:70:30
[INFO] [stdout]    |
[INFO] [stdout] 70 |     /// IETF TRILL Protocol [IEEE].
[INFO] [stdout]    |                              ^^^^ no item named `IEEE` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC903`
[INFO] [stdout]   --> src/ethernet.rs:74:53
[INFO] [stdout]    |
[INFO] [stdout] 74 |     /// Reverse Address Resolution Protocol (RARP) [RFC903].
[INFO] [stdout]    |                                                     ^^^^^^ no item named `RFC903` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `Apple`
[INFO] [stdout]   --> src/ethernet.rs:76:32
[INFO] [stdout]    |
[INFO] [stdout] 76 |     /// AppleTalk - EtherTalk [Apple].
[INFO] [stdout]    |                                ^^^^^ no item named `Apple` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `Apple`
[INFO] [stdout]   --> src/ethernet.rs:78:55
[INFO] [stdout]    |
[INFO] [stdout] 78 |     /// AppleTalk Address Resolution Protocol (AARP) [Apple].
[INFO] [stdout]    |                                                       ^^^^^ no item named `Apple` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `Xerox`
[INFO] [stdout]   --> src/ethernet.rs:80:14
[INFO] [stdout]    |
[INFO] [stdout] 80 |     /// IPX [Xerox].
[INFO] [stdout]    |              ^^^^^ no item named `Xerox` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC7042`
[INFO] [stdout]   --> src/ethernet.rs:84:45
[INFO] [stdout]    |
[INFO] [stdout] 84 |     /// Internet Protocol version 6 (IPv6) [RFC7042].
[INFO] [stdout]    |                                             ^^^^^^^ no item named `RFC7042` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2460`
[INFO] [stdout]   --> src/ip.rs:27:33
[INFO] [stdout]    |
[INFO] [stdout] 27 |     /// IPv6 Hop-by-Hop Option [RFC2460]
[INFO] [stdout]    |                                 ^^^^^^^ no item named `RFC2460` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC792`
[INFO] [stdout]   --> src/ip.rs:30:35
[INFO] [stdout]    |
[INFO] [stdout] 30 |     /// Internet Control Message [RFC792]
[INFO] [stdout]    |                                   ^^^^^^ no item named `RFC792` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC1112`
[INFO] [stdout]   --> src/ip.rs:33:36
[INFO] [stdout]    |
[INFO] [stdout] 33 |     /// Internet Group Management [RFC1112]
[INFO] [stdout]    |                                    ^^^^^^^ no item named `RFC1112` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC823`
[INFO] [stdout]   --> src/ip.rs:36:29
[INFO] [stdout]    |
[INFO] [stdout] 36 |     /// Gateway-to-Gateway [RFC823]
[INFO] [stdout]    |                             ^^^^^^ no item named `RFC823` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2003`
[INFO] [stdout]   --> src/ip.rs:39:29
[INFO] [stdout]    |
[INFO] [stdout] 39 |     /// IPv4 encapsulation [RFC2003]
[INFO] [stdout]    |                             ^^^^^^^ no item named `RFC2003` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC1819`
[INFO] [stdout]   --> src/ip.rs:42:26
[INFO] [stdout]    |
[INFO] [stdout] 42 |     /// Stream [RFC1190][RFC1819]
[INFO] [stdout]    |                          ^^^^^^^ no item named `RFC1819` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC793`
[INFO] [stdout]   --> src/ip.rs:45:31
[INFO] [stdout]    |
[INFO] [stdout] 45 |     /// Transmission Control [RFC793]
[INFO] [stdout]    |                               ^^^^^^ no item named `RFC793` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC888`
[INFO] [stdout]   --> src/ip.rs:51:36
[INFO] [stdout]    |
[INFO] [stdout] 51 |     /// Exterior Gateway Protocol [RFC888]
[INFO] [stdout]    |                                    ^^^^^^ no item named `RFC888` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC741`
[INFO] [stdout]   --> src/ip.rs:60:33
[INFO] [stdout]    |
[INFO] [stdout] 60 |     /// Network Voice Protocol [RFC741]
[INFO] [stdout]    |                                 ^^^^^^ no item named `RFC741` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC768`
[INFO] [stdout]   --> src/ip.rs:78:24
[INFO] [stdout]    |
[INFO] [stdout] 78 |     /// User Datagram [RFC768]
[INFO] [stdout]    |                        ^^^^^^ no item named `RFC768` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC869`
[INFO] [stdout]   --> src/ip.rs:87:26
[INFO] [stdout]    |
[INFO] [stdout] 87 |     /// Host Monitoring [RFC869]
[INFO] [stdout]    |                          ^^^^^^ no item named `RFC869` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC908`
[INFO] [stdout]    --> src/ip.rs:108:33
[INFO] [stdout]     |
[INFO] [stdout] 108 |     /// Reliable Data Protocol [RFC908]
[INFO] [stdout]     |                                 ^^^^^^ no item named `RFC908` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC938`
[INFO] [stdout]    --> src/ip.rs:111:40
[INFO] [stdout]     |
[INFO] [stdout] 111 |     /// Internet Reliable Transaction [RFC938]
[INFO] [stdout]     |                                        ^^^^^^ no item named `RFC938` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC905`
[INFO] [stdout]    --> src/ip.rs:114:41
[INFO] [stdout]     |
[INFO] [stdout] 114 |     /// ISO Transport Protocol Class 4 [RFC905]
[INFO] [stdout]     |                                         ^^^^^^ no item named `RFC905` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC969`
[INFO] [stdout]    --> src/ip.rs:117:38
[INFO] [stdout]     |
[INFO] [stdout] 117 |     /// Bulk Data Transfer Protocol [RFC969]
[INFO] [stdout]     |                                      ^^^^^^ no item named `RFC969` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4340`
[INFO] [stdout]    --> src/ip.rs:126:47
[INFO] [stdout]     |
[INFO] [stdout] 126 |     /// Datagram Congestion Control Protocol [RFC4340]
[INFO] [stdout]     |                                               ^^^^^^^ no item named `RFC4340` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2473`
[INFO] [stdout]    --> src/ip.rs:150:29
[INFO] [stdout]     |
[INFO] [stdout] 150 |     /// IPv6 encapsulation [RFC2473]
[INFO] [stdout]     |                             ^^^^^^^ no item named `RFC2473` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3209`
[INFO] [stdout]    --> src/ip.rs:165:40
[INFO] [stdout]     |
[INFO] [stdout] 165 |     /// Reservation Protocol [RFC2205][RFC3209]
[INFO] [stdout]     |                                        ^^^^^^^ no item named `RFC3209` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC1701`
[INFO] [stdout]    --> src/ip.rs:168:40
[INFO] [stdout]     |
[INFO] [stdout] 168 |     /// Generic Routing Encapsulation [RFC1701]
[INFO] [stdout]     |                                        ^^^^^^^ no item named `RFC1701` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4728`
[INFO] [stdout]    --> src/ip.rs:171:42
[INFO] [stdout]     |
[INFO] [stdout] 171 |     /// Dynamic Source Routing Protocol [RFC4728]
[INFO] [stdout]     |                                          ^^^^^^^ no item named `RFC4728` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4303`
[INFO] [stdout]    --> src/ip.rs:177:33
[INFO] [stdout]     |
[INFO] [stdout] 177 |     /// Encap Security Payload [RFC4303]
[INFO] [stdout]     |                                 ^^^^^^^ no item named `RFC4303` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4302`
[INFO] [stdout]    --> src/ip.rs:180:32
[INFO] [stdout]     |
[INFO] [stdout] 180 |     /// Authentication Header [RFC4302]
[INFO] [stdout]     |                                ^^^^^^^ no item named `RFC4302` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC1735`
[INFO] [stdout]    --> src/ip.rs:189:43
[INFO] [stdout]     |
[INFO] [stdout] 189 |     /// NBMA Address Resolution Protocol [RFC1735]
[INFO] [stdout]     |                                           ^^^^^^^ no item named `RFC1735` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4443`
[INFO] [stdout]    --> src/ip.rs:204:17
[INFO] [stdout]     |
[INFO] [stdout] 204 |     /// ICMPv6 [RFC4443]
[INFO] [stdout]     |                 ^^^^^^^ no item named `RFC4443` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2460`
[INFO] [stdout]    --> src/ip.rs:207:34
[INFO] [stdout]     |
[INFO] [stdout] 207 |     /// No Next Header for IPv6 [RFC2460]
[INFO] [stdout]     |                                  ^^^^^^^ no item named `RFC2460` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2460`
[INFO] [stdout]    --> src/ip.rs:210:39
[INFO] [stdout]     |
[INFO] [stdout] 210 |     /// Destination Options for IPv6 [RFC2460]
[INFO] [stdout]     |                                       ^^^^^^^ no item named `RFC2460` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2328`
[INFO] [stdout]    --> src/ip.rs:297:27
[INFO] [stdout]     |
[INFO] [stdout] 297 |     /// OSPFIGP [RFC1583][RFC2328][RFC5340]
[INFO] [stdout]     |                           ^^^^^^^ no item named `RFC2328` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5340`
[INFO] [stdout]    --> src/ip.rs:297:36
[INFO] [stdout]     |
[INFO] [stdout] 297 |     /// OSPFIGP [RFC1583][RFC2328][RFC5340]
[INFO] [stdout]     |                                    ^^^^^^^ no item named `RFC5340` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3378`
[INFO] [stdout]    --> src/ip.rs:321:43
[INFO] [stdout]     |
[INFO] [stdout] 321 |     /// Ethernet-within-IP Encapsulation [RFC3378]
[INFO] [stdout]     |                                           ^^^^^^^ no item named `RFC3378` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC1241`
[INFO] [stdout]    --> src/ip.rs:324:31
[INFO] [stdout]     |
[INFO] [stdout] 324 |     /// Encapsulation Header [RFC1241]
[INFO] [stdout]     |                               ^^^^^^^ no item named `RFC1241` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4601`
[INFO] [stdout]    --> src/ip.rs:339:41
[INFO] [stdout]     |
[INFO] [stdout] 339 |     /// Protocol Independent Multicast [RFC4601]
[INFO] [stdout]     |                                         ^^^^^^^ no item named `RFC4601` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2393`
[INFO] [stdout]    --> src/ip.rs:354:42
[INFO] [stdout]     |
[INFO] [stdout] 354 |     /// IP Payload Compression Protocol [RFC2393]
[INFO] [stdout]     |                                          ^^^^^^^ no item named `RFC2393` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5798`
[INFO] [stdout]    --> src/ip.rs:366:45
[INFO] [stdout]     |
[INFO] [stdout] 366 |     /// Virtual Router Redundancy Protocol [RFC5798]
[INFO] [stdout]     |                                             ^^^^^^^ no item named `RFC5798` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3931`
[INFO] [stdout]    --> src/ip.rs:375:39
[INFO] [stdout]     |
[INFO] [stdout] 375 |     /// Layer Two Tunneling Protocol [RFC3931]
[INFO] [stdout]     |                                       ^^^^^^^ no item named `RFC3931` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6172`
[INFO] [stdout]    --> src/ip.rs:429:24
[INFO] [stdout]     |
[INFO] [stdout] 429 |     /// Fibre Channel [RFC6172]
[INFO] [stdout]     |                        ^^^^^^^ no item named `RFC6172` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3175`
[INFO] [stdout]    --> src/ip.rs:432:10
[INFO] [stdout]     |
[INFO] [stdout] 432 |     /// [RFC3175]
[INFO] [stdout]     |          ^^^^^^^ no item named `RFC3175` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6275`
[INFO] [stdout]    --> src/ip.rs:435:10
[INFO] [stdout]     |
[INFO] [stdout] 435 |     /// [RFC6275]
[INFO] [stdout]     |          ^^^^^^^ no item named `RFC6275` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3828`
[INFO] [stdout]    --> src/ip.rs:438:10
[INFO] [stdout]     |
[INFO] [stdout] 438 |     /// [RFC3828]
[INFO] [stdout]     |          ^^^^^^^ no item named `RFC3828` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4023`
[INFO] [stdout]    --> src/ip.rs:441:10
[INFO] [stdout]     |
[INFO] [stdout] 441 |     /// [RFC4023]
[INFO] [stdout]     |          ^^^^^^^ no item named `RFC4023` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5498`
[INFO] [stdout]    --> src/ip.rs:444:26
[INFO] [stdout]     |
[INFO] [stdout] 444 |     /// MANET Protocols [RFC5498]
[INFO] [stdout]     |                          ^^^^^^^ no item named `RFC5498` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5201`
[INFO] [stdout]    --> src/ip.rs:447:33
[INFO] [stdout]     |
[INFO] [stdout] 447 |     /// Host Identity Protocol [RFC5201]
[INFO] [stdout]     |                                 ^^^^^^^ no item named `RFC5201` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5533`
[INFO] [stdout]    --> src/ip.rs:450:25
[INFO] [stdout]     |
[INFO] [stdout] 450 |     /// Shim6 Protocol [RFC5533]
[INFO] [stdout]     |                         ^^^^^^^ no item named `RFC5533` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5840`
[INFO] [stdout]    --> src/ip.rs:453:49
[INFO] [stdout]     |
[INFO] [stdout] 453 |     /// Wrapped Encapsulating Security Payload [RFC5840]
[INFO] [stdout]     |                                                 ^^^^^^^ no item named `RFC5840` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5858`
[INFO] [stdout]    --> src/ip.rs:456:36
[INFO] [stdout]     |
[INFO] [stdout] 456 |     /// Robust Header Compression [RFC5858]
[INFO] [stdout]     |                                    ^^^^^^^ no item named `RFC5858` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3692`
[INFO] [stdout]    --> src/ip.rs:459:46
[INFO] [stdout]     |
[INFO] [stdout] 459 |     /// Use for experimentation and testing [RFC3692]
[INFO] [stdout]     |                                              ^^^^^^^ no item named `RFC3692` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3692`
[INFO] [stdout]    --> src/ip.rs:462:46
[INFO] [stdout]     |
[INFO] [stdout] 462 |     /// Use for experimentation and testing [RFC3692]
[INFO] [stdout]     |                                              ^^^^^^^ no item named `RFC3692` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/ethernet.rs:54:5
[INFO] [stdout]    |
[INFO] [stdout] 54 | /// http://www.iana.org/assignments/ieee-802-numbers/ieee-802-numbers.xhtml.
[INFO] [stdout]    |     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<http://www.iana.org/assignments/ieee-802-numbers/ieee-802-numbers.xhtml.>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout]    = note: `#[warn(rustdoc::bare_urls)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/ip.rs:16:5
[INFO] [stdout]    |
[INFO] [stdout] 16 | /// http://www.iana.org/assignments/protocol-numbers/protocol-numbers.xhtml
[INFO] [stdout]    |     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<http://www.iana.org/assignments/protocol-numbers/protocol-numbers.xhtml>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/ipv4.rs:28:5
[INFO] [stdout]    |
[INFO] [stdout] 28 | /// http://www.iana.org/assignments/ip-parameters/ip-parameters.xhtml
[INFO] [stdout]    |     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<http://www.iana.org/assignments/ip-parameters/ip-parameters.xhtml>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/vlan.rs:25:5
[INFO] [stdout]    |
[INFO] [stdout] 25 | /// https://en.wikipedia.org/wiki/IEEE_P802.1p.
[INFO] [stdout]    |     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://en.wikipedia.org/wiki/IEEE_P802.1p.>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: 58 warnings emitted
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr]     Finished dev [unoptimized + debuginfo] target(s) in 6.69s
[INFO] running `Command { std: "docker" "inspect" "82fecfd0dd5a4d34b9b296afac0a4735976b7909aab6b3c3dd14efe0914ce33b", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "82fecfd0dd5a4d34b9b296afac0a4735976b7909aab6b3c3dd14efe0914ce33b", kill_on_drop: false }`
[INFO] [stdout] 82fecfd0dd5a4d34b9b296afac0a4735976b7909aab6b3c3dd14efe0914ce33b
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-2-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-2-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTFLAGS=--cap-lints=warn" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "DOCS_RS=1" "-e" "RUSTC_BOOTSTRAP=1" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:5ff2268d62e97bff2cde7d5815dd6ed5b47097566f13b8d0ca110b04b60e07ed" "/opt/rustwide/cargo-home/bin/cargo" "+1.69.0" "rustdoc" "--lib" "-Zrustdoc-map" "-Z" "unstable-options" "--config" "build.rustdocflags=[\"-Z\", \"unstable-options\", \"--document-private-items\"]" "--frozen" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] 397ee52a9017294d228e9334fe0398f6b489ecddd136b24dd1c74f4de6104f2f
[INFO] running `Command { std: "docker" "start" "-a" "397ee52a9017294d228e9334fe0398f6b489ecddd136b24dd1c74f4de6104f2f", kill_on_drop: false }`
[INFO] [stderr]  Documenting libpacket v0.1.2 (/opt/rustwide/workdir)
[INFO] [stdout] warning: unresolved link to `RFC7042`
[INFO] [stdout]   --> src/ethernet.rs:64:45
[INFO] [stdout]    |
[INFO] [stdout] 64 |     /// Internet Protocol version 4 (IPv4) [RFC7042].
[INFO] [stdout]    |                                             ^^^^^^^ no item named `RFC7042` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout]    = note: `#[warn(rustdoc::broken_intra_doc_links)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC7042`
[INFO] [stdout]   --> src/ethernet.rs:66:44
[INFO] [stdout]    |
[INFO] [stdout] 66 |     /// Address Resolution Protocol (ARP) [RFC7042].
[INFO] [stdout]    |                                            ^^^^^^^ no item named `RFC7042` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `IEEE`
[INFO] [stdout]   --> src/ethernet.rs:70:30
[INFO] [stdout]    |
[INFO] [stdout] 70 |     /// IETF TRILL Protocol [IEEE].
[INFO] [stdout]    |                              ^^^^ no item named `IEEE` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC903`
[INFO] [stdout]   --> src/ethernet.rs:74:53
[INFO] [stdout]    |
[INFO] [stdout] 74 |     /// Reverse Address Resolution Protocol (RARP) [RFC903].
[INFO] [stdout]    |                                                     ^^^^^^ no item named `RFC903` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `Apple`
[INFO] [stdout]   --> src/ethernet.rs:76:32
[INFO] [stdout]    |
[INFO] [stdout] 76 |     /// AppleTalk - EtherTalk [Apple].
[INFO] [stdout]    |                                ^^^^^ no item named `Apple` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `Apple`
[INFO] [stdout]   --> src/ethernet.rs:78:55
[INFO] [stdout]    |
[INFO] [stdout] 78 |     /// AppleTalk Address Resolution Protocol (AARP) [Apple].
[INFO] [stdout]    |                                                       ^^^^^ no item named `Apple` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `Xerox`
[INFO] [stdout]   --> src/ethernet.rs:80:14
[INFO] [stdout]    |
[INFO] [stdout] 80 |     /// IPX [Xerox].
[INFO] [stdout]    |              ^^^^^ no item named `Xerox` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC7042`
[INFO] [stdout]   --> src/ethernet.rs:84:45
[INFO] [stdout]    |
[INFO] [stdout] 84 |     /// Internet Protocol version 6 (IPv6) [RFC7042].
[INFO] [stdout]    |                                             ^^^^^^^ no item named `RFC7042` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2460`
[INFO] [stdout]   --> src/ip.rs:27:33
[INFO] [stdout]    |
[INFO] [stdout] 27 |     /// IPv6 Hop-by-Hop Option [RFC2460]
[INFO] [stdout]    |                                 ^^^^^^^ no item named `RFC2460` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC792`
[INFO] [stdout]   --> src/ip.rs:30:35
[INFO] [stdout]    |
[INFO] [stdout] 30 |     /// Internet Control Message [RFC792]
[INFO] [stdout]    |                                   ^^^^^^ no item named `RFC792` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC1112`
[INFO] [stdout]   --> src/ip.rs:33:36
[INFO] [stdout]    |
[INFO] [stdout] 33 |     /// Internet Group Management [RFC1112]
[INFO] [stdout]    |                                    ^^^^^^^ no item named `RFC1112` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC823`
[INFO] [stdout]   --> src/ip.rs:36:29
[INFO] [stdout]    |
[INFO] [stdout] 36 |     /// Gateway-to-Gateway [RFC823]
[INFO] [stdout]    |                             ^^^^^^ no item named `RFC823` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2003`
[INFO] [stdout]   --> src/ip.rs:39:29
[INFO] [stdout]    |
[INFO] [stdout] 39 |     /// IPv4 encapsulation [RFC2003]
[INFO] [stdout]    |                             ^^^^^^^ no item named `RFC2003` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC1819`
[INFO] [stdout]   --> src/ip.rs:42:26
[INFO] [stdout]    |
[INFO] [stdout] 42 |     /// Stream [RFC1190][RFC1819]
[INFO] [stdout]    |                          ^^^^^^^ no item named `RFC1819` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC793`
[INFO] [stdout]   --> src/ip.rs:45:31
[INFO] [stdout]    |
[INFO] [stdout] 45 |     /// Transmission Control [RFC793]
[INFO] [stdout]    |                               ^^^^^^ no item named `RFC793` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC888`
[INFO] [stdout]   --> src/ip.rs:51:36
[INFO] [stdout]    |
[INFO] [stdout] 51 |     /// Exterior Gateway Protocol [RFC888]
[INFO] [stdout]    |                                    ^^^^^^ no item named `RFC888` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC741`
[INFO] [stdout]   --> src/ip.rs:60:33
[INFO] [stdout]    |
[INFO] [stdout] 60 |     /// Network Voice Protocol [RFC741]
[INFO] [stdout]    |                                 ^^^^^^ no item named `RFC741` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC768`
[INFO] [stdout]   --> src/ip.rs:78:24
[INFO] [stdout]    |
[INFO] [stdout] 78 |     /// User Datagram [RFC768]
[INFO] [stdout]    |                        ^^^^^^ no item named `RFC768` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC869`
[INFO] [stdout]   --> src/ip.rs:87:26
[INFO] [stdout]    |
[INFO] [stdout] 87 |     /// Host Monitoring [RFC869]
[INFO] [stdout]    |                          ^^^^^^ no item named `RFC869` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC908`
[INFO] [stdout]    --> src/ip.rs:108:33
[INFO] [stdout]     |
[INFO] [stdout] 108 |     /// Reliable Data Protocol [RFC908]
[INFO] [stdout]     |                                 ^^^^^^ no item named `RFC908` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC938`
[INFO] [stdout]    --> src/ip.rs:111:40
[INFO] [stdout]     |
[INFO] [stdout] 111 |     /// Internet Reliable Transaction [RFC938]
[INFO] [stdout]     |                                        ^^^^^^ no item named `RFC938` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC905`
[INFO] [stdout]    --> src/ip.rs:114:41
[INFO] [stdout]     |
[INFO] [stdout] 114 |     /// ISO Transport Protocol Class 4 [RFC905]
[INFO] [stdout]     |                                         ^^^^^^ no item named `RFC905` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC969`
[INFO] [stdout]    --> src/ip.rs:117:38
[INFO] [stdout]     |
[INFO] [stdout] 117 |     /// Bulk Data Transfer Protocol [RFC969]
[INFO] [stdout]     |                                      ^^^^^^ no item named `RFC969` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4340`
[INFO] [stdout]    --> src/ip.rs:126:47
[INFO] [stdout]     |
[INFO] [stdout] 126 |     /// Datagram Congestion Control Protocol [RFC4340]
[INFO] [stdout]     |                                               ^^^^^^^ no item named `RFC4340` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2473`
[INFO] [stdout]    --> src/ip.rs:150:29
[INFO] [stdout]     |
[INFO] [stdout] 150 |     /// IPv6 encapsulation [RFC2473]
[INFO] [stdout]     |                             ^^^^^^^ no item named `RFC2473` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3209`
[INFO] [stdout]    --> src/ip.rs:165:40
[INFO] [stdout]     |
[INFO] [stdout] 165 |     /// Reservation Protocol [RFC2205][RFC3209]
[INFO] [stdout]     |                                        ^^^^^^^ no item named `RFC3209` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC1701`
[INFO] [stdout]    --> src/ip.rs:168:40
[INFO] [stdout]     |
[INFO] [stdout] 168 |     /// Generic Routing Encapsulation [RFC1701]
[INFO] [stdout]     |                                        ^^^^^^^ no item named `RFC1701` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4728`
[INFO] [stdout]    --> src/ip.rs:171:42
[INFO] [stdout]     |
[INFO] [stdout] 171 |     /// Dynamic Source Routing Protocol [RFC4728]
[INFO] [stdout]     |                                          ^^^^^^^ no item named `RFC4728` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4303`
[INFO] [stdout]    --> src/ip.rs:177:33
[INFO] [stdout]     |
[INFO] [stdout] 177 |     /// Encap Security Payload [RFC4303]
[INFO] [stdout]     |                                 ^^^^^^^ no item named `RFC4303` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4302`
[INFO] [stdout]    --> src/ip.rs:180:32
[INFO] [stdout]     |
[INFO] [stdout] 180 |     /// Authentication Header [RFC4302]
[INFO] [stdout]     |                                ^^^^^^^ no item named `RFC4302` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC1735`
[INFO] [stdout]    --> src/ip.rs:189:43
[INFO] [stdout]     |
[INFO] [stdout] 189 |     /// NBMA Address Resolution Protocol [RFC1735]
[INFO] [stdout]     |                                           ^^^^^^^ no item named `RFC1735` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4443`
[INFO] [stdout]    --> src/ip.rs:204:17
[INFO] [stdout]     |
[INFO] [stdout] 204 |     /// ICMPv6 [RFC4443]
[INFO] [stdout]     |                 ^^^^^^^ no item named `RFC4443` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2460`
[INFO] [stdout]    --> src/ip.rs:207:34
[INFO] [stdout]     |
[INFO] [stdout] 207 |     /// No Next Header for IPv6 [RFC2460]
[INFO] [stdout]     |                                  ^^^^^^^ no item named `RFC2460` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2460`
[INFO] [stdout]    --> src/ip.rs:210:39
[INFO] [stdout]     |
[INFO] [stdout] 210 |     /// Destination Options for IPv6 [RFC2460]
[INFO] [stdout]     |                                       ^^^^^^^ no item named `RFC2460` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2328`
[INFO] [stdout]    --> src/ip.rs:297:27
[INFO] [stdout]     |
[INFO] [stdout] 297 |     /// OSPFIGP [RFC1583][RFC2328][RFC5340]
[INFO] [stdout]     |                           ^^^^^^^ no item named `RFC2328` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5340`
[INFO] [stdout]    --> src/ip.rs:297:36
[INFO] [stdout]     |
[INFO] [stdout] 297 |     /// OSPFIGP [RFC1583][RFC2328][RFC5340]
[INFO] [stdout]     |                                    ^^^^^^^ no item named `RFC5340` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3378`
[INFO] [stdout]    --> src/ip.rs:321:43
[INFO] [stdout]     |
[INFO] [stdout] 321 |     /// Ethernet-within-IP Encapsulation [RFC3378]
[INFO] [stdout]     |                                           ^^^^^^^ no item named `RFC3378` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC1241`
[INFO] [stdout]    --> src/ip.rs:324:31
[INFO] [stdout]     |
[INFO] [stdout] 324 |     /// Encapsulation Header [RFC1241]
[INFO] [stdout]     |                               ^^^^^^^ no item named `RFC1241` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4601`
[INFO] [stdout]    --> src/ip.rs:339:41
[INFO] [stdout]     |
[INFO] [stdout] 339 |     /// Protocol Independent Multicast [RFC4601]
[INFO] [stdout]     |                                         ^^^^^^^ no item named `RFC4601` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2393`
[INFO] [stdout]    --> src/ip.rs:354:42
[INFO] [stdout]     |
[INFO] [stdout] 354 |     /// IP Payload Compression Protocol [RFC2393]
[INFO] [stdout]     |                                          ^^^^^^^ no item named `RFC2393` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5798`
[INFO] [stdout]    --> src/ip.rs:366:45
[INFO] [stdout]     |
[INFO] [stdout] 366 |     /// Virtual Router Redundancy Protocol [RFC5798]
[INFO] [stdout]     |                                             ^^^^^^^ no item named `RFC5798` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3931`
[INFO] [stdout]    --> src/ip.rs:375:39
[INFO] [stdout]     |
[INFO] [stdout] 375 |     /// Layer Two Tunneling Protocol [RFC3931]
[INFO] [stdout]     |                                       ^^^^^^^ no item named `RFC3931` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6172`
[INFO] [stdout]    --> src/ip.rs:429:24
[INFO] [stdout]     |
[INFO] [stdout] 429 |     /// Fibre Channel [RFC6172]
[INFO] [stdout]     |                        ^^^^^^^ no item named `RFC6172` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3175`
[INFO] [stdout]    --> src/ip.rs:432:10
[INFO] [stdout]     |
[INFO] [stdout] 432 |     /// [RFC3175]
[INFO] [stdout]     |          ^^^^^^^ no item named `RFC3175` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6275`
[INFO] [stdout]    --> src/ip.rs:435:10
[INFO] [stdout]     |
[INFO] [stdout] 435 |     /// [RFC6275]
[INFO] [stdout]     |          ^^^^^^^ no item named `RFC6275` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3828`
[INFO] [stdout]    --> src/ip.rs:438:10
[INFO] [stdout]     |
[INFO] [stdout] 438 |     /// [RFC3828]
[INFO] [stdout]     |          ^^^^^^^ no item named `RFC3828` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4023`
[INFO] [stdout]    --> src/ip.rs:441:10
[INFO] [stdout]     |
[INFO] [stdout] 441 |     /// [RFC4023]
[INFO] [stdout]     |          ^^^^^^^ no item named `RFC4023` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5498`
[INFO] [stdout]    --> src/ip.rs:444:26
[INFO] [stdout]     |
[INFO] [stdout] 444 |     /// MANET Protocols [RFC5498]
[INFO] [stdout]     |                          ^^^^^^^ no item named `RFC5498` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5201`
[INFO] [stdout]    --> src/ip.rs:447:33
[INFO] [stdout]     |
[INFO] [stdout] 447 |     /// Host Identity Protocol [RFC5201]
[INFO] [stdout]     |                                 ^^^^^^^ no item named `RFC5201` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5533`
[INFO] [stdout]    --> src/ip.rs:450:25
[INFO] [stdout]     |
[INFO] [stdout] 450 |     /// Shim6 Protocol [RFC5533]
[INFO] [stdout]     |                         ^^^^^^^ no item named `RFC5533` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5840`
[INFO] [stdout]    --> src/ip.rs:453:49
[INFO] [stdout]     |
[INFO] [stdout] 453 |     /// Wrapped Encapsulating Security Payload [RFC5840]
[INFO] [stdout]     |                                                 ^^^^^^^ no item named `RFC5840` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5858`
[INFO] [stdout]    --> src/ip.rs:456:36
[INFO] [stdout]     |
[INFO] [stdout] 456 |     /// Robust Header Compression [RFC5858]
[INFO] [stdout]     |                                    ^^^^^^^ no item named `RFC5858` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3692`
[INFO] [stdout]    --> src/ip.rs:459:46
[INFO] [stdout]     |
[INFO] [stdout] 459 |     /// Use for experimentation and testing [RFC3692]
[INFO] [stdout]     |                                              ^^^^^^^ no item named `RFC3692` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3692`
[INFO] [stdout]    --> src/ip.rs:462:46
[INFO] [stdout]     |
[INFO] [stdout] 462 |     /// Use for experimentation and testing [RFC3692]
[INFO] [stdout]     |                                              ^^^^^^^ no item named `RFC3692` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/ethernet.rs:54:5
[INFO] [stdout]    |
[INFO] [stdout] 54 | /// http://www.iana.org/assignments/ieee-802-numbers/ieee-802-numbers.xhtml.
[INFO] [stdout]    |     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<http://www.iana.org/assignments/ieee-802-numbers/ieee-802-numbers.xhtml.>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout]    = note: `#[warn(rustdoc::bare_urls)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/ip.rs:16:5
[INFO] [stdout]    |
[INFO] [stdout] 16 | /// http://www.iana.org/assignments/protocol-numbers/protocol-numbers.xhtml
[INFO] [stdout]    |     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<http://www.iana.org/assignments/protocol-numbers/protocol-numbers.xhtml>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/ipv4.rs:28:5
[INFO] [stdout]    |
[INFO] [stdout] 28 | /// http://www.iana.org/assignments/ip-parameters/ip-parameters.xhtml
[INFO] [stdout]    |     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<http://www.iana.org/assignments/ip-parameters/ip-parameters.xhtml>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/vlan.rs:25:5
[INFO] [stdout]    |
[INFO] [stdout] 25 | /// https://en.wikipedia.org/wiki/IEEE_P802.1p.
[INFO] [stdout]    |     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://en.wikipedia.org/wiki/IEEE_P802.1p.>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: 58 warnings emitted
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr]     Finished dev [unoptimized + debuginfo] target(s) in 2.79s
[INFO] running `Command { std: "docker" "inspect" "397ee52a9017294d228e9334fe0398f6b489ecddd136b24dd1c74f4de6104f2f", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "397ee52a9017294d228e9334fe0398f6b489ecddd136b24dd1c74f4de6104f2f", kill_on_drop: false }`
[INFO] [stdout] 397ee52a9017294d228e9334fe0398f6b489ecddd136b24dd1c74f4de6104f2f
