[INFO] fetching crate bgp-rs 0.6.0...
[INFO] documenting bgp-rs-0.6.0 against 1.69.0 for beta-1.70-rustdoc-1
[INFO] extracting crate bgp-rs 0.6.0 into /workspace/builds/worker-1-tc1/source
[INFO] validating manifest of crates.io crate bgp-rs 0.6.0 on toolchain 1.69.0
[INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" "/workspace/cargo-home/bin/cargo" "+1.69.0" "metadata" "--manifest-path" "Cargo.toml" "--no-deps", kill_on_drop: false }`
[INFO] started tweaking crates.io crate bgp-rs 0.6.0
[INFO] finished tweaking crates.io crate bgp-rs 0.6.0
[INFO] tweaked toml for crates.io crate bgp-rs 0.6.0 written to /workspace/builds/worker-1-tc1/source/Cargo.toml
[INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" __CARGO_TEST_CHANNEL_OVERRIDE_DO_NOT_USE_THIS="nightly" "/workspace/cargo-home/bin/cargo" "+1.69.0" "generate-lockfile" "--manifest-path" "Cargo.toml" "-Zno-index-update", kill_on_drop: false }`
[INFO] running `Command { std: CARGO_HOME="/workspace/cargo-home" RUSTUP_HOME="/workspace/rustup-home" "/workspace/cargo-home/bin/cargo" "+1.69.0" "fetch" "--manifest-path" "Cargo.toml", kill_on_drop: false }`
[INFO] [stderr]  Downloading crates ...
[INFO] [stderr]   Downloaded take_mut v0.2.2
[INFO] [stderr]   Downloaded unicode-xid v0.0.4
[INFO] [stderr]   Downloaded rle-decode-fast v1.0.3
[INFO] [stderr]   Downloaded quote v0.3.15
[INFO] [stderr]   Downloaded synom v0.11.3
[INFO] [stderr]   Downloaded derive-into-owned v0.1.0
[INFO] [stderr]   Downloaded libflate v0.1.27
[INFO] [stderr]   Downloaded pcap-file v1.1.1
[INFO] [stderr]   Downloaded mrt-rs v2.0.1
[INFO] [stderr]   Downloaded twoway v0.2.2
[INFO] [stderr]   Downloaded syn v0.11.11
[INFO] [stderr]   Downloaded etherparse v0.9.0
[INFO] [stderr]   Downloaded unchecked-index v0.2.2
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-1-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-1-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:5ff2268d62e97bff2cde7d5815dd6ed5b47097566f13b8d0ca110b04b60e07ed" "/opt/rustwide/cargo-home/bin/cargo" "+1.69.0" "metadata" "--no-deps" "--format-version=1", kill_on_drop: false }`
[INFO] [stdout] 948c2c8769ed3e52ce6d7b1400cb612e086bcd3ccd2f9856ffa0eea9e979aa7c
[INFO] running `Command { std: "docker" "start" "-a" "948c2c8769ed3e52ce6d7b1400cb612e086bcd3ccd2f9856ffa0eea9e979aa7c", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "inspect" "948c2c8769ed3e52ce6d7b1400cb612e086bcd3ccd2f9856ffa0eea9e979aa7c", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "948c2c8769ed3e52ce6d7b1400cb612e086bcd3ccd2f9856ffa0eea9e979aa7c", kill_on_drop: false }`
[INFO] [stdout] 948c2c8769ed3e52ce6d7b1400cb612e086bcd3ccd2f9856ffa0eea9e979aa7c
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-1-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-1-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTFLAGS=--cap-lints=warn" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:5ff2268d62e97bff2cde7d5815dd6ed5b47097566f13b8d0ca110b04b60e07ed" "/opt/rustwide/cargo-home/bin/cargo" "+1.69.0" "doc" "--frozen" "--no-deps" "--document-private-items" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] eb3c25073200075083ab6e33014845f147a912a010ae8292d1c0e2aaa68ecbde
[INFO] running `Command { std: "docker" "start" "-a" "eb3c25073200075083ab6e33014845f147a912a010ae8292d1c0e2aaa68ecbde", kill_on_drop: false }`
[INFO] [stderr]     Checking byteorder v1.4.3
[INFO] [stderr]  Documenting bgp-rs v0.6.0 (/opt/rustwide/workdir)
[INFO] [stdout] warning: unresolved link to `RFC4271`
[INFO] [stdout]   --> src/notification.rs:11:27
[INFO] [stdout]    |
[INFO] [stdout] 11 |     /// Major Error Code [RFC4271]
[INFO] [stdout]    |                           ^^^^^^^ no item named `RFC4271` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout]    = note: `#[warn(rustdoc::broken_intra_doc_links)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4271`
[INFO] [stdout]   --> src/notification.rs:13:27
[INFO] [stdout]    |
[INFO] [stdout] 13 |     /// Minor Error Code [RFC4271]
[INFO] [stdout]    |                           ^^^^^^^ no item named `RFC4271` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4760`
[INFO] [stdout]    --> src/lib.rs:183:29
[INFO] [stdout]     |
[INFO] [stdout] 183 |     /// Unicast Forwarding [RFC4760]
[INFO] [stdout]     |                             ^^^^^^^ no item named `RFC4760` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4760`
[INFO] [stdout]    --> src/lib.rs:185:31
[INFO] [stdout]     |
[INFO] [stdout] 185 |     /// Multicast Forwarding [RFC4760]
[INFO] [stdout]     |                               ^^^^^^^ no item named `RFC4760` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3107`
[INFO] [stdout]    --> src/lib.rs:187:22
[INFO] [stdout]     |
[INFO] [stdout] 187 |     /// MPLS Labels [RFC3107]
[INFO] [stdout]     |                      ^^^^^^^ no item named `RFC3107` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC7752`
[INFO] [stdout]    --> src/lib.rs:195:17
[INFO] [stdout]     |
[INFO] [stdout] 195 |     /// BGP LS [RFC7752]
[INFO] [stdout]     |                 ^^^^^^^ no item named `RFC7752` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC7752`
[INFO] [stdout]    --> src/lib.rs:197:21
[INFO] [stdout]     |
[INFO] [stdout] 197 |     /// BGP LS VPN [RFC7752]
[INFO] [stdout]     |                     ^^^^^^^ no item named `RFC7752` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4684`
[INFO] [stdout]    --> src/lib.rs:199:14
[INFO] [stdout]     |
[INFO] [stdout] 199 |     /// RTC [RFC4684]
[INFO] [stdout]     |              ^^^^^^^ no item named `RFC4684` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4364`
[INFO] [stdout]    --> src/lib.rs:201:19
[INFO] [stdout]     |
[INFO] [stdout] 201 |     /// MPLS VPN [RFC4364]
[INFO] [stdout]     |                   ^^^^^^^ no item named `RFC4364` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: 9 warnings emitted
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr]     Finished dev [unoptimized + debuginfo] target(s) in 0.96s
[INFO] running `Command { std: "docker" "inspect" "eb3c25073200075083ab6e33014845f147a912a010ae8292d1c0e2aaa68ecbde", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "eb3c25073200075083ab6e33014845f147a912a010ae8292d1c0e2aaa68ecbde", kill_on_drop: false }`
[INFO] [stdout] eb3c25073200075083ab6e33014845f147a912a010ae8292d1c0e2aaa68ecbde
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-1-tc1/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-1-tc1/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTFLAGS=--cap-lints=warn" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "RUSTC_BOOTSTRAP=1" "-e" "DOCS_RS=1" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:5ff2268d62e97bff2cde7d5815dd6ed5b47097566f13b8d0ca110b04b60e07ed" "/opt/rustwide/cargo-home/bin/cargo" "+1.69.0" "rustdoc" "--lib" "-Zrustdoc-map" "-Z" "unstable-options" "--config" "build.rustdocflags=[\"-Z\", \"unstable-options\", \"--document-private-items\"]" "--frozen" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] 7368f24a23b8e46c6eb35c0a694e8572119672bccf7ce491417996602206c762
[INFO] running `Command { std: "docker" "start" "-a" "7368f24a23b8e46c6eb35c0a694e8572119672bccf7ce491417996602206c762", kill_on_drop: false }`
[INFO] [stderr]  Documenting bgp-rs v0.6.0 (/opt/rustwide/workdir)
[INFO] [stdout] warning: unresolved link to `RFC4271`
[INFO] [stdout]   --> src/notification.rs:11:27
[INFO] [stdout]    |
[INFO] [stdout] 11 |     /// Major Error Code [RFC4271]
[INFO] [stdout]    |                           ^^^^^^^ no item named `RFC4271` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout]    = note: `#[warn(rustdoc::broken_intra_doc_links)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4271`
[INFO] [stdout]   --> src/notification.rs:13:27
[INFO] [stdout]    |
[INFO] [stdout] 13 |     /// Minor Error Code [RFC4271]
[INFO] [stdout]    |                           ^^^^^^^ no item named `RFC4271` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4760`
[INFO] [stdout]    --> src/lib.rs:183:29
[INFO] [stdout]     |
[INFO] [stdout] 183 |     /// Unicast Forwarding [RFC4760]
[INFO] [stdout]     |                             ^^^^^^^ no item named `RFC4760` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4760`
[INFO] [stdout]    --> src/lib.rs:185:31
[INFO] [stdout]     |
[INFO] [stdout] 185 |     /// Multicast Forwarding [RFC4760]
[INFO] [stdout]     |                               ^^^^^^^ no item named `RFC4760` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3107`
[INFO] [stdout]    --> src/lib.rs:187:22
[INFO] [stdout]     |
[INFO] [stdout] 187 |     /// MPLS Labels [RFC3107]
[INFO] [stdout]     |                      ^^^^^^^ no item named `RFC3107` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC7752`
[INFO] [stdout]    --> src/lib.rs:195:17
[INFO] [stdout]     |
[INFO] [stdout] 195 |     /// BGP LS [RFC7752]
[INFO] [stdout]     |                 ^^^^^^^ no item named `RFC7752` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC7752`
[INFO] [stdout]    --> src/lib.rs:197:21
[INFO] [stdout]     |
[INFO] [stdout] 197 |     /// BGP LS VPN [RFC7752]
[INFO] [stdout]     |                     ^^^^^^^ no item named `RFC7752` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4684`
[INFO] [stdout]    --> src/lib.rs:199:14
[INFO] [stdout]     |
[INFO] [stdout] 199 |     /// RTC [RFC4684]
[INFO] [stdout]     |              ^^^^^^^ no item named `RFC4684` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4364`
[INFO] [stdout]    --> src/lib.rs:201:19
[INFO] [stdout]     |
[INFO] [stdout] 201 |     /// MPLS VPN [RFC4364]
[INFO] [stdout]     |                   ^^^^^^^ no item named `RFC4364` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: 9 warnings emitted
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr]     Finished dev [unoptimized + debuginfo] target(s) in 0.75s
[INFO] running `Command { std: "docker" "inspect" "7368f24a23b8e46c6eb35c0a694e8572119672bccf7ce491417996602206c762", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "7368f24a23b8e46c6eb35c0a694e8572119672bccf7ce491417996602206c762", kill_on_drop: false }`
[INFO] [stdout] 7368f24a23b8e46c6eb35c0a694e8572119672bccf7ce491417996602206c762
