[INFO] fetching crate async-smtp 0.4.0...
[INFO] documenting async-smtp-0.4.0 against 1.54.0 for beta-1.55-rustdoc-1
[INFO] extracting crate async-smtp 0.4.0 into /workspace/builds/worker-113/source
[INFO] validating manifest of crates.io crate async-smtp 0.4.0 on toolchain 1.54.0
[INFO] running `Command { std: "/workspace/cargo-home/bin/cargo" "+1.54.0" "metadata" "--manifest-path" "Cargo.toml" "--no-deps", kill_on_drop: false }`
[INFO] started tweaking crates.io crate async-smtp 0.4.0
[INFO] removed 0 missing examples
[INFO] finished tweaking crates.io crate async-smtp 0.4.0
[INFO] tweaked toml for crates.io crate async-smtp 0.4.0 written to /workspace/builds/worker-113/source/Cargo.toml
[INFO] crate crates.io crate async-smtp 0.4.0 already has a lockfile, it will not be regenerated
[INFO] running `Command { std: "/workspace/cargo-home/bin/cargo" "+1.54.0" "fetch" "--manifest-path" "Cargo.toml", kill_on_drop: false }`
[INFO] [stderr]     Blocking waiting for file lock on package cache
[INFO] [stderr]     Blocking waiting for file lock on package cache
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-113/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-113/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:34b6a614d2c27851fe6cbf88fbd1137609cefab8b10d0615aaeb6fd47975d74e" "/opt/rustwide/cargo-home/bin/cargo" "+1.54.0" "metadata" "--no-deps" "--format-version=1", kill_on_drop: false }`
[INFO] [stdout] 567de264ccb488bcae5e74225683ff0d4d1f1f795f6457bc41e1d09f0be0e077
[INFO] running `Command { std: "docker" "start" "-a" "567de264ccb488bcae5e74225683ff0d4d1f1f795f6457bc41e1d09f0be0e077", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "inspect" "567de264ccb488bcae5e74225683ff0d4d1f1f795f6457bc41e1d09f0be0e077", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "567de264ccb488bcae5e74225683ff0d4d1f1f795f6457bc41e1d09f0be0e077", kill_on_drop: false }`
[INFO] [stdout] 567de264ccb488bcae5e74225683ff0d4d1f1f795f6457bc41e1d09f0be0e077
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-113/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-113/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:34b6a614d2c27851fe6cbf88fbd1137609cefab8b10d0615aaeb6fd47975d74e" "/opt/rustwide/cargo-home/bin/cargo" "+1.54.0" "doc" "--frozen" "--no-deps" "--document-private-items" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] 11403b17312008584598e9bd8e4d6e984041cb045b129e8b8081bef5eeef306d
[INFO] running `Command { std: "docker" "start" "-a" "11403b17312008584598e9bd8e4d6e984041cb045b129e8b8081bef5eeef306d", kill_on_drop: false }`
[INFO] [stderr]    Compiling proc-macro2 v1.0.24
[INFO] [stderr]    Compiling unicode-xid v0.2.1
[INFO] [stderr]    Compiling syn v1.0.67
[INFO] [stderr]    Compiling libc v0.2.91
[INFO] [stderr]    Compiling memchr v2.3.4
[INFO] [stderr]    Compiling value-bag v1.0.0-alpha.6
[INFO] [stderr]    Compiling log v0.4.14
[INFO] [stderr]     Checking futures-core v0.3.13
[INFO] [stderr]     Checking fastrand v1.4.0
[INFO] [stderr]    Compiling cc v1.0.67
[INFO] [stderr]     Checking futures-io v0.3.13
[INFO] [stderr]     Checking pin-project-lite v0.2.6
[INFO] [stderr]     Checking vec-arena v1.1.0
[INFO] [stderr]    Compiling signal-hook v0.3.7
[INFO] [stderr]    Compiling openssl v0.10.33
[INFO] [stderr]     Checking atomic-waker v1.0.0
[INFO] [stderr]    Compiling native-tls v0.2.7
[INFO] [stderr]    Compiling serde v1.0.125
[INFO] [stderr]    Compiling lexical-core v0.7.5
[INFO] [stderr]     Checking openssl-probe v0.1.2
[INFO] [stderr]    Compiling serde_derive v1.0.125
[INFO] [stderr]     Checking slab v0.4.2
[INFO] [stderr]     Checking arrayvec v0.5.2
[INFO] [stderr]    Compiling async-trait v0.1.48
[INFO] [stderr]     Checking itoa v0.4.7
[INFO] [stderr]     Checking ascii_utils v0.9.3
[INFO] [stderr]     Checking bufstream v0.1.4
[INFO] [stderr]    Compiling crossbeam-utils v0.8.3
[INFO] [stderr]     Checking tinyvec v1.1.1
[INFO] [stderr]     Checking unicode-bidi v0.3.4
[INFO] [stderr]     Checking async-lock v2.3.0
[INFO] [stderr]    Compiling nom v5.1.2
[INFO] [stderr]     Checking async-channel v1.6.1
[INFO] [stderr]     Checking fast_chemail v0.9.6
[INFO] [stderr]     Checking futures-lite v1.11.3
[INFO] [stderr]    Compiling quote v1.0.9
[INFO] [stderr]     Checking unicode-normalization v0.1.17
[INFO] [stderr]    Compiling openssl-sys v0.9.61
[INFO] [stderr]     Checking socket2 v0.4.0
[INFO] [stderr]     Checking signal-hook-registry v1.3.0
[INFO] [stderr]     Checking num_cpus v1.13.0
[INFO] [stderr]     Checking hostname v0.1.5
[INFO] [stderr]     Checking blocking v1.0.2
[INFO] [stderr]     Checking async-executor v1.4.0
[INFO] [stderr]     Checking nb-connect v1.1.0
[INFO] [stderr]     Checking idna v0.2.2
[INFO] [stderr]     Checking url v2.2.1
[INFO] [stderr]     Checking serde_json v1.0.64
[INFO] [stderr]    Compiling ctor v0.1.20
[INFO] [stderr]    Compiling thiserror-impl v1.0.24
[INFO] [stderr]    Compiling pin-project-internal v1.0.6
[INFO] [stderr]     Checking thiserror v1.0.24
[INFO] [stderr]     Checking polling v2.0.3
[INFO] [stderr]     Checking kv-log-macro v1.0.7
[INFO] [stderr]     Checking pin-project v1.0.6
[INFO] [stderr]     Checking async-io v1.3.1
[INFO] [stderr]     Checking async-process v1.0.2
[INFO] [stderr]     Checking async-global-executor v2.0.2
[INFO] [stderr]     Checking async-std v1.9.0
[INFO] [stderr]     Checking async-native-tls v0.3.3
[INFO] [stderr]  Documenting async-smtp v0.4.0 (/opt/rustwide/workdir)
[INFO] [stdout] warning: unresolved link to `SmtpClient::new_simple`
[INFO] [stdout]   --> src/smtp/smtp_client.rs:97:25
[INFO] [stdout]    |
[INFO] [stdout] 97 |     /// Consider using [`SmtpClient::new_simple`] instead, if possible.
[INFO] [stdout]    |                         ^^^^^^^^^^^^^^^^^^^^^^^^ the struct `SmtpClient` has no field or associated item named `new_simple`
[INFO] [stdout]    |
[INFO] [stdout]    = note: `#[warn(rustdoc::broken_intra_doc_links)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/smtp/authentication.rs:61:19
[INFO] [stdout]    |
[INFO] [stdout] 61 |     /// RFC 4616: https://tools.ietf.org/html/rfc4616
[INFO] [stdout]    |                   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc4616>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: `#[warn(rustdoc::bare_urls)]` on by default
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/smtp/authentication.rs:65:9
[INFO] [stdout]    |
[INFO] [stdout] 65 |     /// https://www.ietf.org/archive/id/draft-murchison-sasl-login-00.txt
[INFO] [stdout]    |         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://www.ietf.org/archive/id/draft-murchison-sasl-login-00.txt>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/smtp/authentication.rs:68:9
[INFO] [stdout]    |
[INFO] [stdout] 68 |     /// https://developers.google.com/gmail/imap/xoauth2-protocol
[INFO] [stdout]    |         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://developers.google.com/gmail/imap/xoauth2-protocol>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/smtp/extension.rs:81:19
[INFO] [stdout]    |
[INFO] [stdout] 81 |     /// RFC 6152: https://tools.ietf.org/html/rfc6152
[INFO] [stdout]    |                   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc6152>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/smtp/extension.rs:85:19
[INFO] [stdout]    |
[INFO] [stdout] 85 |     /// RFC 6531: https://tools.ietf.org/html/rfc6531
[INFO] [stdout]    |                   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc6531>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> src/smtp/extension.rs:89:19
[INFO] [stdout]    |
[INFO] [stdout] 89 |     /// RFC 2487: https://tools.ietf.org/html/rfc2487
[INFO] [stdout]    |                   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc2487>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: 7 warnings emitted
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr]     Finished dev [unoptimized + debuginfo] target(s) in 17.12s
[INFO] running `Command { std: "docker" "inspect" "11403b17312008584598e9bd8e4d6e984041cb045b129e8b8081bef5eeef306d", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "11403b17312008584598e9bd8e4d6e984041cb045b129e8b8081bef5eeef306d", kill_on_drop: false }`
[INFO] [stdout] 11403b17312008584598e9bd8e4d6e984041cb045b129e8b8081bef5eeef306d
