[INFO] cloning repository https://github.com/jonfk/hydra-auth-example-rs
[INFO] running `Command { std: "git" "-c" "credential.helper=" "-c" "credential.helper=/workspace/cargo-home/bin/git-credential-null" "clone" "--bare" "https://github.com/jonfk/hydra-auth-example-rs" "/workspace/cache/git-repos/https%3A%2F%2Fgithub.com%2Fjonfk%2Fhydra-auth-example-rs", kill_on_drop: false }`
[INFO] [stderr] Cloning into bare repository '/workspace/cache/git-repos/https%3A%2F%2Fgithub.com%2Fjonfk%2Fhydra-auth-example-rs'...
[INFO] running `Command { std: "git" "rev-parse" "HEAD", kill_on_drop: false }`
[INFO] [stdout] 3e6eeb641d898b2e7c74b1b1f706b01b8ba5b989
[INFO] documenting jonfk/hydra-auth-example-rs against beta-2021-08-01 for beta-1.55-rustdoc-1
[INFO] running `Command { std: "git" "clone" "/workspace/cache/git-repos/https%3A%2F%2Fgithub.com%2Fjonfk%2Fhydra-auth-example-rs" "/workspace/builds/worker-7/source", kill_on_drop: false }`
[INFO] [stderr] Cloning into '/workspace/builds/worker-7/source'...
[INFO] [stderr] done.
[INFO] validating manifest of git repo https://github.com/jonfk/hydra-auth-example-rs on toolchain beta-2021-08-01
[INFO] running `Command { std: "/workspace/cargo-home/bin/cargo" "+beta-2021-08-01" "metadata" "--manifest-path" "Cargo.toml" "--no-deps", kill_on_drop: false }`
[INFO] started tweaking git repo https://github.com/jonfk/hydra-auth-example-rs
[INFO] finished tweaking git repo https://github.com/jonfk/hydra-auth-example-rs
[INFO] tweaked toml for git repo https://github.com/jonfk/hydra-auth-example-rs written to /workspace/builds/worker-7/source/Cargo.toml
[INFO] crate git repo https://github.com/jonfk/hydra-auth-example-rs already has a lockfile, it will not be regenerated
[INFO] running `Command { std: "/workspace/cargo-home/bin/cargo" "+beta-2021-08-01" "fetch" "--manifest-path" "Cargo.toml", kill_on_drop: false }`
[INFO] [stderr]     Blocking waiting for file lock on package cache
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-7/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-7/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:34b6a614d2c27851fe6cbf88fbd1137609cefab8b10d0615aaeb6fd47975d74e" "/opt/rustwide/cargo-home/bin/cargo" "+beta-2021-08-01" "metadata" "--no-deps" "--format-version=1", kill_on_drop: false }`
[INFO] [stdout] 239a1efdc3eaafe66993727fd8771576b97d0ff2233989decfcb65db55b329ea
[INFO] running `Command { std: "docker" "start" "-a" "239a1efdc3eaafe66993727fd8771576b97d0ff2233989decfcb65db55b329ea", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "inspect" "239a1efdc3eaafe66993727fd8771576b97d0ff2233989decfcb65db55b329ea", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "239a1efdc3eaafe66993727fd8771576b97d0ff2233989decfcb65db55b329ea", kill_on_drop: false }`
[INFO] [stdout] 239a1efdc3eaafe66993727fd8771576b97d0ff2233989decfcb65db55b329ea
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-7/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-7/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "ghcr.io/rust-lang/crates-build-env/linux@sha256:34b6a614d2c27851fe6cbf88fbd1137609cefab8b10d0615aaeb6fd47975d74e" "/opt/rustwide/cargo-home/bin/cargo" "+beta-2021-08-01" "doc" "--frozen" "--no-deps" "--document-private-items" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] 29356521e39c13ecf20f0dc38b505cab79d66c903f8d9d443c7bda85be16d449
[INFO] running `Command { std: "docker" "start" "-a" "29356521e39c13ecf20f0dc38b505cab79d66c903f8d9d443c7bda85be16d449", kill_on_drop: false }`
[INFO] [stderr]    Compiling memchr v2.3.0
[INFO] [stderr]    Compiling syn v1.0.13
[INFO] [stderr]    Compiling cc v1.0.50
[INFO] [stderr]    Compiling rand_core v0.4.2
[INFO] [stderr]    Compiling serde v1.0.104
[INFO] [stderr]     Checking regex-syntax v0.6.13
[INFO] [stderr]    Compiling ucd-trie v0.1.2
[INFO] [stderr]    Compiling encoding_rs v0.8.22
[INFO] [stderr]     Checking pin-project-lite v0.1.2
[INFO] [stderr]     Checking remove_dir_all v0.5.2
[INFO] [stderr]    Compiling proc-macro2 v1.0.8
[INFO] [stderr]    Compiling indexmap v1.3.1
[INFO] [stderr]     Checking lock_api v0.3.3
[INFO] [stderr]    Compiling libc v0.2.66
[INFO] [stderr]     Checking tokio-executor v0.1.9
[INFO] [stderr]    Compiling num-traits v0.2.11
[INFO] [stderr]    Compiling num-integer v0.1.42
[INFO] [stderr]     Checking headers-core v0.2.0
[INFO] [stderr]     Checking num_cpus v1.12.0
[INFO] [stderr]     Checking getrandom v0.1.14
[INFO] [stderr]     Checking rand_os v0.1.3
[INFO] [stderr]     Checking log v0.3.9
[INFO] [stderr]     Checking want v0.3.0
[INFO] [stderr]     Checking atty v0.2.14
[INFO] [stderr]     Checking flate2 v1.0.13
[INFO] [stderr]     Checking bytes v0.4.12
[INFO] [stderr]     Checking mio v0.6.21
[INFO] [stderr]     Checking crossbeam-channel v0.4.0
[INFO] [stderr]     Checking block-buffer v0.7.3
[INFO] [stderr]     Checking digest v0.8.1
[INFO] [stderr]    Compiling rand_core v0.3.1
[INFO] [stderr]    Compiling rand_pcg v0.1.2
[INFO] [stderr]    Compiling rand_jitter v0.1.4
[INFO] [stderr]     Checking url v2.1.1
[INFO] [stderr]     Checking mime_guess v2.0.1
[INFO] [stderr]     Checking tokio-current-thread v0.1.6
[INFO] [stderr]     Checking tokio-timer v0.2.12
[INFO] [stderr]     Checking cookie v0.12.0
[INFO] [stderr]     Checking tokio-threadpool v0.1.17
[INFO] [stderr]     Checking futures-cpupool v0.1.8
[INFO] [stderr]     Checking pest v2.1.2
[INFO] [stderr]     Checking rand_core v0.5.1
[INFO] [stderr]     Checking sha-1 v0.8.2
[INFO] [stderr]     Checking tokio-io v0.1.12
[INFO] [stderr]     Checking http v0.1.21
[INFO] [stderr]     Checking tokio-buf v0.1.1
[INFO] [stderr]     Checking string v0.2.1
[INFO] [stderr]     Checking input_buffer v0.2.0
[INFO] [stderr]     Checking parking_lot v0.9.0
[INFO] [stderr]     Checking mime v0.2.6
[INFO] [stderr]    Compiling rand_hc v0.1.0
[INFO] [stderr]    Compiling rand_chacha v0.1.1
[INFO] [stderr]    Compiling rand_xorshift v0.1.1
[INFO] [stderr]    Compiling rand_isaac v0.1.1
[INFO] [stderr]     Checking rand v0.6.5
[INFO] [stderr]     Checking rand_chacha v0.2.1
[INFO] [stderr]     Checking headers v0.3.0
[INFO] [stderr]     Checking mio-uds v0.6.7
[INFO] [stderr]    Compiling quote v1.0.2
[INFO] [stderr]    Compiling aho-corasick v0.7.6
[INFO] [stderr]     Checking rand v0.7.3
[INFO] [stderr]     Checking tokio-reactor v0.1.11
[INFO] [stderr]     Checking bstr v0.2.9
[INFO] [stderr]     Checking futures-util v0.3.1
[INFO] [stderr]     Checking buf_redux v0.8.4
[INFO] [stderr]     Checking twoway v0.1.8
[INFO] [stderr]     Checking chrono v0.4.10
[INFO] [stderr]    Compiling openssl-sys v0.9.53
[INFO] [stderr]    Compiling backtrace-sys v0.1.32
[INFO] [stderr]     Checking tokio-tcp v0.1.3
[INFO] [stderr]     Checking regex v1.3.3
[INFO] [stderr]     Checking tokio v0.1.22
[INFO] [stderr]    Compiling phf_generator v0.7.24
[INFO] [stderr]     Checking h2 v0.1.26
[INFO] [stderr]     Checking http-body v0.1.0
[INFO] [stderr]     Checking uuid v0.7.4
[INFO] [stderr]     Checking tempfile v3.1.0
[INFO] [stderr]     Checking tungstenite v0.9.2
[INFO] [stderr]    Compiling phf_codegen v0.7.24
[INFO] [stderr]    Compiling pest_meta v2.1.2
[INFO] [stderr]    Compiling openssl v0.10.26
[INFO] [stderr]    Compiling native-tls v0.2.3
[INFO] [stderr]     Checking publicsuffix v1.5.4
[INFO] [stderr]     Checking globset v0.4.4
[INFO] [stderr]     Checking env_logger v0.7.1
[INFO] [stderr]    Compiling mime_guess v1.8.7
[INFO] [stderr]     Checking backtrace v0.3.42
[INFO] [stderr]     Checking ignore v0.4.11
[INFO] [stderr]     Checking hyper v0.12.35
[INFO] [stderr]     Checking futures v0.3.1
[INFO] [stderr]     Checking globwalk v0.7.1
[INFO] [stderr]     Checking multipart v0.16.1
[INFO] [stderr]    Compiling parse-zoneinfo v0.2.1
[INFO] [stderr]     Checking hyper-tls v0.3.2
[INFO] [stderr]    Compiling chrono-tz v0.5.1
[INFO] [stderr]    Compiling synstructure v0.12.3
[INFO] [stderr]    Compiling pest_generator v2.1.1
[INFO] [stderr]    Compiling serde_derive v1.0.104
[INFO] [stderr]    Compiling tokio-macros v0.2.3
[INFO] [stderr]    Compiling failure_derive v0.1.6
[INFO] [stderr]    Compiling pin-project-internal v0.4.6
[INFO] [stderr]    Compiling pest_derive v2.1.0
[INFO] [stderr]     Checking tokio v0.2.9
[INFO] [stderr]     Checking failure v0.1.6
[INFO] [stderr]     Checking pin-project v0.4.6
[INFO] [stderr]     Checking tokio-util v0.2.0
[INFO] [stderr]     Checking h2 v0.2.1
[INFO] [stderr]     Checking hyper v0.13.1
[INFO] [stderr]     Checking serde_json v1.0.46
[INFO] [stderr]     Checking serde_urlencoded v0.5.5
[INFO] [stderr]     Checking serde_urlencoded v0.6.1
[INFO] [stderr]     Checking cookie_store v0.7.0
[INFO] [stderr]     Checking warp v0.2.0
[INFO] [stderr]     Checking tera v1.0.2
[INFO] [stderr]     Checking reqwest v0.9.24
[INFO] [stderr]     Checking hydra v1.0.0 (/opt/rustwide/workdir/hydra)
[INFO] [stderr]  Documenting hydra v1.0.0 (/opt/rustwide/workdir/hydra)
[INFO] [stderr] thread 'rustc' panicked at 'no errors encountered even though `delay_span_bug` issued', compiler/rustc_errors/src/lib.rs:1050:13
[INFO] [stdout] error: internal compiler error: unexpected concrete region in borrowck: ReStatic
[INFO] [stdout]    --> /opt/rustwide/cargo-home/registry/src/github.com-1ecc6299db9ec823/warp-0.2.0/src/filters/sse.rs:457:5
[INFO] [stdout]     |
[INFO] [stdout] 457 | /     pub fn stream<S>(
[INFO] [stdout] 458 | |         self,
[INFO] [stdout] 459 | |         event_stream: S,
[INFO] [stdout] 460 | |     ) -> impl TryStream<
[INFO] [stdout] ...   |
[INFO] [stdout] 476 | |         }
[INFO] [stdout] 477 | |     }
[INFO] [stdout]     | |_____^
[INFO] [stdout]     |
[INFO] [stdout]     = note: delayed at compiler/rustc_mir/src/borrow_check/region_infer/opaque_types.rs:87:44
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr] stack backtrace:
[INFO] [stdout] error: internal compiler error: unexpected concrete region in borrowck: ReStatic
[INFO] [stdout]    --> /opt/rustwide/cargo-home/registry/src/github.com-1ecc6299db9ec823/warp-0.2.0/src/filters/sse.rs:492:1
[INFO] [stdout]     |
[INFO] [stdout] 492 | / pub fn keep<S>(
[INFO] [stdout] 493 | |     event_stream: S,
[INFO] [stdout] 494 | |     keep_interval: impl Into<Option<Duration>>,
[INFO] [stdout] 495 | | ) -> impl TryStream<
[INFO] [stdout] ...   |
[INFO] [stdout] 514 | |     }
[INFO] [stdout] 515 | | }
[INFO] [stdout]     | |_^
[INFO] [stdout]     |
[INFO] [stdout]     = note: delayed at compiler/rustc_mir/src/borrow_check/region_infer/opaque_types.rs:87:44
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr]    0:     0x7faaaf21eb00 - std::backtrace_rs::backtrace::libunwind::trace::hff4d1766e93f64f1
[INFO] [stderr]                                at /rustc/53fd98ca776cb875bc9e5514f56b52eb74f9e7a9/library/std/src/../../backtrace/src/backtrace/libunwind.rs:90:5
[INFO] [stderr]    1:     0x7faaaf21eb00 - std::backtrace_rs::backtrace::trace_unsynchronized::h56bbc8eb78770bcb
[INFO] [stderr]                                at /rustc/53fd98ca776cb875bc9e5514f56b52eb74f9e7a9/library/std/src/../../backtrace/src/backtrace/mod.rs:66:5
[INFO] [stderr]    2:     0x7faaaf21eb00 - std::sys_common::backtrace::_print_fmt::h5c8e75464faca780
[INFO] [stderr]                                at /rustc/53fd98ca776cb875bc9e5514f56b52eb74f9e7a9/library/std/src/sys_common/backtrace.rs:67:5
[INFO] [stderr]    3:     0x7faaaf21eb00 - <std::sys_common::backtrace::_print::DisplayBacktrace as core::fmt::Display>::fmt::h48b88277def8b362
[INFO] [stderr]                                at /rustc/53fd98ca776cb875bc9e5514f56b52eb74f9e7a9/library/std/src/sys_common/backtrace.rs:46:22
[INFO] [stderr]    4:     0x7faaaf28c63c - core::fmt::write::h3381b3176fe2b3d3
[INFO] [stderr]                                at /rustc/53fd98ca776cb875bc9e5514f56b52eb74f9e7a9/library/core/src/fmt/mod.rs:1115:17
[INFO] [stderr]    5:     0x7faaaf2103e5 - std::io::Write::write_fmt::hd42607e5d8e44db0
[INFO] [stderr]                                at /rustc/53fd98ca776cb875bc9e5514f56b52eb74f9e7a9/library/std/src/io/mod.rs:1665:15
[INFO] [stderr]    6:     0x7faaaf22281b - std::sys_common::backtrace::_print::ha537687d6c17dd0d
[INFO] [stderr]                                at /rustc/53fd98ca776cb875bc9e5514f56b52eb74f9e7a9/library/std/src/sys_common/backtrace.rs:49:5
[INFO] [stderr]    7:     0x7faaaf22281b - std::sys_common::backtrace::print::h61376ae57d131d72
[INFO] [stderr]                                at /rustc/53fd98ca776cb875bc9e5514f56b52eb74f9e7a9/library/std/src/sys_common/backtrace.rs:36:9
[INFO] [stderr]    8:     0x7faaaf22281b - std::panicking::default_hook::{{closure}}::h0f7208c0b9644a54
[INFO] [stderr]                                at /rustc/53fd98ca776cb875bc9e5514f56b52eb74f9e7a9/library/std/src/panicking.rs:208:50
[INFO] [stderr]    9:     0x7faaaf2222f1 - std::panicking::default_hook::hdac7fc06578c14ce
[INFO] [stderr]                                at /rustc/53fd98ca776cb875bc9e5514f56b52eb74f9e7a9/library/std/src/panicking.rs:225:9
[INFO] [stderr]   10:     0x7faaaf9fc531 - rustc_driver::DEFAULT_HOOK::{{closure}}::{{closure}}::he0fb23ee363efe57
[INFO] [stderr]   11:     0x7faaa1e01203 - <alloc::boxed::Box<F,A> as core::ops::function::Fn<Args>>::call::hd2323c7b10994d91
[INFO] [stderr]                                at /rustc/53fd98ca776cb875bc9e5514f56b52eb74f9e7a9/library/alloc/src/boxed.rs:1586:9
[INFO] [stderr]   12:     0x7faaa1da9f2a - proc_macro::bridge::client::<impl proc_macro::bridge::Bridge>::enter::{{closure}}::{{closure}}::haa7ac5fa4aca5aa5
[INFO] [stderr]                                at /rustc/53fd98ca776cb875bc9e5514f56b52eb74f9e7a9/library/proc_macro/src/bridge/client.rs:320:21
[INFO] [stderr]   13:     0x7faaaf223049 - std::panicking::rust_panic_with_hook::h72b21c283da3d1ef
[INFO] [stderr]                                at /rustc/53fd98ca776cb875bc9e5514f56b52eb74f9e7a9/library/std/src/panicking.rs:626:17
[INFO] [stderr]   14:     0x7faaaf222b07 - std::panicking::begin_panic_handler::{{closure}}::he5778f1729cff84a
[INFO] [stderr]                                at /rustc/53fd98ca776cb875bc9e5514f56b52eb74f9e7a9/library/std/src/panicking.rs:519:13
[INFO] [stderr]   15:     0x7faaaf21efdc - std::sys_common::backtrace::__rust_end_short_backtrace::h2d11ca8b453b4b1d
[INFO] [stderr]                                at /rustc/53fd98ca776cb875bc9e5514f56b52eb74f9e7a9/library/std/src/sys_common/backtrace.rs:141:18
[INFO] [stderr]   16:     0x7faaaf222a69 - rust_begin_unwind
[INFO] [stderr]                                at /rustc/53fd98ca776cb875bc9e5514f56b52eb74f9e7a9/library/std/src/panicking.rs:515:5
[INFO] [stderr]   17:     0x7faaaf1eba6b - std::panicking::begin_panic_fmt::h746518bde832d259
[INFO] [stderr]                                at /rustc/53fd98ca776cb875bc9e5514f56b52eb74f9e7a9/library/std/src/panicking.rs:457:5
[INFO] [stderr]   18:     0x7faab1e601a9 - rustc_errors::HandlerInner::flush_delayed::h68abfe220c70dca1
[INFO] [stderr]   19:     0x7faab1e5ec0d - <rustc_errors::HandlerInner as core::ops::drop::Drop>::drop::hd769a4292ac9bfa2
[INFO] [stderr]   20:     0x7faab15138d6 - core::ptr::drop_in_place<rustc_session::parse::ParseSess>::h3c16055fae7b64de
[INFO] [stderr]   21:     0x7faab1515a1e - <alloc::rc::Rc<T> as core::ops::drop::Drop>::drop::ha02c0db4efb40d0e
[INFO] [stderr]   22:     0x7faab14eacfd - core::ptr::drop_in_place<rustc_interface::interface::Compiler>::h4b986457436dbab5
[INFO] [stderr]   23:     0x7faab14ea2e3 - rustc_span::with_source_map::h46995da78fbfb2ca
[INFO] [stderr]   24:     0x7faab14fbbca - rustc_interface::interface::create_compiler_and_run::hdd0d8e5ea2028f60
[INFO] [stderr]   25:     0x7faab14eec49 - scoped_tls::ScopedKey<T>::set::h4889fb0c1fafdd05
[INFO] [stderr]   26:     0x7faab14eb66a - std::sys_common::backtrace::__rust_begin_short_backtrace::h78e9a1a2353d1913
[INFO] [stderr]   27:     0x7faab14eaab5 - core::ops::function::FnOnce::call_once{{vtable.shim}}::hb838edfbc6ca2ea1
[INFO] [stderr]   28:     0x7faaaf22f5d7 - <alloc::boxed::Box<F,A> as core::ops::function::FnOnce<Args>>::call_once::h65c29e4642be2358
[INFO] [stderr]                                at /rustc/53fd98ca776cb875bc9e5514f56b52eb74f9e7a9/library/alloc/src/boxed.rs:1572:9
[INFO] [stderr]   29:     0x7faaaf22f5d7 - <alloc::boxed::Box<F,A> as core::ops::function::FnOnce<Args>>::call_once::hd0f8f7fbbd9fffbf
[INFO] [stderr]                                at /rustc/53fd98ca776cb875bc9e5514f56b52eb74f9e7a9/library/alloc/src/boxed.rs:1572:9
[INFO] [stderr]   30:     0x7faaaf22f5d7 - std::sys::unix::thread::Thread::new::thread_start::h2fd22fee3ca77b65
[INFO] [stderr]                                at /rustc/53fd98ca776cb875bc9e5514f56b52eb74f9e7a9/library/std/src/sys/unix/thread.rs:74:17
[INFO] [stderr]   31:     0x7faaaf14b609 - start_thread
[INFO] [stderr]   32:     0x7faaaf05f293 - clone
[INFO] [stderr]   33:                0x0 - <unknown>
[INFO] [stderr] 
[INFO] [stderr] error: internal compiler error: unexpected panic
[INFO] [stderr] 
[INFO] [stderr] note: the compiler unexpectedly panicked. this is a bug.
[INFO] [stderr] 
[INFO] [stderr] note: we would appreciate a bug report: https://github.com/rust-lang/rust/issues/new?labels=C-bug%2C+I-ICE%2C+T-compiler&template=ice.md
[INFO] [stderr] 
[INFO] [stderr] note: rustc 1.55.0-beta.3 (53fd98ca7 2021-07-31) running on x86_64-unknown-linux-gnu
[INFO] [stderr] 
[INFO] [stderr] note: compiler flags: -C embed-bitcode=no -C debuginfo=2 --crate-type lib
[INFO] [stderr] 
[INFO] [stderr] note: some of the compiler flags provided by cargo are hidden
[INFO] [stderr] 
[INFO] [stderr] query stack during panic:
[INFO] [stderr] end of query stack
[INFO] [stderr] error: could not compile `warp`
[INFO] [stderr] warning: build failed, waiting for other jobs to finish...
[INFO] [stdout] warning: unresolved link to `JWA`
[INFO] [stdout]   --> hydra/src/models/json_web_key.rs:16:230
[INFO] [stdout]    |
[INFO] [stdout] 16 | ...d Encryption Algorithms\" registry established by [JWA] or be a value that contains a Collision- Resistant Name.
[INFO] [stdout]    |                                                       ^^^ no item named `JWA` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = note: `#[warn(rustdoc::broken_intra_doc_links)]` on by default
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `JWA`
[INFO] [stdout]   --> hydra/src/models/json_web_key.rs:34:237
[INFO] [stdout]    |
[INFO] [stdout] 34 | ...NA \"JSON Web Key Types\" registry established by [JWA] or be a value that contains a Collision- Resistant Name.  The \"kty\" value is...
[INFO] [stdout]    |                                                       ^^^ no item named `JWA` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5280`
[INFO] [stdout]   --> hydra/src/models/json_web_key.rs:50:108
[INFO] [stdout]    |
[INFO] [stdout] 50 | ...ains a chain of one or more PKIX certificates [RFC5280].  The certificate chain is represented as a JSON array of certificate value st...
[INFO] [stdout]    |                                                   ^^^^^^^ no item named `RFC5280` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4648`
[INFO] [stdout]   --> hydra/src/models/json_web_key.rs:50:263
[INFO] [stdout]    |
[INFO] [stdout] 50 | ...n the array is a base64-encoded (Section 4 of [RFC4648] -- not base64url-encoded) DER [ITU.X690.1994] PKIX certificate value. The PKIX...
[INFO] [stdout]    |                                                   ^^^^^^^ no item named `RFC4648` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `:port`
[INFO] [stdout]   --> hydra/src/models/o_auth2_client.rs:16:64
[INFO] [stdout]    |
[INFO] [stdout] 16 |     /// AllowedCORSOrigins are one or more URLs (scheme://host[:port]) which are allowed to make CORS requests to the /oauth/token endpoi...
[INFO] [stdout]    |                                                                ^^^^^ no item named `:port` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `JWK`
[INFO] [stdout]   --> hydra/src/models/o_auth2_client.rs:60:48
[INFO] [stdout]    |
[INFO] [stdout] 60 |     /// URL for the Client's JSON Web Key Set [JWK] document. If the Client signs requests to the Server, it contains the signing key(s) ...
[INFO] [stdout]    |                                                ^^^ no item named `JWK` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `JWS`
[INFO] [stdout]   --> hydra/src/models/o_auth2_client.rs:81:14
[INFO] [stdout]    |
[INFO] [stdout] 81 |     /// JWS [JWS] alg algorithm [JWA] that MUST be used for signing Request Objects sent to the OP. All Request Objects from this Client ...
[INFO] [stdout]    |              ^^^ no item named `JWS` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `JWA`
[INFO] [stdout]   --> hydra/src/models/o_auth2_client.rs:81:34
[INFO] [stdout]    |
[INFO] [stdout] 81 |     /// JWS [JWS] alg algorithm [JWA] that MUST be used for signing Request Objects sent to the OP. All Request Objects from this Client ...
[INFO] [stdout]    |                                  ^^^ no item named `JWA` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6749`
[INFO] [stdout]   --> hydra/src/models/o_auth2_client.rs:90:120
[INFO] [stdout]    |
[INFO] [stdout] 90 | ...ues (as described in Section 3.3 of OAuth 2.0 [RFC6749]) that the client can use when requesting access tokens.
[INFO] [stdout]    |                                                   ^^^^^^^ no item named `RFC6749` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `JWA`
[INFO] [stdout]    --> hydra/src/models/o_auth2_client.rs:108:28
[INFO] [stdout]     |
[INFO] [stdout] 108 |     /// JWS alg algorithm [JWA] REQUIRED for signing UserInfo Responses. If this is specified, the response will be JWT [JWT] serialized,...
[INFO] [stdout]     |                            ^^^ no item named `JWA` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `JWT`
[INFO] [stdout]    --> hydra/src/models/o_auth2_client.rs:108:122
[INFO] [stdout]     |
[INFO] [stdout] 108 | ...s. If this is specified, the response will be JWT [JWT] serialized, and signed using JWS. The default, if omitted, is for the UserInfo...
[INFO] [stdout]     |                                                       ^^^ no item named `JWT` in scope
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC7519`
[INFO] [stdout]   --> hydra/src/models/o_auth2_token_introspection.rs:47:50
[INFO] [stdout]    |
[INFO] [stdout] 47 |     /// Subject of the token, as defined in JWT [RFC7519]. Usually a machine-readable identifier of the resource owner who authorized thi...
[INFO] [stdout]    |                                                  ^^^^^^^ no item named `RFC7519` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5646`
[INFO] [stdout]   --> hydra/src/models/open_id_connect_context.rs:28:142
[INFO] [stdout]    |
[INFO] [stdout] 28 | ...epresented as a space-separated list of BCP47 [RFC5646] language tag values, ordered by preference. For instance, the value \"fr-CA fr...
[INFO] [stdout]    |                                                   ^^^^^^^ no item named `RFC5646` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5322`
[INFO] [stdout]   --> hydra/src/models/userinfo_response.rs:20:86
[INFO] [stdout]    |
[INFO] [stdout] 20 |     /// End-User's preferred e-mail address. Its value MUST conform to the RFC 5322 [RFC5322] addr-spec syntax. The RP MUST NOT rely upon...
[INFO] [stdout]    |                                                                                      ^^^^^^^ no item named `RFC5322` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5646`
[INFO] [stdout]   --> hydra/src/models/userinfo_response.rs:35:52
[INFO] [stdout]    |
[INFO] [stdout] 35 |     /// End-User's locale, represented as a BCP47 [RFC5646] language tag. This is typically an ISO 639-1 Alpha-2 [ISO639‑1] language code...
[INFO] [stdout]    |                                                    ^^^^^^^ no item named `RFC5646` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3966`
[INFO] [stdout]   --> hydra/src/models/userinfo_response.rs:47:273
[INFO] [stdout]    |
[INFO] [stdout] 47 | ...e extension be represented using the RFC 3966 [RFC3966] extension syntax, for example, +1 (604) 555-1234;ext=5678.
[INFO] [stdout]    |                                                   ^^^^^^^ no item named `RFC3966` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `zoneinfo`
[INFO] [stdout]   --> hydra/src/models/userinfo_response.rs:71:31
[INFO] [stdout]    |
[INFO] [stdout] 71 |     /// String from zoneinfo [zoneinfo] time zone database representing the End-User's time zone. For example, Europe/Paris or America/Lo...
[INFO] [stdout]    |                               ^^^^^^^^ no item named `zoneinfo` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `JWK`
[INFO] [stdout]   --> hydra/src/models/well_known.rs:50:43
[INFO] [stdout]    |
[INFO] [stdout] 50 |     /// URL of the OP's JSON Web Key Set [JWK] document. This contains the signing key(s) the RP uses to validate signatures from the OP....
[INFO] [stdout]    |                                           ^^^ no item named `JWK` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6749`
[INFO] [stdout]   --> hydra/src/models/well_known.rs:74:55
[INFO] [stdout]    |
[INFO] [stdout] 74 |     /// SON array containing a list of the OAuth 2.0 [RFC6749] scope values that this server supports. The server MUST support the openid...
[INFO] [stdout]    |                                                       ^^^^^^^ no item named `RFC6749` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `JWS`
[INFO] [stdout]   --> hydra/src/models/well_known.rs:89:50
[INFO] [stdout]    |
[INFO] [stdout] 89 |     /// JSON array containing a list of the JWS [JWS] signing algorithms (alg values) [JWA] supported by the UserInfo Endpoint to encode ...
[INFO] [stdout]    |                                                  ^^^ no item named `JWS` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `JWA`
[INFO] [stdout]   --> hydra/src/models/well_known.rs:89:88
[INFO] [stdout]    |
[INFO] [stdout] 89 |     /// JSON array containing a list of the JWS [JWS] signing algorithms (alg values) [JWA] supported by the UserInfo Endpoint to encode ...
[INFO] [stdout]    |                                                                                        ^^^ no item named `JWA` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `JWT`
[INFO] [stdout]   --> hydra/src/models/well_known.rs:89:159
[INFO] [stdout]    |
[INFO] [stdout] 89 | ...e UserInfo Endpoint to encode the Claims in a JWT [JWT].
[INFO] [stdout]    |                                                       ^^^ no item named `JWT` in scope
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> hydra/src/models/accept_login_request.rs:22:171
[INFO] [stdout]    |
[INFO] [stdout] 22 | ...wise Identifier Algorithm)[http://openid.net/specs/openid-connect-core-1_0.html#PairwiseAlg] of the OpenID Connect specification. It a...
[INFO] [stdout]    |                               ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<http://openid.net/specs/openid-connect-core-1_0.html#PairwiseAlg>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: `#[warn(rustdoc::bare_urls)]` on by default
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> hydra/src/models/o_auth2_token_introspection.rs:11:32
[INFO] [stdout]    |
[INFO] [stdout] 11 | /// OAuth2TokenIntrospection : https://tools.ietf.org/html/rfc7662
[INFO] [stdout]    |                                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc7662>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: this URL is not a hyperlink
[INFO] [stdout]   --> hydra/src/models/o_auth2_token_introspection.rs:59:9
[INFO] [stdout]    |
[INFO] [stdout] 59 |     /// https://tools.ietf.org/html/rfc7662
[INFO] [stdout]    |         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ help: use an automatic link instead: `<https://tools.ietf.org/html/rfc7662>`
[INFO] [stdout]    |
[INFO] [stdout]    = note: bare URLs are not automatically turned into clickable links
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: 25 warnings emitted
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr] error: build failed
[INFO] running `Command { std: "docker" "inspect" "29356521e39c13ecf20f0dc38b505cab79d66c903f8d9d443c7bda85be16d449", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "29356521e39c13ecf20f0dc38b505cab79d66c903f8d9d443c7bda85be16d449", kill_on_drop: false }`
[INFO] [stdout] 29356521e39c13ecf20f0dc38b505cab79d66c903f8d9d443c7bda85be16d449
