[INFO] fetching crate trust-dns-proto 0.20.0-alpha.2...
[INFO] documenting trust-dns-proto-0.20.0-alpha.2 against beta-2020-10-09 for beta-1.48-rustdoc-1
[INFO] extracting crate trust-dns-proto 0.20.0-alpha.2 into /workspace/builds/worker-6/source
[INFO] validating manifest of crates.io crate trust-dns-proto 0.20.0-alpha.2 on toolchain beta-2020-10-09
[INFO] running `Command { std: "/workspace/cargo-home/bin/cargo" "+beta-2020-10-09" "read-manifest" "--manifest-path" "Cargo.toml", kill_on_drop: false }`
[INFO] started tweaking crates.io crate trust-dns-proto 0.20.0-alpha.2
[INFO] finished tweaking crates.io crate trust-dns-proto 0.20.0-alpha.2
[INFO] tweaked toml for crates.io crate trust-dns-proto 0.20.0-alpha.2 written to /workspace/builds/worker-6/source/Cargo.toml
[INFO] running `Command { std: "/workspace/cargo-home/bin/cargo" "+beta-2020-10-09" "generate-lockfile" "--manifest-path" "Cargo.toml" "-Zno-index-update", kill_on_drop: false }`
[INFO] running `Command { std: "/workspace/cargo-home/bin/cargo" "+beta-2020-10-09" "fetch" "--locked" "--manifest-path" "Cargo.toml", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-6/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-6/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "rustops/crates-build-env@sha256:d92eaeed33fa75130ca1ee6c8a01d1ffb62bac859dfdfb3450e3e5d1c0146529" "/opt/rustwide/cargo-home/bin/cargo" "+beta-2020-10-09" "metadata" "--no-deps" "--format-version=1", kill_on_drop: false }`
[INFO] [stderr] WARNING: Your kernel does not support swap limit capabilities or the cgroup is not mounted. Memory limited without swap.
[INFO] [stdout] 1643b0feda28c9d1b4876779c251b38112b42917f1568c312621630b360aa647
[INFO] running `Command { std: "docker" "start" "-a" "1643b0feda28c9d1b4876779c251b38112b42917f1568c312621630b360aa647", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "inspect" "1643b0feda28c9d1b4876779c251b38112b42917f1568c312621630b360aa647", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "1643b0feda28c9d1b4876779c251b38112b42917f1568c312621630b360aa647", kill_on_drop: false }`
[INFO] [stdout] 1643b0feda28c9d1b4876779c251b38112b42917f1568c312621630b360aa647
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-6/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-6/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "rustops/crates-build-env@sha256:d92eaeed33fa75130ca1ee6c8a01d1ffb62bac859dfdfb3450e3e5d1c0146529" "/opt/rustwide/cargo-home/bin/cargo" "+beta-2020-10-09" "doc" "--frozen" "--no-deps" "--document-private-items" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] 62b7b13a615ca9f5084e824d9b4454fdb6e0ff3445a29b0c52a1de18949467cd
[INFO] [stderr] WARNING: Your kernel does not support swap limit capabilities or the cgroup is not mounted. Memory limited without swap.
[INFO] running `Command { std: "docker" "start" "-a" "62b7b13a615ca9f5084e824d9b4454fdb6e0ff3445a29b0c52a1de18949467cd", kill_on_drop: false }`
[INFO] [stderr]    Compiling syn v1.0.45
[INFO] [stderr]     Checking tokio v0.2.22
[INFO] [stderr]    Compiling pin-project-internal v0.4.27
[INFO] [stderr]    Compiling thiserror-impl v1.0.21
[INFO] [stderr]    Compiling async-trait v0.1.41
[INFO] [stderr]    Compiling enum-as-inner v0.3.3
[INFO] [stderr]     Checking thiserror v1.0.21
[INFO] [stderr]     Checking pin-project v0.4.27
[INFO] [stderr]     Checking futures-util v0.3.6
[INFO] [stderr]  Documenting trust-dns-proto v0.20.0-alpha.2 (/opt/rustwide/workdir)
[INFO] [stdout] warning: unresolved link to `RFC5070`
[INFO] [stdout]    --> src/rr/rdata/caa.rs:235:36
[INFO] [stdout]     |
[INFO] [stdout] 235 |     ///    (IODEF) format is used [RFC5070].
[INFO] [stdout]     |                                    ^^^^^^^ the module `caa` contains no item named `RFC5070`
[INFO] [stdout]     |
[INFO] [stdout]     = note: `#[warn(broken_intra_doc_links)]` on by default
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5280`
[INFO] [stdout]    --> src/rr/rdata/tlsa.rs:178:75
[INFO] [stdout]     |
[INFO] [stdout] 178 |     /// Full certificate: the Certificate binary structure as defined in [RFC5280]
[INFO] [stdout]     |                                                                           ^^^^^^^ the module `tlsa` contains no item named `RFC5280`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5280`
[INFO] [stdout]    --> src/rr/rdata/tlsa.rs:181:75
[INFO] [stdout]     |
[INFO] [stdout] 181 |     /// SubjectPublicKeyInfo: DER-encoded binary structure as defined in [RFC5280]
[INFO] [stdout]     |                                                                           ^^^^^^^ the module `tlsa` contains no item named `RFC5280`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6234`
[INFO] [stdout]    --> src/rr/rdata/tlsa.rs:239:43
[INFO] [stdout]     |
[INFO] [stdout] 239 |     /// SHA-256 hash of selected content [RFC6234]
[INFO] [stdout]     |                                           ^^^^^^^ the module `tlsa` contains no item named `RFC6234`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6234`
[INFO] [stdout]    --> src/rr/rdata/tlsa.rs:242:43
[INFO] [stdout]     |
[INFO] [stdout] 242 |     /// SHA-512 hash of selected content [RFC6234]
[INFO] [stdout]     |                                           ^^^^^^^ the module `tlsa` contains no item named `RFC6234`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `1`
[INFO] [stdout]   --> src/rr/record_type.rs:41:18
[INFO] [stdout]    |
[INFO] [stdout] 41 |     /// RFC 1035[1] IPv4 Address record
[INFO] [stdout]    |                  ^ the module `record_type` contains no item named `1`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `2`
[INFO] [stdout]   --> src/rr/record_type.rs:43:18
[INFO] [stdout]    |
[INFO] [stdout] 43 |     /// RFC 3596[2] IPv6 address record
[INFO] [stdout]    |                  ^ the module `record_type` contains no item named `2`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `1`
[INFO] [stdout]   --> src/rr/record_type.rs:48:18
[INFO] [stdout]    |
[INFO] [stdout] 48 |     /// RFC 1035[1] All cached records, aka ANY
[INFO] [stdout]    |                  ^ the module `record_type` contains no item named `1`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `1`
[INFO] [stdout]   --> src/rr/record_type.rs:51:18
[INFO] [stdout]    |
[INFO] [stdout] 51 |     /// RFC 1035[1] Authoritative Zone Transfer
[INFO] [stdout]    |                  ^ the module `record_type` contains no item named `1`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `1`
[INFO] [stdout]   --> src/rr/record_type.rs:56:18
[INFO] [stdout]    |
[INFO] [stdout] 56 |     /// RFC 1035[1] Canonical name record
[INFO] [stdout]    |                  ^ the module `record_type` contains no item named `1`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `1`
[INFO] [stdout]   --> src/rr/record_type.rs:66:18
[INFO] [stdout]    |
[INFO] [stdout] 66 |     /// RFC 1035[1] Mail exchange record
[INFO] [stdout]    |                  ^ the module `record_type` contains no item named `1`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `1`
[INFO] [stdout]   --> src/rr/record_type.rs:70:18
[INFO] [stdout]    |
[INFO] [stdout] 70 |     /// RFC 1035[1] Name server record
[INFO] [stdout]    |                  ^ the module `record_type` contains no item named `1`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `1`
[INFO] [stdout]   --> src/rr/record_type.rs:72:18
[INFO] [stdout]    |
[INFO] [stdout] 72 |     /// RFC 1035[1] Null server record, for testing
[INFO] [stdout]    |                  ^ the module `record_type` contains no item named `1`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `1`
[INFO] [stdout]   --> src/rr/record_type.rs:78:18
[INFO] [stdout]    |
[INFO] [stdout] 78 |     /// RFC 1035[1] Pointer record
[INFO] [stdout]    |                  ^ the module `record_type` contains no item named `1`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `1`
[INFO] [stdout]   --> src/rr/record_type.rs:81:18
[INFO] [stdout]    |
[INFO] [stdout] 81 |     /// RFC 1035[1] and RFC 2308[9] Start of [a zone of] authority record
[INFO] [stdout]    |                  ^ the module `record_type` contains no item named `1`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `9`
[INFO] [stdout]   --> src/rr/record_type.rs:81:34
[INFO] [stdout]    |
[INFO] [stdout] 81 |     /// RFC 1035[1] and RFC 2308[9] Start of [a zone of] authority record
[INFO] [stdout]    |                                  ^ the module `record_type` contains no item named `9`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `1`
[INFO] [stdout]   --> src/rr/record_type.rs:92:18
[INFO] [stdout]    |
[INFO] [stdout] 92 |     /// RFC 1035[1] Text record
[INFO] [stdout]    |                  ^ the module `record_type` contains no item named `1`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `futures::sync::mpsc::UnboundedSender`
[INFO] [stdout]   --> src/xfer/mod.rs:74:14
[INFO] [stdout]    |
[INFO] [stdout] 74 |     /// see [`futures::sync::mpsc::UnboundedSender`]
[INFO] [stdout]    |              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ the module `xfer` contains no item named `futures`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `futures::sync::mpsc::UnboundedSender`
[INFO] [stdout]    --> src/xfer/mod.rs:130:14
[INFO] [stdout]     |
[INFO] [stdout] 130 |     /// see [`futures::sync::mpsc::UnboundedSender`]
[INFO] [stdout]     |              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ the module `xfer` contains no item named `futures`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `from_ascii`
[INFO] [stdout]     --> src/rr/domain/name.rs:1241:66
[INFO] [stdout]      |
[INFO] [stdout] 1241 |     /// Uses the Name::from_utf8 conversion on this string, see [`from_ascii`] for ascii only, or for preserving case
[INFO] [stdout]      |                                                                  ^^^^^^^^^^^^ the module `name` contains no item named `from_ascii`
[INFO] [stdout]      |
[INFO] [stdout]      = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: 20 warnings emitted
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr]     Finished dev [unoptimized + debuginfo] target(s) in 26.33s
[INFO] running `Command { std: "docker" "inspect" "62b7b13a615ca9f5084e824d9b4454fdb6e0ff3445a29b0c52a1de18949467cd", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "62b7b13a615ca9f5084e824d9b4454fdb6e0ff3445a29b0c52a1de18949467cd", kill_on_drop: false }`
[INFO] [stdout] 62b7b13a615ca9f5084e824d9b4454fdb6e0ff3445a29b0c52a1de18949467cd
