[INFO] fetching crate rustic_hal 0.2.0...
[INFO] documenting rustic_hal-0.2.0 against beta-2020-10-09 for beta-1.48-rustdoc-1
[INFO] extracting crate rustic_hal 0.2.0 into /workspace/builds/worker-3/source
[INFO] validating manifest of crates.io crate rustic_hal 0.2.0 on toolchain beta-2020-10-09
[INFO] running `Command { std: "/workspace/cargo-home/bin/cargo" "+beta-2020-10-09" "read-manifest" "--manifest-path" "Cargo.toml", kill_on_drop: false }`
[INFO] started tweaking crates.io crate rustic_hal 0.2.0
[INFO] finished tweaking crates.io crate rustic_hal 0.2.0
[INFO] tweaked toml for crates.io crate rustic_hal 0.2.0 written to /workspace/builds/worker-3/source/Cargo.toml
[INFO] running `Command { std: "/workspace/cargo-home/bin/cargo" "+beta-2020-10-09" "generate-lockfile" "--manifest-path" "Cargo.toml" "-Zno-index-update", kill_on_drop: false }`
[INFO] running `Command { std: "/workspace/cargo-home/bin/cargo" "+beta-2020-10-09" "fetch" "--locked" "--manifest-path" "Cargo.toml", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-3/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-3/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "rustops/crates-build-env@sha256:d92eaeed33fa75130ca1ee6c8a01d1ffb62bac859dfdfb3450e3e5d1c0146529" "/opt/rustwide/cargo-home/bin/cargo" "+beta-2020-10-09" "metadata" "--no-deps" "--format-version=1", kill_on_drop: false }`
[INFO] [stderr] WARNING: Your kernel does not support swap limit capabilities or the cgroup is not mounted. Memory limited without swap.
[INFO] [stdout] 3711a465a0ed1f730032edfbdb833968bd44fe4b3227e3c5278bb5f6a5e044d8
[INFO] running `Command { std: "docker" "start" "-a" "3711a465a0ed1f730032edfbdb833968bd44fe4b3227e3c5278bb5f6a5e044d8", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "inspect" "3711a465a0ed1f730032edfbdb833968bd44fe4b3227e3c5278bb5f6a5e044d8", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "3711a465a0ed1f730032edfbdb833968bd44fe4b3227e3c5278bb5f6a5e044d8", kill_on_drop: false }`
[INFO] [stdout] 3711a465a0ed1f730032edfbdb833968bd44fe4b3227e3c5278bb5f6a5e044d8
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-3/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-3/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "rustops/crates-build-env@sha256:d92eaeed33fa75130ca1ee6c8a01d1ffb62bac859dfdfb3450e3e5d1c0146529" "/opt/rustwide/cargo-home/bin/cargo" "+beta-2020-10-09" "doc" "--frozen" "--no-deps" "--document-private-items" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] a1cf736867a4be228e8d30cc3452d18f583e44a36923ae617fd5cf813746b1fd
[INFO] [stderr] WARNING: Your kernel does not support swap limit capabilities or the cgroup is not mounted. Memory limited without swap.
[INFO] running `Command { std: "docker" "start" "-a" "a1cf736867a4be228e8d30cc3452d18f583e44a36923ae617fd5cf813746b1fd", kill_on_drop: false }`
[INFO] [stderr]    Compiling rustic_hal v0.2.0 (/opt/rustwide/workdir)
[INFO] [stderr]  Documenting rustic_hal v0.2.0 (/opt/rustwide/workdir)
[INFO] [stdout] warning: unresolved link to `RFC3986`
[INFO] [stdout]   --> src/link.rs:19:36
[INFO] [stdout]    |
[INFO] [stdout] 19 |     /// Its value is either a URI [RFC3986] or a URI Template [RFC6570].
[INFO] [stdout]    |                                    ^^^^^^^ the module `link` contains no item named `RFC3986`
[INFO] [stdout]    |
[INFO] [stdout]    = note: `#[warn(broken_intra_doc_links)]` on by default
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6570`
[INFO] [stdout]   --> src/link.rs:19:64
[INFO] [stdout]    |
[INFO] [stdout] 19 |     /// Its value is either a URI [RFC3986] or a URI Template [RFC6570].
[INFO] [stdout]    |                                                                ^^^^^^^ the module `link` contains no item named `RFC6570`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5988`
[INFO] [stdout]   --> src/link.rs:70:51
[INFO] [stdout]    |
[INFO] [stdout] 70 |     /// human-readable identifier (as defined by [RFC5988]).
[INFO] [stdout]    |                                                   ^^^^^^^ the module `link` contains no item named `RFC5988`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5988`
[INFO] [stdout]   --> src/link.rs:76:45
[INFO] [stdout]    |
[INFO] [stdout] 76 |     /// the target resource (as defined by [RFC5988]).
[INFO] [stdout]    |                                             ^^^^^^^ the module `link` contains no item named `RFC5988`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: 4 warnings emitted
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr]     Finished dev [unoptimized + debuginfo] target(s) in 2.78s
[INFO] running `Command { std: "docker" "inspect" "a1cf736867a4be228e8d30cc3452d18f583e44a36923ae617fd5cf813746b1fd", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "a1cf736867a4be228e8d30cc3452d18f583e44a36923ae617fd5cf813746b1fd", kill_on_drop: false }`
[INFO] [stdout] a1cf736867a4be228e8d30cc3452d18f583e44a36923ae617fd5cf813746b1fd
