[INFO] fetching crate pnet_packet 0.26.0...
[INFO] documenting pnet_packet-0.26.0 against beta-2020-10-09 for beta-1.48-rustdoc-1
[INFO] extracting crate pnet_packet 0.26.0 into /workspace/builds/worker-8/source
[INFO] validating manifest of crates.io crate pnet_packet 0.26.0 on toolchain beta-2020-10-09
[INFO] running `Command { std: "/workspace/cargo-home/bin/cargo" "+beta-2020-10-09" "read-manifest" "--manifest-path" "Cargo.toml", kill_on_drop: false }`
[INFO] started tweaking crates.io crate pnet_packet 0.26.0
[INFO] finished tweaking crates.io crate pnet_packet 0.26.0
[INFO] tweaked toml for crates.io crate pnet_packet 0.26.0 written to /workspace/builds/worker-8/source/Cargo.toml
[INFO] running `Command { std: "/workspace/cargo-home/bin/cargo" "+beta-2020-10-09" "generate-lockfile" "--manifest-path" "Cargo.toml" "-Zno-index-update", kill_on_drop: false }`
[INFO] running `Command { std: "/workspace/cargo-home/bin/cargo" "+beta-2020-10-09" "fetch" "--locked" "--manifest-path" "Cargo.toml", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-8/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-8/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "rustops/crates-build-env@sha256:d92eaeed33fa75130ca1ee6c8a01d1ffb62bac859dfdfb3450e3e5d1c0146529" "/opt/rustwide/cargo-home/bin/cargo" "+beta-2020-10-09" "metadata" "--no-deps" "--format-version=1", kill_on_drop: false }`
[INFO] [stderr] WARNING: Your kernel does not support swap limit capabilities or the cgroup is not mounted. Memory limited without swap.
[INFO] [stdout] 241187fe56d6156c7860d7d86a982b0e5ac60d38e04f8214c0f81d3fef10b88e
[INFO] running `Command { std: "docker" "start" "-a" "241187fe56d6156c7860d7d86a982b0e5ac60d38e04f8214c0f81d3fef10b88e", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "inspect" "241187fe56d6156c7860d7d86a982b0e5ac60d38e04f8214c0f81d3fef10b88e", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "241187fe56d6156c7860d7d86a982b0e5ac60d38e04f8214c0f81d3fef10b88e", kill_on_drop: false }`
[INFO] [stdout] 241187fe56d6156c7860d7d86a982b0e5ac60d38e04f8214c0f81d3fef10b88e
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-8/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-8/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "rustops/crates-build-env@sha256:d92eaeed33fa75130ca1ee6c8a01d1ffb62bac859dfdfb3450e3e5d1c0146529" "/opt/rustwide/cargo-home/bin/cargo" "+beta-2020-10-09" "doc" "--frozen" "--no-deps" "--document-private-items" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] d0dfc4accc390a27d7c9c7db0968a7844e2147949e610edf5d34334a2238bb85
[INFO] [stderr] WARNING: Your kernel does not support swap limit capabilities or the cgroup is not mounted. Memory limited without swap.
[INFO] running `Command { std: "docker" "start" "-a" "d0dfc4accc390a27d7c9c7db0968a7844e2147949e610edf5d34334a2238bb85", kill_on_drop: false }`
[INFO] [stderr]    Compiling rustc-serialize v0.3.24
[INFO] [stderr]    Compiling term v0.4.6
[INFO] [stderr]    Compiling unicode-xid v0.0.3
[INFO] [stderr]    Compiling bitflags v0.5.0
[INFO] [stderr]     Checking pnet_base v0.26.0
[INFO] [stderr]     Checking pnet_macros_support v0.26.0
[INFO] [stderr]    Compiling syntex_pos v0.42.0
[INFO] [stderr]    Compiling syntex_errors v0.42.0
[INFO] [stderr]    Compiling syntex_syntax v0.42.0
[INFO] [stderr]    Compiling syntex v0.42.2
[INFO] [stderr]    Compiling pnet_macros v0.26.0
[INFO] [stderr]    Compiling pnet_packet v0.26.0 (/opt/rustwide/workdir)
[INFO] [stderr]  Documenting pnet_packet v0.26.0 (/opt/rustwide/workdir)
[INFO] [stdout] warning: unnecessary braces around method argument
[INFO] [stdout]    --> /opt/rustwide/target/debug/build/pnet_packet-0f4a11e09b544f7f/out/gre.rs:386:22
[INFO] [stdout]     |
[INFO] [stdout] 386 |             vec.push({ (packet[co] as u8) });
[INFO] [stdout]     |                      ^^^^^^^^^^^^^^^^^^^^^^ help: remove these braces
[INFO] [stdout]     |
[INFO] [stdout]     = note: `#[warn(unused_braces)]` on by default
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unnecessary braces around method argument
[INFO] [stdout]    --> /opt/rustwide/target/debug/build/pnet_packet-0f4a11e09b544f7f/out/gre.rs:759:22
[INFO] [stdout]     |
[INFO] [stdout] 759 |             vec.push({ (packet[co] as u8) });
[INFO] [stdout]     |                      ^^^^^^^^^^^^^^^^^^^^^^ help: remove these braces
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unnecessary braces around method argument
[INFO] [stdout]     --> /opt/rustwide/target/debug/build/pnet_packet-0f4a11e09b544f7f/out/ipv4.rs:1407:22
[INFO] [stdout]      |
[INFO] [stdout] 1407 |             vec.push({ (packet[co] as u8) });
[INFO] [stdout]      |                      ^^^^^^^^^^^^^^^^^^^^^^ help: remove these braces
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unnecessary braces around method argument
[INFO] [stdout]     --> /opt/rustwide/target/debug/build/pnet_packet-0f4a11e09b544f7f/out/ipv4.rs:1530:22
[INFO] [stdout]      |
[INFO] [stdout] 1530 |             vec.push({ (packet[co] as u8) });
[INFO] [stdout]      |                      ^^^^^^^^^^^^^^^^^^^^^^ help: remove these braces
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unnecessary braces around method argument
[INFO] [stdout]     --> /opt/rustwide/target/debug/build/pnet_packet-0f4a11e09b544f7f/out/tcp.rs:1009:22
[INFO] [stdout]      |
[INFO] [stdout] 1009 |             vec.push({ (packet[co] as u8) });
[INFO] [stdout]      |                      ^^^^^^^^^^^^^^^^^^^^^^ help: remove these braces
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unnecessary braces around method argument
[INFO] [stdout]     --> /opt/rustwide/target/debug/build/pnet_packet-0f4a11e09b544f7f/out/tcp.rs:1110:22
[INFO] [stdout]      |
[INFO] [stdout] 1110 |             vec.push({ (packet[co] as u8) });
[INFO] [stdout]      |                      ^^^^^^^^^^^^^^^^^^^^^^ help: remove these braces
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC7042`
[INFO] [stdout]    --> /opt/rustwide/target/debug/build/pnet_packet-0f4a11e09b544f7f/out/ethernet.rs:711:45
[INFO] [stdout]     |
[INFO] [stdout] 711 |     /// Internet Protocol version 4 (IPv4) [RFC7042].
[INFO] [stdout]     |                                             ^^^^^^^ the module `EtherTypes` contains no item named `RFC7042`
[INFO] [stdout]     |
[INFO] [stdout]     = note: `#[warn(broken_intra_doc_links)]` on by default
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC7042`
[INFO] [stdout]    --> /opt/rustwide/target/debug/build/pnet_packet-0f4a11e09b544f7f/out/ethernet.rs:713:44
[INFO] [stdout]     |
[INFO] [stdout] 713 |     /// Address Resolution Protocol (ARP) [RFC7042].
[INFO] [stdout]     |                                            ^^^^^^^ the module `EtherTypes` contains no item named `RFC7042`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `IEEE`
[INFO] [stdout]    --> /opt/rustwide/target/debug/build/pnet_packet-0f4a11e09b544f7f/out/ethernet.rs:717:30
[INFO] [stdout]     |
[INFO] [stdout] 717 |     /// IETF TRILL Protocol [IEEE].
[INFO] [stdout]     |                              ^^^^ the module `EtherTypes` contains no item named `IEEE`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC903`
[INFO] [stdout]    --> /opt/rustwide/target/debug/build/pnet_packet-0f4a11e09b544f7f/out/ethernet.rs:721:53
[INFO] [stdout]     |
[INFO] [stdout] 721 |     /// Reverse Address Resolution Protocol (RARP) [RFC903].
[INFO] [stdout]     |                                                     ^^^^^^ the module `EtherTypes` contains no item named `RFC903`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `Apple`
[INFO] [stdout]    --> /opt/rustwide/target/debug/build/pnet_packet-0f4a11e09b544f7f/out/ethernet.rs:723:32
[INFO] [stdout]     |
[INFO] [stdout] 723 |     /// AppleTalk - EtherTalk [Apple].
[INFO] [stdout]     |                                ^^^^^ the module `EtherTypes` contains no item named `Apple`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `Apple`
[INFO] [stdout]    --> /opt/rustwide/target/debug/build/pnet_packet-0f4a11e09b544f7f/out/ethernet.rs:725:55
[INFO] [stdout]     |
[INFO] [stdout] 725 |     /// AppleTalk Address Resolution Protocol (AARP) [Apple].
[INFO] [stdout]     |                                                       ^^^^^ the module `EtherTypes` contains no item named `Apple`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `Xerox`
[INFO] [stdout]    --> /opt/rustwide/target/debug/build/pnet_packet-0f4a11e09b544f7f/out/ethernet.rs:727:14
[INFO] [stdout]     |
[INFO] [stdout] 727 |     /// IPX [Xerox].
[INFO] [stdout]     |              ^^^^^ the module `EtherTypes` contains no item named `Xerox`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC7042`
[INFO] [stdout]    --> /opt/rustwide/target/debug/build/pnet_packet-0f4a11e09b544f7f/out/ethernet.rs:731:45
[INFO] [stdout]     |
[INFO] [stdout] 731 |     /// Internet Protocol version 6 (IPv6) [RFC7042].
[INFO] [stdout]     |                                             ^^^^^^^ the module `EtherTypes` contains no item named `RFC7042`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2460`
[INFO] [stdout]   --> src/ip.rs:27:33
[INFO] [stdout]    |
[INFO] [stdout] 27 |     /// IPv6 Hop-by-Hop Option [RFC2460]
[INFO] [stdout]    |                                 ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC2460`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC792`
[INFO] [stdout]   --> src/ip.rs:30:35
[INFO] [stdout]    |
[INFO] [stdout] 30 |     /// Internet Control Message [RFC792]
[INFO] [stdout]    |                                   ^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC792`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC1112`
[INFO] [stdout]   --> src/ip.rs:33:36
[INFO] [stdout]    |
[INFO] [stdout] 33 |     /// Internet Group Management [RFC1112]
[INFO] [stdout]    |                                    ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC1112`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC823`
[INFO] [stdout]   --> src/ip.rs:36:29
[INFO] [stdout]    |
[INFO] [stdout] 36 |     /// Gateway-to-Gateway [RFC823]
[INFO] [stdout]    |                             ^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC823`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2003`
[INFO] [stdout]   --> src/ip.rs:39:29
[INFO] [stdout]    |
[INFO] [stdout] 39 |     /// IPv4 encapsulation [RFC2003]
[INFO] [stdout]    |                             ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC2003`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC1819`
[INFO] [stdout]   --> src/ip.rs:42:26
[INFO] [stdout]    |
[INFO] [stdout] 42 |     /// Stream [RFC1190][RFC1819]
[INFO] [stdout]    |                          ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC1819`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC793`
[INFO] [stdout]   --> src/ip.rs:45:31
[INFO] [stdout]    |
[INFO] [stdout] 45 |     /// Transmission Control [RFC793]
[INFO] [stdout]    |                               ^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC793`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC888`
[INFO] [stdout]   --> src/ip.rs:51:36
[INFO] [stdout]    |
[INFO] [stdout] 51 |     /// Exterior Gateway Protocol [RFC888]
[INFO] [stdout]    |                                    ^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC888`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC741`
[INFO] [stdout]   --> src/ip.rs:60:33
[INFO] [stdout]    |
[INFO] [stdout] 60 |     /// Network Voice Protocol [RFC741]
[INFO] [stdout]    |                                 ^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC741`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC768`
[INFO] [stdout]   --> src/ip.rs:78:24
[INFO] [stdout]    |
[INFO] [stdout] 78 |     /// User Datagram [RFC768]
[INFO] [stdout]    |                        ^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC768`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC869`
[INFO] [stdout]   --> src/ip.rs:87:26
[INFO] [stdout]    |
[INFO] [stdout] 87 |     /// Host Monitoring [RFC869]
[INFO] [stdout]    |                          ^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC869`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC908`
[INFO] [stdout]    --> src/ip.rs:108:33
[INFO] [stdout]     |
[INFO] [stdout] 108 |     /// Reliable Data Protocol [RFC908]
[INFO] [stdout]     |                                 ^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC908`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC938`
[INFO] [stdout]    --> src/ip.rs:111:40
[INFO] [stdout]     |
[INFO] [stdout] 111 |     /// Internet Reliable Transaction [RFC938]
[INFO] [stdout]     |                                        ^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC938`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC905`
[INFO] [stdout]    --> src/ip.rs:114:41
[INFO] [stdout]     |
[INFO] [stdout] 114 |     /// ISO Transport Protocol Class 4 [RFC905]
[INFO] [stdout]     |                                         ^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC905`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC969`
[INFO] [stdout]    --> src/ip.rs:117:38
[INFO] [stdout]     |
[INFO] [stdout] 117 |     /// Bulk Data Transfer Protocol [RFC969]
[INFO] [stdout]     |                                      ^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC969`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4340`
[INFO] [stdout]    --> src/ip.rs:126:47
[INFO] [stdout]     |
[INFO] [stdout] 126 |     /// Datagram Congestion Control Protocol [RFC4340]
[INFO] [stdout]     |                                               ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC4340`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2473`
[INFO] [stdout]    --> src/ip.rs:150:29
[INFO] [stdout]     |
[INFO] [stdout] 150 |     /// IPv6 encapsulation [RFC2473]
[INFO] [stdout]     |                             ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC2473`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3209`
[INFO] [stdout]    --> src/ip.rs:165:40
[INFO] [stdout]     |
[INFO] [stdout] 165 |     /// Reservation Protocol [RFC2205][RFC3209]
[INFO] [stdout]     |                                        ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC3209`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC1701`
[INFO] [stdout]    --> src/ip.rs:168:40
[INFO] [stdout]     |
[INFO] [stdout] 168 |     /// Generic Routing Encapsulation [RFC1701]
[INFO] [stdout]     |                                        ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC1701`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4728`
[INFO] [stdout]    --> src/ip.rs:171:42
[INFO] [stdout]     |
[INFO] [stdout] 171 |     /// Dynamic Source Routing Protocol [RFC4728]
[INFO] [stdout]     |                                          ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC4728`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4303`
[INFO] [stdout]    --> src/ip.rs:177:33
[INFO] [stdout]     |
[INFO] [stdout] 177 |     /// Encap Security Payload [RFC4303]
[INFO] [stdout]     |                                 ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC4303`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4302`
[INFO] [stdout]    --> src/ip.rs:180:32
[INFO] [stdout]     |
[INFO] [stdout] 180 |     /// Authentication Header [RFC4302]
[INFO] [stdout]     |                                ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC4302`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC1735`
[INFO] [stdout]    --> src/ip.rs:189:43
[INFO] [stdout]     |
[INFO] [stdout] 189 |     /// NBMA Address Resolution Protocol [RFC1735]
[INFO] [stdout]     |                                           ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC1735`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4443`
[INFO] [stdout]    --> src/ip.rs:204:17
[INFO] [stdout]     |
[INFO] [stdout] 204 |     /// ICMPv6 [RFC4443]
[INFO] [stdout]     |                 ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC4443`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2460`
[INFO] [stdout]    --> src/ip.rs:207:34
[INFO] [stdout]     |
[INFO] [stdout] 207 |     /// No Next Header for IPv6 [RFC2460]
[INFO] [stdout]     |                                  ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC2460`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2460`
[INFO] [stdout]    --> src/ip.rs:210:39
[INFO] [stdout]     |
[INFO] [stdout] 210 |     /// Destination Options for IPv6 [RFC2460]
[INFO] [stdout]     |                                       ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC2460`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2328`
[INFO] [stdout]    --> src/ip.rs:297:27
[INFO] [stdout]     |
[INFO] [stdout] 297 |     /// OSPFIGP [RFC1583][RFC2328][RFC5340]
[INFO] [stdout]     |                           ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC2328`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5340`
[INFO] [stdout]    --> src/ip.rs:297:36
[INFO] [stdout]     |
[INFO] [stdout] 297 |     /// OSPFIGP [RFC1583][RFC2328][RFC5340]
[INFO] [stdout]     |                                    ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC5340`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3378`
[INFO] [stdout]    --> src/ip.rs:321:43
[INFO] [stdout]     |
[INFO] [stdout] 321 |     /// Ethernet-within-IP Encapsulation [RFC3378]
[INFO] [stdout]     |                                           ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC3378`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC1241`
[INFO] [stdout]    --> src/ip.rs:324:31
[INFO] [stdout]     |
[INFO] [stdout] 324 |     /// Encapsulation Header [RFC1241]
[INFO] [stdout]     |                               ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC1241`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4601`
[INFO] [stdout]    --> src/ip.rs:339:41
[INFO] [stdout]     |
[INFO] [stdout] 339 |     /// Protocol Independent Multicast [RFC4601]
[INFO] [stdout]     |                                         ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC4601`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC2393`
[INFO] [stdout]    --> src/ip.rs:354:42
[INFO] [stdout]     |
[INFO] [stdout] 354 |     /// IP Payload Compression Protocol [RFC2393]
[INFO] [stdout]     |                                          ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC2393`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5798`
[INFO] [stdout]    --> src/ip.rs:366:45
[INFO] [stdout]     |
[INFO] [stdout] 366 |     /// Virtual Router Redundancy Protocol [RFC5798]
[INFO] [stdout]     |                                             ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC5798`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3931`
[INFO] [stdout]    --> src/ip.rs:375:39
[INFO] [stdout]     |
[INFO] [stdout] 375 |     /// Layer Two Tunneling Protocol [RFC3931]
[INFO] [stdout]     |                                       ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC3931`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6172`
[INFO] [stdout]    --> src/ip.rs:429:24
[INFO] [stdout]     |
[INFO] [stdout] 429 |     /// Fibre Channel [RFC6172]
[INFO] [stdout]     |                        ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC6172`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3175`
[INFO] [stdout]    --> src/ip.rs:432:10
[INFO] [stdout]     |
[INFO] [stdout] 432 |     /// [RFC3175]
[INFO] [stdout]     |          ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC3175`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6275`
[INFO] [stdout]    --> src/ip.rs:435:10
[INFO] [stdout]     |
[INFO] [stdout] 435 |     /// [RFC6275]
[INFO] [stdout]     |          ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC6275`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3828`
[INFO] [stdout]    --> src/ip.rs:438:10
[INFO] [stdout]     |
[INFO] [stdout] 438 |     /// [RFC3828]
[INFO] [stdout]     |          ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC3828`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4023`
[INFO] [stdout]    --> src/ip.rs:441:10
[INFO] [stdout]     |
[INFO] [stdout] 441 |     /// [RFC4023]
[INFO] [stdout]     |          ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC4023`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5498`
[INFO] [stdout]    --> src/ip.rs:444:26
[INFO] [stdout]     |
[INFO] [stdout] 444 |     /// MANET Protocols [RFC5498]
[INFO] [stdout]     |                          ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC5498`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5201`
[INFO] [stdout]    --> src/ip.rs:447:33
[INFO] [stdout]     |
[INFO] [stdout] 447 |     /// Host Identity Protocol [RFC5201]
[INFO] [stdout]     |                                 ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC5201`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5533`
[INFO] [stdout]    --> src/ip.rs:450:25
[INFO] [stdout]     |
[INFO] [stdout] 450 |     /// Shim6 Protocol [RFC5533]
[INFO] [stdout]     |                         ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC5533`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5840`
[INFO] [stdout]    --> src/ip.rs:453:49
[INFO] [stdout]     |
[INFO] [stdout] 453 |     /// Wrapped Encapsulating Security Payload [RFC5840]
[INFO] [stdout]     |                                                 ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC5840`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5858`
[INFO] [stdout]    --> src/ip.rs:456:36
[INFO] [stdout]     |
[INFO] [stdout] 456 |     /// Robust Header Compression [RFC5858]
[INFO] [stdout]     |                                    ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC5858`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3692`
[INFO] [stdout]    --> src/ip.rs:459:46
[INFO] [stdout]     |
[INFO] [stdout] 459 |     /// Use for experimentation and testing [RFC3692]
[INFO] [stdout]     |                                              ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC3692`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3692`
[INFO] [stdout]    --> src/ip.rs:462:46
[INFO] [stdout]     |
[INFO] [stdout] 462 |     /// Use for experimentation and testing [RFC3692]
[INFO] [stdout]     |                                              ^^^^^^^ the module `IpNextHeaderProtocols` contains no item named `RFC3692`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: 60 warnings emitted
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr]     Finished dev [unoptimized + debuginfo] target(s) in 38.32s
[INFO] running `Command { std: "docker" "inspect" "d0dfc4accc390a27d7c9c7db0968a7844e2147949e610edf5d34334a2238bb85", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "d0dfc4accc390a27d7c9c7db0968a7844e2147949e610edf5d34334a2238bb85", kill_on_drop: false }`
[INFO] [stdout] d0dfc4accc390a27d7c9c7db0968a7844e2147949e610edf5d34334a2238bb85
