[INFO] fetching crate bgp-rs 0.6.0...
[INFO] documenting bgp-rs-0.6.0 against beta-2020-10-09 for beta-1.48-rustdoc-1
[INFO] extracting crate bgp-rs 0.6.0 into /workspace/builds/worker-12/source
[INFO] validating manifest of crates.io crate bgp-rs 0.6.0 on toolchain beta-2020-10-09
[INFO] running `Command { std: "/workspace/cargo-home/bin/cargo" "+beta-2020-10-09" "read-manifest" "--manifest-path" "Cargo.toml", kill_on_drop: false }`
[INFO] started tweaking crates.io crate bgp-rs 0.6.0
[INFO] finished tweaking crates.io crate bgp-rs 0.6.0
[INFO] tweaked toml for crates.io crate bgp-rs 0.6.0 written to /workspace/builds/worker-12/source/Cargo.toml
[INFO] running `Command { std: "/workspace/cargo-home/bin/cargo" "+beta-2020-10-09" "generate-lockfile" "--manifest-path" "Cargo.toml" "-Zno-index-update", kill_on_drop: false }`
[INFO] running `Command { std: "/workspace/cargo-home/bin/cargo" "+beta-2020-10-09" "fetch" "--locked" "--manifest-path" "Cargo.toml", kill_on_drop: false }`
[INFO] [stderr]  Downloading crates ...
[INFO] [stderr]   Downloaded derive-into-owned v0.1.0
[INFO] [stderr]   Downloaded pcap-file v1.1.1
[INFO] [stderr]   Downloaded mrt-rs v2.0.1
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-12/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-12/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "rustops/crates-build-env@sha256:d92eaeed33fa75130ca1ee6c8a01d1ffb62bac859dfdfb3450e3e5d1c0146529" "/opt/rustwide/cargo-home/bin/cargo" "+beta-2020-10-09" "metadata" "--no-deps" "--format-version=1", kill_on_drop: false }`
[INFO] [stdout] 0b15f271b992289bfe2f7e09312742b917decff65375350746d4924819b1b5ff
[INFO] [stderr] WARNING: Your kernel does not support swap limit capabilities or the cgroup is not mounted. Memory limited without swap.
[INFO] running `Command { std: "docker" "start" "-a" "0b15f271b992289bfe2f7e09312742b917decff65375350746d4924819b1b5ff", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "inspect" "0b15f271b992289bfe2f7e09312742b917decff65375350746d4924819b1b5ff", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "0b15f271b992289bfe2f7e09312742b917decff65375350746d4924819b1b5ff", kill_on_drop: false }`
[INFO] [stdout] 0b15f271b992289bfe2f7e09312742b917decff65375350746d4924819b1b5ff
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-12/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-12/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "rustops/crates-build-env@sha256:d92eaeed33fa75130ca1ee6c8a01d1ffb62bac859dfdfb3450e3e5d1c0146529" "/opt/rustwide/cargo-home/bin/cargo" "+beta-2020-10-09" "doc" "--frozen" "--no-deps" "--document-private-items" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] 90d1e2a99103a552dc68c4a00261e5259ea6541b96c828c6ae9cf9eea7ae5da0
[INFO] [stderr] WARNING: Your kernel does not support swap limit capabilities or the cgroup is not mounted. Memory limited without swap.
[INFO] running `Command { std: "docker" "start" "-a" "90d1e2a99103a552dc68c4a00261e5259ea6541b96c828c6ae9cf9eea7ae5da0", kill_on_drop: false }`
[INFO] [stderr]    Compiling byteorder v1.3.4
[INFO] [stderr]  Documenting bgp-rs v0.6.0 (/opt/rustwide/workdir)
[INFO] [stdout] warning: unresolved link to `RFC4760`
[INFO] [stdout]    --> src/lib.rs:183:29
[INFO] [stdout]     |
[INFO] [stdout] 183 |     /// Unicast Forwarding [RFC4760]
[INFO] [stdout]     |                             ^^^^^^^ the module `bgp_rs` contains no item named `RFC4760`
[INFO] [stdout]     |
[INFO] [stdout]     = note: `#[warn(broken_intra_doc_links)]` on by default
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4760`
[INFO] [stdout]    --> src/lib.rs:185:31
[INFO] [stdout]     |
[INFO] [stdout] 185 |     /// Multicast Forwarding [RFC4760]
[INFO] [stdout]     |                               ^^^^^^^ the module `bgp_rs` contains no item named `RFC4760`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3107`
[INFO] [stdout]    --> src/lib.rs:187:22
[INFO] [stdout]     |
[INFO] [stdout] 187 |     /// MPLS Labels [RFC3107]
[INFO] [stdout]     |                      ^^^^^^^ the module `bgp_rs` contains no item named `RFC3107`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC7752`
[INFO] [stdout]    --> src/lib.rs:195:17
[INFO] [stdout]     |
[INFO] [stdout] 195 |     /// BGP LS [RFC7752]
[INFO] [stdout]     |                 ^^^^^^^ the module `bgp_rs` contains no item named `RFC7752`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC7752`
[INFO] [stdout]    --> src/lib.rs:197:21
[INFO] [stdout]     |
[INFO] [stdout] 197 |     /// BGP LS VPN [RFC7752]
[INFO] [stdout]     |                     ^^^^^^^ the module `bgp_rs` contains no item named `RFC7752`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4684`
[INFO] [stdout]    --> src/lib.rs:199:14
[INFO] [stdout]     |
[INFO] [stdout] 199 |     /// RTC [RFC4684]
[INFO] [stdout]     |              ^^^^^^^ the module `bgp_rs` contains no item named `RFC4684`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4364`
[INFO] [stdout]    --> src/lib.rs:201:19
[INFO] [stdout]     |
[INFO] [stdout] 201 |     /// MPLS VPN [RFC4364]
[INFO] [stdout]     |                   ^^^^^^^ the module `bgp_rs` contains no item named `RFC4364`
[INFO] [stdout]     |
[INFO] [stdout]     = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4271`
[INFO] [stdout]   --> src/notification.rs:11:27
[INFO] [stdout]    |
[INFO] [stdout] 11 |     /// Major Error Code [RFC4271]
[INFO] [stdout]    |                           ^^^^^^^ the module `notification` contains no item named `RFC4271`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4271`
[INFO] [stdout]   --> src/notification.rs:13:27
[INFO] [stdout]    |
[INFO] [stdout] 13 |     /// Minor Error Code [RFC4271]
[INFO] [stdout]    |                           ^^^^^^^ the module `notification` contains no item named `RFC4271`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: 9 warnings emitted
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr]     Finished dev [unoptimized + debuginfo] target(s) in 3.56s
[INFO] running `Command { std: "docker" "inspect" "90d1e2a99103a552dc68c4a00261e5259ea6541b96c828c6ae9cf9eea7ae5da0", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "90d1e2a99103a552dc68c4a00261e5259ea6541b96c828c6ae9cf9eea7ae5da0", kill_on_drop: false }`
[INFO] [stdout] 90d1e2a99103a552dc68c4a00261e5259ea6541b96c828c6ae9cf9eea7ae5da0
