[INFO] fetching crate openid 0.6.0...
[INFO] documenting openid-0.6.0 against beta-2020-10-09 for beta-1.48-rustdoc-1
[INFO] extracting crate openid 0.6.0 into /workspace/builds/worker-6/source
[INFO] validating manifest of crates.io crate openid 0.6.0 on toolchain beta-2020-10-09
[INFO] running `Command { std: "/workspace/cargo-home/bin/cargo" "+beta-2020-10-09" "read-manifest" "--manifest-path" "Cargo.toml", kill_on_drop: false }`
[INFO] started tweaking crates.io crate openid 0.6.0
[INFO] finished tweaking crates.io crate openid 0.6.0
[INFO] tweaked toml for crates.io crate openid 0.6.0 written to /workspace/builds/worker-6/source/Cargo.toml
[INFO] running `Command { std: "/workspace/cargo-home/bin/cargo" "+beta-2020-10-09" "generate-lockfile" "--manifest-path" "Cargo.toml" "-Zno-index-update", kill_on_drop: false }`
[INFO] running `Command { std: "/workspace/cargo-home/bin/cargo" "+beta-2020-10-09" "fetch" "--locked" "--manifest-path" "Cargo.toml", kill_on_drop: false }`
[INFO] [stderr]  Downloading crates ...
[INFO] [stderr]   Downloaded validator v0.11.0
[INFO] [stderr]   Downloaded validator_derive v0.11.0
[INFO] [stderr]   Downloaded validator_types v0.11.0
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-6/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-6/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "rustops/crates-build-env@sha256:d92eaeed33fa75130ca1ee6c8a01d1ffb62bac859dfdfb3450e3e5d1c0146529" "/opt/rustwide/cargo-home/bin/cargo" "+beta-2020-10-09" "metadata" "--no-deps" "--format-version=1", kill_on_drop: false }`
[INFO] [stdout] 91d7b3932171ba87fe4e77702aee6aa4d7074fe3998ef4479ab49d3460aa2229
[INFO] [stderr] WARNING: Your kernel does not support swap limit capabilities or the cgroup is not mounted. Memory limited without swap.
[INFO] running `Command { std: "docker" "start" "-a" "91d7b3932171ba87fe4e77702aee6aa4d7074fe3998ef4479ab49d3460aa2229", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "inspect" "91d7b3932171ba87fe4e77702aee6aa4d7074fe3998ef4479ab49d3460aa2229", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "91d7b3932171ba87fe4e77702aee6aa4d7074fe3998ef4479ab49d3460aa2229", kill_on_drop: false }`
[INFO] [stdout] 91d7b3932171ba87fe4e77702aee6aa4d7074fe3998ef4479ab49d3460aa2229
[INFO] running `Command { std: "docker" "create" "-v" "/var/lib/crater-agent-workspace/builds/worker-6/target:/opt/rustwide/target:rw,Z" "-v" "/var/lib/crater-agent-workspace/builds/worker-6/source:/opt/rustwide/workdir:ro,Z" "-v" "/var/lib/crater-agent-workspace/cargo-home:/opt/rustwide/cargo-home:ro,Z" "-v" "/var/lib/crater-agent-workspace/rustup-home:/opt/rustwide/rustup-home:ro,Z" "-e" "SOURCE_DIR=/opt/rustwide/workdir" "-e" "CARGO_TARGET_DIR=/opt/rustwide/target" "-e" "CARGO_INCREMENTAL=0" "-e" "RUST_BACKTRACE=full" "-e" "RUSTDOCFLAGS=--cap-lints=warn" "-e" "CARGO_HOME=/opt/rustwide/cargo-home" "-e" "RUSTUP_HOME=/opt/rustwide/rustup-home" "-w" "/opt/rustwide/workdir" "-m" "1610612736" "--user" "0:0" "--network" "none" "rustops/crates-build-env@sha256:d92eaeed33fa75130ca1ee6c8a01d1ffb62bac859dfdfb3450e3e5d1c0146529" "/opt/rustwide/cargo-home/bin/cargo" "+beta-2020-10-09" "doc" "--frozen" "--no-deps" "--document-private-items" "--message-format=json", kill_on_drop: false }`
[INFO] [stdout] 170b742102844901f1e7c374a16daa5978a07abbb4ec8fbbfcdf59186365700b
[INFO] [stderr] WARNING: Your kernel does not support swap limit capabilities or the cgroup is not mounted. Memory limited without swap.
[INFO] running `Command { std: "docker" "start" "-a" "170b742102844901f1e7c374a16daa5978a07abbb4ec8fbbfcdf59186365700b", kill_on_drop: false }`
[INFO] [stderr]    Compiling if_chain v1.0.1
[INFO] [stderr]    Compiling validator_types v0.11.0
[INFO] [stderr]     Checking num-complex v0.2.4
[INFO] [stderr]     Checking num-bigint v0.2.6
[INFO] [stderr]    Compiling proc-macro-error v1.0.4
[INFO] [stderr]     Checking tokio v0.2.22
[INFO] [stderr]     Checking url v2.1.1
[INFO] [stderr]     Checking serde_json v1.0.59
[INFO] [stderr]     Checking chrono v0.4.19
[INFO] [stderr]    Compiling validator_derive v0.11.0
[INFO] [stderr]     Checking num-rational v0.2.4
[INFO] [stderr]     Checking serde_urlencoded v0.6.1
[INFO] [stderr]     Checking num v0.2.1
[INFO] [stderr]     Checking biscuit v0.4.2
[INFO] [stderr]     Checking tokio-util v0.3.1
[INFO] [stderr]     Checking tokio-tls v0.3.1
[INFO] [stderr]     Checking h2 v0.2.6
[INFO] [stderr]     Checking validator v0.11.0
[INFO] [stderr]     Checking hyper v0.13.8
[INFO] [stderr]     Checking hyper-tls v0.4.3
[INFO] [stderr]     Checking reqwest v0.10.8
[INFO] [stderr]  Documenting openid v0.6.0 (/opt/rustwide/workdir)
[INFO] [stdout] warning: unresolved link to `RFC5322`
[INFO] [stdout]   --> src/userinfo.rs:44:86
[INFO] [stdout]    |
[INFO] [stdout] 44 | ...value MUST conform to the RFC 5322 [RFC5322] addr-spec syntax. The RP MUST NOT rely upon this value being unique, as discussed in Sect...
[INFO] [stdout]    |                                        ^^^^^^^ the module `userinfo` contains no item named `RFC5322`
[INFO] [stdout]    |
[INFO] [stdout]    = note: `#[warn(broken_intra_doc_links)]` on by default
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `zoneinfo`
[INFO] [stdout]   --> src/userinfo.rs:58:31
[INFO] [stdout]    |
[INFO] [stdout] 58 |     /// String from zoneinfo [zoneinfo] time zone database representing the End-User's time zone. For example, Europe/Paris or America/Lo...
[INFO] [stdout]    |                               ^^^^^^^^ the module `userinfo` contains no item named `zoneinfo`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5646`
[INFO] [stdout]   --> src/userinfo.rs:63:52
[INFO] [stdout]    |
[INFO] [stdout] 63 |     /// End-User's locale, represented as a BCP47 [RFC5646] language tag. This is typically an ISO 639-1 Alpha-2 [ISO639‑1] language code...
[INFO] [stdout]    |                                                    ^^^^^^^ the module `userinfo` contains no item named `RFC5646`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3966`
[INFO] [stdout]   --> src/userinfo.rs:67:273
[INFO] [stdout]    |
[INFO] [stdout] 67 | ... be represented using the RFC 3966 [RFC3966] extension syntax, for example, +1 (604) 555-1234;ext=5678.
[INFO] [stdout]    |                                        ^^^^^^^ the module `userinfo` contains no item named `RFC3966`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC4627`
[INFO] [stdout]   --> src/userinfo.rs:73:89
[INFO] [stdout]    |
[INFO] [stdout] 73 | ...ue of the address member is a JSON [RFC4627] structure containing some or all of the members defined in Section 5.1.1.
[INFO] [stdout]    |                                        ^^^^^^^ the module `userinfo` contains no item named `RFC4627`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `JWT`
[INFO] [stdout]  --> src/claims.rs:5:375
[INFO] [stdout]   |
[INFO] [stdout] 5 | ...s represented as a JSON Web Token (JWT) [JWT].
[INFO] [stdout]   |                                             ^^^ the module `claims` contains no item named `JWT`
[INFO] [stdout]   |
[INFO] [stdout]   = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC3339`
[INFO] [stdout]   --> src/claims.rs:13:473
[INFO] [stdout]    |
[INFO] [stdout] 13 | ...C until the date/time. See RFC 3339 [RFC3339] for details regarding date/times in general and UTC in particular.
[INFO] [stdout]    |                                         ^^^^^^^ the module `claims` contains no item named `RFC3339`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `ISO29115`
[INFO] [stdout]   --> src/claims.rs:26:309
[INFO] [stdout]    |
[INFO] [stdout] 26 | ... the requirements of ISO/IEC 29115 [ISO29115] level 1. Authentication using a long-lived browser cookie, for instance, is one example ...
[INFO] [stdout]    |                                        ^^^^^^^^ the module `claims` contains no item named `ISO29115`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC6711`
[INFO] [stdout]   --> src/claims.rs:26:664
[INFO] [stdout]    |
[INFO] [stdout] 26 | ... 0.) An absolute URI or an RFC 6711 [RFC6711] registered name SHOULD be used as the acr value; registered names MUST NOT be used with ...
[INFO] [stdout]    |                                         ^^^^^^^ the module `claims` contains no item named `RFC6711`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: unresolved link to `RFC5322`
[INFO] [stdout]   --> src/userinfo.rs:44:86
[INFO] [stdout]    |
[INFO] [stdout] 44 | ...value MUST conform to the RFC 5322 [RFC5322] addr-spec syntax. The RP MUST NOT rely upon this value being unique, as discussed in Sect...
[INFO] [stdout]    |                                        ^^^^^^^ the module `userinfo` contains no item named `RFC5322`
[INFO] [stdout]    |
[INFO] [stdout]    = help: to escape `[` and `]` characters, add '\' before them like `\[` or `\]`
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stdout] warning: 10 warnings emitted
[INFO] [stdout] 
[INFO] [stdout] 
[INFO] [stderr]     Finished dev [unoptimized + debuginfo] target(s) in 36.90s
[INFO] running `Command { std: "docker" "inspect" "170b742102844901f1e7c374a16daa5978a07abbb4ec8fbbfcdf59186365700b", kill_on_drop: false }`
[INFO] running `Command { std: "docker" "rm" "-f" "170b742102844901f1e7c374a16daa5978a07abbb4ec8fbbfcdf59186365700b", kill_on_drop: false }`
[INFO] [stdout] 170b742102844901f1e7c374a16daa5978a07abbb4ec8fbbfcdf59186365700b
